Page MenuHomePhabricator

Sandbox to automatically deal with tokens
Closed, ResolvedPublic

Description

The API Sandbox could provide for an easier way to deal with tokens, either by completely automatizing their request, or by offerin a "click one button" feature next to a token field that retrieves an appropriate token so that the request can be made.


Version: unspecified
Severity: enhancement

Details

Reference
bz36875

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 12:26 AM
bzimport set Reference to bz36875.
bzimport added a subscriber: Unknown Object (MLST).
Denny created this task.May 15 2012, 9:08 PM
  • Bug 54938 has been marked as a duplicate of this bug. ***

(The patch above is abandoned, so I'm unassigning Jon. Bug is free for taking!)

Yes, this would be a great idea IMHO. Thanks.

Change 209570 had a related patch set uploaded (by Anomie):
WIP: Add Special:ApiSandbox

https://gerrit.wikimedia.org/r/209570

Sn1per added a subscriber: Sn1per.Jan 25 2016, 1:44 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 25 2016, 1:44 AM

Change 209570 merged by jenkins-bot:
Add Special:ApiSandbox

https://gerrit.wikimedia.org/r/209570

Sn1per awarded a token.Feb 3 2016, 5:00 PM
Anomie closed this task as Resolved.Feb 3 2016, 5:11 PM
Anomie claimed this task.
Anomie added a subscriber: Anomie.