Page MenuHomePhabricator

Restore functioning of $CHANGEDORCREATED for backward compatibility of outdated enotif_body
Closed, ResolvedPublic

Description

After upgrading to 067fe75c717cc085742a5d20e61c80a4c1b80ca0 E-Notifs show unresolved variable $CHANGEDORCREATED

observed in

Dear (username, correct)

the (pagename, correct) has been $CHANGEDORCREATED on
10 December 2012


Version: 1.21.x
Severity: enhancement
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=42752

Details

Reference
bz42941

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:03 AM
bzimport added a project: MediaWiki-Email.
bzimport set Reference to bz42941.
Wikinaut created this task.Dec 11 2012, 7:43 AM
aaron added a comment.Dec 11 2012, 8:01 AM

Is there a custom message defined in a MediaWiki: page for the affected wiki?

See https://bugzilla.wikimedia.org/show_bug.cgi?id=14901#c70 .

users and admins should be informed in release notes that - if they use customised mail templates for e-mail notification - these templates need to be (most likely) changed.

Closed as resolved invalid by the reporter, because it appears to be a problem of (customised) enotif mail templates (i18n), which have not been adapted.

(I am reporting this early; parts of my observation may be wrong or outdated)

See my https://bugzilla.wikimedia.org/show_bug.cgi?id=42941 "Bug 42941 - Enotifs show unresolved variable $CHANGEDORCREATED (version of 08.12.2012)"

Regarding

which aims to fix this bug,

  • users and admins should be informed in release notes that - if they use customised mail templates for e-mail notification - these templates need to be (most likely) changed

to make them correctly working with the new software.

An indication that a change is needed is for example an unresolved variable $CHANGEDORCREATED in received enotifs.

@aaron: the english message file shows specific messages for page change/creation... actions. Need more time to check the new messages and mechanism.

may be that

"- users and admins should be informed in release notes that - if they use
customised mail templates for e-mail notification - these templates need to be
(most likely) changed"

Perhaps the committer(s) of the patch 494529503b41142d68d52c458a44b82577699785

can better comment than I (at the moment).

@aaron wrote

Is there a custom message defined in a MediaWiki: page for the affected wiki?

I forgot to answer your question:

Yes, I do have a customised enotif_body message in my wiki which uses the (now-removed) $CHANGEDORCREATED .

After deletion of my MediaWiki:enotif_body , it works fine.

Note that bug 42941 is different and happens without custom enotif_body.

A short while ago I added complete docs to [[translatewiki:MediaWiki:Enotif_body/qqq]], it would be nice if you could write a short update on what needs doing, as done with
https://www.mediawiki.org/wiki/MediaWiki_1.21/wmf5#welcomecreation

Then, if someone runs a script like https://www.mediawiki.org/wiki/User:S_Page_%28WMF%29/welcomecreation_messages#Script_to_generate_this , we can also notified the affected wikis.

richardg_uk wrote:

Further to comments at bug 42752:

  • my more recent MediaWiki.org email notifications are now OK again;
  • mybugs.mail@gmail.com has reported the problem with ptwikibooks, presumably caused by the 1.21wmf6 phase 2 rollout a few hours ago.

Should this bug be reopened?

(In reply to comment #9)

Should this bug be reopened?

in my view: not. It works on my large scale wikis.

richardg_uk wrote:

(In reply to comment #10)

(In reply to comment #9)

Should this bug be reopened?

in my view: not. It works on my large scale wikis.

But apparently fails in a transitional period for WMF wikis, as evidenced by MediaWiki wiki and now by ptwikibooks.

By the way yesterday I notified 42 (!) wikis which had a custom enotif_body so that they delete (or update) it, which means they'll run into bug 42752 instead but eventually (...) be ok.

bsitu wrote:

I will add "$CHANGEDORCREATED" replacement back to the script so wikis with old custom enotif_body will still work.

bsitu wrote:

submitted a patch in here: https://gerrit.wikimedia.org/r/#/c/39179/, hopefully this would resolve the problem

(In reply to comment #14)

submitted a patch in here: https://gerrit.wikimedia.org/r/#/c/39179/,
hopefully
this would resolve the problem

Thanks, adjusting summary and resolution accordingly.

People kept cluttering bug 42752 with reports of this bug but they really are two different things, so I'm leaving this open until the change is merged/deployed so that is shows up in searches.

Just my comment:

I originally designed enotif, I have nothing against a convenience/compatibility patch regarding this variable "$CHANGEDORCREATED".

On the other I wondering if the patch is really needed, because it creates a legacy and an overhead which is not needed, because we now have these distinct messages (which are much better: they can be better localised).

richardg_uk wrote:

Just received this email notification from idwiki (running 1.21wmf6):

Halo Richardguk,
Halaman Pembicaraan Pengguna:Richardguk di Wikipedia telah
$CHANGEDORCREATED pada 2013-01-06 oleh LaninBot, lihat
http://id.wikipedia.org/wiki/Pembicaraan_Pengguna:Richardguk
untuk revisi terakhir.
...

Looks like the patch in comment #14 is still awaiting review.

Patch is merged (or will be soon). This BC feature is scheduled for removal in MediaWiki 1.23 now.