Page MenuHomePhabricator

Links in block reason on [[Special:CentralAuth]] link to the local wiki, not the one the block was issued on
Closed, ResolvedPublic

Description

Basically when blocking a user with something like "{{blocktemplate}} [[Article]]", and then looking at [[Special:CentralAuth/Username]] on a different wiki, the links in the block log point to local targets rather than pointing to the wiki the block was issued on.

This can be seen at https://www.wikidata.org/w/index.php?title=Special%3ACentralAuth&target=Legosock where I blocked my alt. account on testwiki.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=45629

Details

Reference
bz45412
Related Gerrit Patches:
mediawiki/extensions/CentralAuth : masterCorrectly parse links in block reasons on SpecialCentralAuth

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 1:25 AM
bzimport set Reference to bz45412.
bzimport added a subscriber: Unknown Object (MLST).
Legoktm created this task.Feb 26 2013, 5:24 AM
  • Bug 61916 has been marked as a duplicate of this bug. ***

From bug 61916:

On
https://commons.wikimedia.org/wiki/Special:CentralAuth/Suporte_Acad%C3%AAmico
there is a table cell like this:
<td>Blocked indefinitely.
Reason: Conta de <a href="/w/index.php?title=WP:CPU&amp;action=edit&amp;redlink=1" class="new" title="WP:CPU (page does not exist)">propósito único</a></td>

The link should point to the Portuguese Wikipedia, as in e.g.:
<td>Blocked indefinitely.
Reason: Conta de <a href="//pt.wikipedia.org/wiki/WP:CPU" title="WP:CPU">propósito único</a></td>

If possible, the link should also use the namespace alias and add the "mw-redirect" class whenever that is appropriated, since on
https://pt.wikipedia.org/wiki/Special:Log?page=User%3ASuporte_Acadêmico&uselang=en
the link is like this:

<a href="/wiki/Wikip%C3%A9dia:CPU" class="mw-redirect" title="Wikipédia:CPU">propósito único</a>

Elitre added a subscriber: Elitre.Dec 22 2014, 3:07 PM

Change 182468 had a related patch set uploaded (by Hoo man):
Correctly parse links in block reasons on SpecialCentralAuth

https://gerrit.wikimedia.org/r/182468

Patch-For-Review

Teles added a subscriber: Teles.Jan 3 2015, 12:10 AM

Change 182468 merged by jenkins-bot:
Correctly parse links in block reasons on SpecialCentralAuth

https://gerrit.wikimedia.org/r/182468

hoo closed this task as Resolved.Jan 9 2015, 7:38 PM
hoo claimed this task.