PostEdit: Core-ify this
Closed, ResolvedPublic

Description

As discussed with Steven W. just now, we should move this into MW core (so, amongst other things, VisualEditor can depend on it and not have to re-invent the wheel).


Version: master
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=16066

Related URL: https://gerrit.wikimedia.org/r/66137 (Gerrit Change I01cfc0630c3a505af82922844b5e70c1d61f3c1d)

(In reply to comment #0)

As discussed with Steven W. just now, we should move this into MW core (so,
amongst other things, VisualEditor can depend on it and not have to re-invent
the wheel).

I should note that one extension depending on another is *not* a legitimate reason for moving the dependency into the core. That said, I still agree with the merging of this extension since it's a trivial feature.

ori added a comment.May 30 2013, 7:18 PM

(In reply to comment #2)

I should note that one extension depending on another is *not* a legitimate
reason for moving the dependency into the core. That said, I still agree with
the merging of this extension since it's a trivial feature.

Yes, I agree completely. There had already been wide agreement that this should be moved into core; the VisualEditor requirement is just a spur.

Just for posterity, I'm noting bug 16066 here.

ori added a comment.Jun 1 2013, 1:25 AM

(In reply to comment #1)

Related URL: https://gerrit.wikimedia.org/r/66137 (Gerrit Change
I01cfc0630c3a505af82922844b5e70c1d61f3c1d)

Merged.

Related URL: https://gerrit.wikimedia.org/r/66316 (Gerrit Change I01cfc0630c3a505af82922844b5e70c1d61f3c1d)

That's a cherry-pick back to wmf5, so no wikis that currently have PostEdit will lose it when we disable the extension.

Add Comment