Page MenuHomePhabricator

Previews with references show ugly error message
Closed, ResolvedPublic

Description

Due to bug 49217 when trying to preview content with a reference we get a nasty error rendered in the response.

We may have to workaround yet another API bug here as I suspect bug 49217 will be RESOLVED WONTFIX as is usually the case when I raise bugs for the API.

To replicate click edit
Replace textarea content with
<ref>[http://www.priberam.pt/DLPO/default.aspx?pal=saudade Dicionário Priberam da Língua Portuguesa]</ref>
and hit preview.


Version: unspecified
Severity: normal

Details

Reference
bz49218

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 1:53 AM
bzimport added a project: MobileFrontend-beta.
bzimport set Reference to bz49218.

Isn't this a classic case of garbage in, garbage out?

Can you describe what behavior you'd expect here? Your input is invalid. What would you like the response to be? Failing silently is surely worse than failing loudly, which is the current behavior.

It means you cannot do section level previews. I would expect the tag to be ignored in the output HTML but flagged as a warning in the API response. Why shouldn't I be able to render the reference with a 'broken' anchor tag?

This is basically a duplicate of bug 5984.

As suspected bug closed WONTFIX. \o/ to another API hacky workaround coming to you soon.

MaxSem added a comment.Jun 6 2013, 9:57 AM

See bug 49239 for proper solution.

Turns out the API fix broke other things...

Related URL: https://gerrit.wikimedia.org/r/68046 (Gerrit Change Ieaa684b03ce57b2e9e64e4e18eb5ee48606cab5b)

https://gerrit.wikimedia.org/r/68046 (Gerrit Change Ieaa684b03ce57b2e9e64e4e18eb5ee48606cab5b) | change APPROVED and MERGED [by jenkins-bot]

Related URL: https://gerrit.wikimedia.org/r/68575 (Gerrit Change I261faade919608dab1f213f771dd9d7bc666deb6)

https://gerrit.wikimedia.org/r/68575 (Gerrit Change I261faade919608dab1f213f771dd9d7bc666deb6) | change APPROVED and MERGED [by jenkins-bot]