VisualEditor: Saving fails silently when the database is locked
Closed, ResolvedPublic

Description

Author: kwang

Description:
This shows the article and the visual editor save dialog

I added a link to a new page but it wouldn't let me save my edit. Every time I saved it would load but then display the save page dialog again.

I ended up creating the link in the source.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=53093

Attached:

bzimport set Reference to bz51636.
bzimport created this task.Via LegacyJul 18 2013, 8:38 PM
bzimport added a comment.Via ConduitJul 18 2013, 8:39 PM

kwang wrote:

More details: when I edited the source it said that the database was locked. This is likely the issue that was happening, but the error wasn't showing up in the visual editor.

bzimport added a comment.Via ConduitJul 18 2013, 8:40 PM

kwang wrote:

error while editing source code.

Attached:

Thryduulf added a comment.Via ConduitJul 18 2013, 9:23 PM

Two other users have reported the same thing on en.wikipedia, so the cause was the database being locked.

Could be related to Bug 50472 which is marked as fixed but has apparently not yet been deployed?

gerritbot added a comment.Via ConduitJul 24 2013, 9:33 AM

Change 75561 had a related patch set uploaded by Esanders:
Show when trying to save in read-only mode

https://gerrit.wikimedia.org/r/75561

gerritbot added a comment.Via ConduitJul 24 2013, 2:35 PM

Change 75561 merged by jenkins-bot:
Show error when trying to save in read-only mode

https://gerrit.wikimedia.org/r/75561

Jdforrester-WMF added a comment.Via ConduitJul 24 2013, 2:40 PM

Fixed and will get deployed in a few minutes' time.

Add Comment