Page MenuHomePhabricator

wgUserNewMsgRevisionId null when user talk page has only one revision
Open, HighPublic

Description

wgUserNewMsgRevisionId is apparently null when user talk page has only one revision, even if the user hasn't viewed it yet.

May be caused by Notifications interfering with something (I only tested on test.wp); certainly matters for it, though, as this causes the orange alert not to appear for new users ([[File:Echo Notifications new message indicator.png|this one]]). Therefore marking as 'major'.

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:47 AM
bzimport set Reference to bz51640.
bzimport added a subscriber: Unknown Object (MLST).
matmarex created this task.Jul 18 2013, 9:23 PM

Confirmed in master branch.

[23:39] <kaldari> looks like $user->getNewMessageRevisionId() is returning null even after the first post for some reason.

Change 74547 had a related patch set uploaded by Kaldari:
Making sure wgUserNewMsgRevisionId works even for the first post

https://gerrit.wikimedia.org/r/74547

Change 74547 abandoned by Kaldari:
Making sure wgUserNewMsgRevisionId works even for the first post

Reason:
wrong approach

https://gerrit.wikimedia.org/r/74547

Change 74666 had a related patch set uploaded by Bsitu:
(bug 51640) wgUserNewMsgRevisionId is null with only one rev

https://gerrit.wikimedia.org/r/74666

Change 74666 merged by jenkins-bot:
(bug 51640) wgUserNewMsgRevisionId is null with only one rev

https://gerrit.wikimedia.org/r/74666

Change 76824 had a related patch set uploaded by Bsitu:
Revert "(bug 51640) wgUserNewMsgRevisionId is null with only one rev"

https://gerrit.wikimedia.org/r/76824

Change 76824 merged by jenkins-bot:
Revert "(bug 51640) wgUserNewMsgRevisionId is null with only one rev"

https://gerrit.wikimedia.org/r/76824

All patches got merged - can this bug report be closed as RESOLVED FIXED or is more work required?

The patch was merged, but then reverted.

Echo's alert bar now doesn't require JavaScript, let's try doing this once again.

Looks like this might not be needed anymore. Tagging for next quarter to investigate more closely and maybe remove.

While it was intended for internal use by a feature that no longer exists, usage has crept into about 50-100 user scripts and I couldn't identify off-hand an easy way to migrate those use cases.

I'm taking this off the T233676 goal for now as it's pretty minimal by itself and also limited to logged-in users. Reducing the size of the <head> is still a priority, but this will take more effort that I can spend better on other ways to reduce the <head> size. Will leave this open to be revisited at a later time perhaps.

Krinkle updated the task description. (Show Details)
Krinkle moved this task from Limbo to Perf recommendation on the Performance-Team (Radar) board.
Krinkle removed a subscriber: wikibugs-l-list.

Change 579658 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/core@master] OutputPage: Only export wgUserNewMsgRevisionId if non-null

https://gerrit.wikimedia.org/r/579658

Change 579658 merged by jenkins-bot:
[mediawiki/core@master] OutputPage: Only export wgUserNewMsgRevisionId if non-null

https://gerrit.wikimedia.org/r/579658