Page MenuHomePhabricator

IP addresses should link to Special:Contributions instead of userpage, e.g. on revert notification
Closed, ResolvedPublic

Description

EDIT: There is no longer a link to the user in the flyout, but it still applies on Special:Notifications.


In Notifications, can we link IPs to their special:contributions page, instead of their userpage?

eg. We currently have:
Your edit on [[Mike Patton]] has been reverted by [[User:124.181.111.127|124.181.111.127]]. (Show changes)

we want:
Your edit on [[Mike Patton]] has been reverted by [[Special:Contributions/124.181.111.127|124.181.111.127]]. (Show changes)

This would be consistent with the way IPs are linked in all History pages, eg https://en.wikipedia.org/w/index.php?title=Mike_Patton&action=history

See Also:
T55174: All Echo notifications mentioning the acting user ("agent") should have his nick linked to his user page

Details

Reference
bz53564
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:04 AM
bzimport added a project: Notifications.
bzimport set Reference to bz53564.
bzimport added a subscriber: Unknown Object (MLST).
Quiddity created this task.Aug 29 2013, 9:11 PM

Prioritization and scheduling of this bug is tracked on Mingle card https://mingle.corp.wikimedia.org/projects/flow/cards/239

'notification-reverted2' => 'Your {{PLURAL:$4|edit on [[:$2]] has|edits on [[:$2]] have}} been {{GENDER:$1|reverted}} by [[User:$1|$1]]. $3',

The solution here would probably to just use $1, and have echo figure out whether to make a link to the user page or contributions page, and send that as a parameter.

  • Bug 70116 has been marked as a duplicate of this bug. ***
matthiasmullie triaged this task as Normal priority.Dec 11 2014, 11:27 AM
matthiasmullie set Security to None.
Tinaj1234 removed Tinaj1234 as the assignee of this task.Apr 2 2015, 7:21 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 13 2015, 7:41 PM

Wow, i have been researching a little about this bug. Is it still there or has it been fixed. I think i can challenge myself to fix this bug. I understand that to do hear. But if i have any questions as regards the bug, i will ask.

It's still open. If you have questions, you can ask in #wikimedia-collaboration.

Mattflaschen-WMF renamed this task from IP addresses should link to Special:Contributions instead of userpage to IP addresses should link to Special:Contributions instead of userpage, e.g. on revert notification.Sep 17 2015, 11:16 PM

Change 239301 had a related patch set uploaded (by Mattflaschen):
IP addresses should link to Special:Contributions instead of userpage

https://gerrit.wikimedia.org/r/239301

Change 239301 had a related patch set uploaded (by D3r1ck01):
IP addresses should link to Special:Contributions instead of userpage e.g. revert change

https://gerrit.wikimedia.org/r/239301

Change 239301 abandoned by D3r1ck01:
IP addresses should link to Special:Contributions instead of userpage e.g. revert change

Reason:
Redone

https://gerrit.wikimedia.org/r/239301

Change 239301 restored by Mattflaschen:
IP addresses should link to Special:Contributions instead of userpage e.g. revert change

Reason:
No need to make a new change. Just amend this one.

https://gerrit.wikimedia.org/r/239301

From the last patch set i have submitted, it fixes the Bug. Thanks to Mattflaschen and EBernhardson for their contributions. They really helped me. Finally the bug is fixed.

matej_suchanek updated the task description. (Show Details)

Change 239301 merged by jenkins-bot:
IP addresses should link to Special:Contributions instead of user page for revert

https://gerrit.wikimedia.org/r/239301

Checked in betalabs - reverts made by IP users have a link to Special:Contributions:

<div class="mw-echo-title">Your edit on <a href="/wiki/User_talk:Etonkovidova"
title="User talk:Etonkovidova">User talk:Etonkovidova</a> has been reverted by
<a href="/wiki/Special:Contributions/xx.x.xxx.xxx" title="Special:Contributions/xx.x.xxx.xxx"></a>. <a href="/w/index.php?title=User_talk:Etonkovidova&amp;oldid=2427&amp;diff=prev" title="User talk:Etonkovidova" class="mw-echo-diff">(Show changes)</a></div>
DannyH closed this task as Resolved.Sep 24 2015, 5:18 PM
DannyH added a subscriber: DannyH.
Restricted Application added a project: Growth-Team. · View Herald TranscriptNov 7 2018, 10:27 AM