Page MenuHomePhabricator

Collapsible lists on edit page footer no longer collapsible after live preview is used
Closed, ResolvedPublic

Description

Collapsible lists on edit page footer are no longer collapsible after live preview is used. The collapsibleness from mediawiki.action.edit.collapsibleFooter.js has to be reapplied.

(The wikipage.content hook can't really be used because this is not really content, we'll need a new one.)


Version: 1.22.0
Severity: normal

Details

Reference
bz53918

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:01 AM
bzimport added a project: MediaWiki-JavaScript.
bzimport set Reference to bz53918.
bzimport added a subscriber: Unknown Object (MLST).
matmarex created this task.Sep 8 2013, 4:23 PM

Change 99714 had a related patch set uploaded by Bartosz Dziewoński:
Update collapsible lists below edit form on live preview via mw.hook

https://gerrit.wikimedia.org/r/99714

Change 99714 abandoned by Bartosz Dziewoński:
Update collapsible lists below edit form on live preview via mw.hook

Reason:
Hmm actually, I'm not sure what I was thinking with this. Seems like a bad idea in retrospect.

https://gerrit.wikimedia.org/r/99714

  • Bug 70110 has been marked as a duplicate of this bug. ***
TheDJ added a subscriber: TheDJ.Jan 5 2015, 2:12 PM

This is one more of those UI elements that we should get implemented using PHP/JS templates etc, to make it consistent. We better focus on something like that, otherwise you just keep reimplementing stuff.

Change 200750 had a related patch set uploaded (by TheDJ):
Introduce wikipage.editform hook

https://gerrit.wikimedia.org/r/200750

Change 200750 merged by jenkins-bot:
Introduce wikipage.editform hook

https://gerrit.wikimedia.org/r/200750

TheDJ closed this task as Resolved.May 25 2015, 8:35 AM
TheDJ claimed this task.
TheDJ removed a project: Patch-For-Review.
TheDJ set Security to None.
TheDJ removed a subscriber: Unknown Object (MLST).