Page MenuHomePhabricator

Donate via PayPal from [[wmf:Ways to Give]] says "Please correct the errors in your donation amount"
Closed, ResolvedPublic0 Story Points

Description

Repro:

  1. Go to https://wikimediafoundation.org/wiki/Ways_to_Give
  2. Click "U.S. dollar (USD)" in PayPal section

Actual:

  1. It says "Please correct the errors in your donation amount" in the next page

Expected:

  1. "Please enter your donation amount" or nothing at all. Actually the donor did nothing wrong.

Version: unspecified
Severity: normal

Details

Reference
bz56657

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz56657.
bzimport added a subscriber: Unknown Object (MLST).
liangent created this task.Nov 6 2013, 5:24 AM

Change 141826 had a related patch set uploaded by Ejegg:
Show friendlier error message for zero donation amount

https://gerrit.wikimedia.org/r/141826

Change 141826 merged by Awight:
Show friendlier error message for zero donation amount

https://gerrit.wikimedia.org/r/141826

Change 142890 had a related patch set uploaded by Awight:
Show friendlier error message for zero donation amount

https://gerrit.wikimedia.org/r/142890

Change 142890 merged by jenkins-bot:
Show friendlier error message for zero donation amount

https://gerrit.wikimedia.org/r/142890

Pcoombe reopened this task as Open.Mar 26 2015, 6:19 PM

Re-opening, this is happening again. Not sure if it's due to the DonationInterface refactor a few weeks ago, or the subsequent changes to fix T92705.

Pcoombe set Security to None.

I think this regressed a while ago, actually, when I did some DataValidator cleanup. Looks like commit a24f68fb385a0e76fd1b478a61c4b06cd8edfe9c, 29 Jan 2015.

Change 200031 had a related patch set uploaded (by Awight):
Fix regression with zero-amount error

https://gerrit.wikimedia.org/r/200031

awight edited a custom field.
awight moved this task from Backlog to Review on the Fundraising Sprint Grandmaster Flash board.
atgo edited a custom field.Mar 26 2015, 9:40 PM
atgo assigned this task to awight.

Change 200031 merged by jenkins-bot:
Fix regression with zero-amount error

https://gerrit.wikimedia.org/r/200031

Pcoombe closed this task as Resolved.Mar 27 2015, 12:23 PM

Great, it's working for me now. Thanks @awight!

mmodell removed a subscriber: awight.Jun 22 2017, 9:52 PM