Page MenuHomePhabricator

VisualEditor: Pasting a template throws undefined getModel error
Closed, ResolvedPublic0 Story Points

Description

[Error] TypeError: 'undefined' is not an object (evaluating '$node.data('view').getModel')
getOffsetFromTextNode (load.php, line 244)
getOffset (load.php, line 244)
getRange (load.php, line 248)
pollOnceInternal (load.php, line 319)
pollOnce (load.php, line 319)
documentOnBlur (load.php, line 287)
proxy (load.php, line 10)
focus
afterPaste (load.php, line 299)
(anonymous function) (load.php, line 294)
proxy (load.php, line 10)


Version: unspecified
Severity: normal

Details

Reference
bz58383

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:16 AM
bzimport set Reference to bz58383.
TheDJ created this task.Dec 12 2013, 10:05 AM

I have trouble reproducing this one, but I think it sometimes happens if you delete something in a surface and then try to copy something else in that surface. Or if you select a block in the destination and then do a paste replace.

Safari 7

I can't reproduce this now (Mac OS X 10.9 / Safari 7.0.2) – can you, or should we mark as WORKSFORME?

TheDJ added a comment.Feb 19 2015, 8:31 PM

I haven't seen this problem for a long time, so we should probably close it.

Does this bug mean "you can copy stuff, but nothing happens when you try to paste it"?

Jdforrester-WMF closed this task as Resolved.Aug 11 2015, 7:25 PM
Jdforrester-WMF claimed this task.