Page MenuHomePhabricator

VisualEditor: Add a shortcut for strikethrough (?which?)
Closed, ResolvedPublic

Description

Daniel on Mediawiki.org says they use strikethrough a lot and would like a shortcut for it.

Details

Reference
bz60257

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:08 AM
bzimport set Reference to bz60257.
Elitre created this task.Jan 20 2014, 3:27 PM

Sure. But what short-cut? Remember that it needs to:

  • not clash with
    • any existing VE shortcut,
    • any expected VE shortcut for future uses (e.g. edit image/template/table), or
    • any OS or browser shortcut (e.g. Ctrl+C for copy, Cmd+Q for quit);
  • be available on most users' keyboards;
  • be type-able; and
  • ideally be the "standard" shortcut.

This doesn't leave many options. :-(

I added your comment to Mediawiki.org.
I think I noticed that the numbers 8 and 9 are still available?
Or at least this is what I read in the new keyboard shortcuts list.
(Which, BTW, is not available for me by its shortcut, since / is located on the numeric pad or above number 7, thus won't work).

Change 160174 had a related patch set uploaded by Jforrester:
Add keyboard shortcuts for strikethrough and code annotations

https://gerrit.wikimedia.org/r/160174

Change 160174 merged by jenkins-bot:
Add keyboard shortcuts for strikethrough and code annotations

https://gerrit.wikimedia.org/r/160174

We need to change the shortcut key for code annotation on mac from "cmd+shift+3".Because,its a shortcut to take screenshot so it does not work there.

Verified the fix in Betalabs and test2

Verified the fix in production

@Jdforrester-WMF Since macOS Mojave, Shift-Command-5 is now used for an additional screenshot option, which conflicts with strikethrough. Is it possible to reconfigure? https://support.apple.com/en-us/HT201236

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptNov 26 2018, 2:14 PM
Elitre reopened this task as Stalled.Nov 28 2018, 2:31 PM
Esanders added a subscriber: Esanders.EditedApr 28 2019, 5:29 PM

Google Docs uses Cmd+Shift+X on OSX (as opposed to +5): https://support.google.com/docs/answer/179738?co=GENIE.Platform%3DDesktop&hl=en

Happy to switch to this...

Unfortunately VE uses Cmd+Shift+X for "Change directionality"...

Jdforrester-WMF removed Jdforrester-WMF as the assignee of this task.Jan 15 2020, 6:28 PM

I'm not currently working on this.

Krinkle updated the task description. (Show Details)Jan 15 2020, 6:38 PM
Krinkle removed a subscriber: Krinkle.
Krinkle closed this task as Resolved.Jan 15 2020, 6:42 PM

Re-confirmed in production. It's availabe in the formatting menu, and the indicated shortcut works as expected (Note: on macOS, you may have to use fn+shift+cmd+5 instead of shift+cmd+5 given the latter is by default used by the system's screengrab utility).