Re-consider font size and font-family for form elements in Vector
Closed, InvalidPublic

Description

screenshot using firefox on windows showing upload wizard form inputs with font-sizes annotated

Currently, Upload Wizard defines font-family: sans-serif for most of its form elements. After the "typographical refresh", this, together with the slightly smaller font-family, produces a misaligned output.

https://commons.wikimedia.org/w/index.php?title=Commons%3AVillage_pump&diff=120509714&oldid=120505191


Attached:

bzimport set Reference to bz63408.
bzimport added a subscriber: Unknown Object (MLST).
Rillke created this task.Apr 2 2014, 11:19 AM

Created attachment 15004
more drastically on ff/linux

Attached:

Thanks for taking the time to report this!

How does this create an accessibility problem (anybody could increase the font size in th browser)?

(In reply to Andre Klapper from comment #2)

anybody could increase the font size in th browser

The aim of the "typographical refresh" refresh update was I think to not have people to fiddle around with their browser settings.

Rillke added a comment.Apr 2 2014, 7:16 PM

yeah, form elements do not inherit font family from their offset parents, so you may start a separate bug for this, as if you like to add something similar to

input,select,textarea { font-family:inherit; font-size:inherit; }

but note that UpWiz explicitly defines sans-serif for some classes used on input elements in it.

It is fiexed now? It looks like no?
@Rillke: I guess we can fix this in the global .ccs?

Rillke added a comment.Apr 4 2014, 8:14 PM

(In reply to Steinsplitter from comment #5)
Why is this a major issue? The text is still readable by most people. Or does it even look worse for you than the screenshots I attached?

Yes, we could attempt to "fix" it but applying extra-css often causes many side effects and I'd really like to see it fixed by someone running browser tests before or having a very good understanding of what could happen. Leaving the side effects aside, there is still the maintenance issue. The code we have must be probably be updated if the TypoRefresh updates. No, please let users complain and nag here instead.

Sounds like the fix for this is removing extra overrides from this form.

Krinkle edited the task description. (Show Details)Jan 5 2015, 2:12 AM
Krinkle added a project: Vector.
Krinkle set Security to None.
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:36 PM
Restricted Application added a subscriber: Matanya. · View Herald TranscriptSep 4 2015, 6:36 PM
MarkTraceur closed this task as "Invalid".Dec 3 2015, 4:51 PM
MarkTraceur claimed this task.

I'm going to close this because the issue is no longer the same, since we shifted to OOUI for all of our text fields. If you still don't like the forms for whatever reason, file another bug explaining why with the new design. Thanks!

Add Comment