Interwiki prefix c: should be available as a shortcut for commons:
Closed, ResolvedPublic

Description

Author: le.korrigan

Description:
Currently the interwiki prefix for Wikimedia COmmons is "commons:" ; It could be
abbreviated to "c:" just like "m:" is the short for "meta:". As far as I see
this prefix is not used by anything so far.


Version: unspecified
Severity: enhancement
URL: https://meta.wikimedia.org/wiki/Requests_for_comment/Wikimedia_Commons

bzimport set Reference to bz4676.
bzimport created this task.Via LegacyJan 19 2006, 11:34 PM
bzimport added a comment.Via ConduitNov 18 2006, 9:45 PM

nilfanion wrote:

This would be appreciated and (probably) isn't that hard to implement? Seeing as
Commons is now one of the biggest WMF wikis, I think commons would like to claim
c: before another project does.

bzimport added a comment.Via ConduitMay 22 2007, 4:52 PM

river wrote:

you can edit the interwiki map at [[m:Interwiki map]]. i added c: for you.

bzimport added a comment.Via ConduitMay 22 2007, 4:58 PM

river wrote:

had to revert this, it conflicts with existing articles.

Mattflaschen added a comment.Via ConduitMay 27 2008, 12:40 AM

Can you clarify this? Which existing articles were a problem, on which wiki(s)?

bzimport added a comment.Via ConduitMay 27 2008, 12:43 AM

ayg wrote:

See for instance:

http://en.wikipedia.org/wiki/Special:PrefixIndex/C:

Couldn't find any other wikis with a quick glance.

bzimport added a comment.Via ConduitJun 6 2008, 8:39 PM

dotkorg wrote:

There should be a way to bypass an interwiki redirect when needed; see bug 14448.

IAlex added a comment.Via ConduitApr 4 2009, 9:46 AM
  • Bug 18336 has been marked as a duplicate of this bug. ***
bzimport added a comment.Via ConduitJan 4 2012, 6:54 PM

Tiptoety wrote:

Would it be possible to revisit this issue. There is consensus for this change per http://meta.wikimedia.org/wiki/Requests_for_comment/Wikimedia_Commons

bzimport added a comment.Via ConduitJan 5 2012, 10:06 AM

kontakt-bugzilla-wikimedia-org-22.07.2011 wrote:

(In reply to comment #5)

See for instance:

http://en.wikipedia.org/wiki/Special:PrefixIndex/C:

Couldn't find any other wikis with a quick glance.

Special:PrefixIndex doesn't work with a ":" in the prefix!

Logan added a comment.Via ConduitJan 8 2012, 11:15 PM

(In reply to comment #9)

(In reply to comment #5)
> See for instance:
>
> http://en.wikipedia.org/wiki/Special:PrefixIndex/C:
>
> Couldn't find any other wikis with a quick glance.

Special:PrefixIndex doesn't work with a ":" in the prefix!

It does...Bugzilla just didn't link it properly. Copy the whole link, and it shows you every page/redirect that starts with "C:".

Peachey88 added a comment.Via ConduitJan 8 2012, 11:18 PM

(In reply to comment #8)

Would it be possible to revisit this issue. There is consensus for this change
per http://meta.wikimedia.org/wiki/Requests_for_comment/Wikimedia_Commons

Single letter interwikis are bad, also where was this RfC advertised?

bzimport added a comment.Via ConduitJan 14 2012, 10:38 PM

kontakt-bugzilla-wikimedia-org-22.07.2011 wrote:

(In reply to comment #11)

Single letter interwikis are bad, also where was this RfC advertised?

We already have "m:" for meta, "s:" for wikisource, "b:" for wikibooks, "n:" for wikinews, "v:" for wikiversity, "w:" for wikipedia.

So why are single letter interwikis bad?!?

Peachey88 added a comment.Via ConduitJan 14 2012, 11:14 PM

(In reply to comment #13)

(In reply to comment #11)
>
> Single letter interwikis are bad, also where was this RfC advertised?

We already have "m:" for meta, "s:" for wikisource, "b:" for wikibooks, "n:"
for wikinews, "v:" for wikiversity, "w:" for wikipedia.

So why are single letter interwikis bad?!?

Just because we have something currently, Doesn't make it good. That is kinda like saying Windows NT4 was a good server environment, We should still be using it!

It can and does break page titles on any language that uses a latin alphabet (eg: English Wikipedia), I know this has caused issues with Q: (wikiquote) before and as pointed out previously in the comments regarding this request C: already has articles on en.wikipedia which it would conflict with.

MZMcBride added a comment.Via ConduitJun 28 2013, 3:56 AM

Re-opening this request.

It defies user expectations to not have c: work for Commons, as m: works for Meta-Wiki, d: works for Wikidata, etc.

Looking at [[Special:PrefixIndex/C:]], there are only two non-redirects where there would be a conflict on the English Wikipedia. I imagine there are fewer conflicts on most of the other wikis.

This doesn't seem like a wontfix situation. This can be implemented, it just requires first moving all of the conflicting page titles on the affected wikis (i.e., all Wikimedia wikis) to slightly different titles and updating any links to those pages.

jayvdb added a comment.Via ConduitNov 16 2013, 10:38 AM

On the RFC it was noted that hiwiki uses 'C' as a namespace alias for 'Category', and 'CT' for Category talk, and Mayur indicated that he didnt think the Hindi community would mind if this alias was changed to point to Commons. Is there a way to see how many times Hindi Wikipedia has used this alias. I expect the Hindi Wikipedia community will need to discuss and request a configuration change.

Withoutaname added a comment.Via ConduitJan 31 2014, 12:58 AM

That RFC probably needs to be reopened; 23 editors should not decide the fate of the Wikimedia Community, which Hindi Wikipedia is a large player of, before requesting such a change. Vandenberg, can you contact the Hindi Wikipedia community and engage in dialogue with them about what this change means towards their naming conventions? I'm not sure about the other Wikipedias, but the fact that Hindi Wikipedia uses C as namespace alias [[hi:विशेष:उपसर्ग_अनुसार_पृष्ठ/C:]] means we need their participation and engagement before moving on with this request.

Aklapper added a comment.Via ConduitJan 31 2014, 12:08 PM

In my humble opinion, large players should comment on RFCs while they are open.

jayvdb added a comment.Via ConduitFeb 2 2014, 7:37 AM

A dump scan shows that it is not currently in use _on_ hiwiki, and was only used twice by Mayur historically.

https://meta.wikimedia.org/wiki/User_talk:Mayur#C_alias_on_hiwiki

I also couldnt find any hits on it from a very small sample of the raw pagecounts.

grep -i '^hi c:' pagecounts-20140121-120000

bzimport added a comment.Via ConduitFeb 10 2014, 6:51 AM

philippe wrote:

@Andre - I would agree, except - per Comment 12: "It was advertised at the English Wikipedia Village pump:
http://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28miscellaneous%29/Archive_35#commons_interwiki"

How would the Hindi community know about it then?

Aklapper added a comment.Via ConduitFeb 10 2014, 12:34 PM

ARgh, good point. Sorry, I missed that.

gerritbot added a comment.Via ConduitFeb 12 2014, 6:34 PM

Change 112920 had a related patch set uploaded by Gerrit Patch Uploader:
Add c: as Commons interwiki prefix

https://gerrit.wikimedia.org/r/112920

PiRSquared17 added a comment.Via ConduitFeb 12 2014, 6:38 PM

Don't merge yet.

Withoutaname added a comment.Via ConduitFeb 14 2014, 2:36 AM

Added: depends on [[bugzilla:29940]]; removal of C prefix from hiwiki in that bug ticket necessary for resolving this issue. Do continue to review the proposed patch changes however.

jayvdb added a comment.Via ConduitFeb 14 2014, 1:57 PM

Changing bug title, as the Hindi community has not adopted this, per my comment 19. However bug 29940 does include a link with a consensus of the Hindi community to add them.

TeleComNasSprVen has raised the issue with hi.wp here:

https://hi.wikipedia.org/s/1wt8#Requests_for_comment.2FWikimedia_Commons

PiRSquared17 added a comment.Via ConduitFeb 14 2014, 7:48 PM

(In reply to John Mark Vandenberg from comment #25)

Changing bug title, as the Hindi community has not adopted this, per my
comment 19. However bug 29940 does include a link with a consensus of the
Hindi community to add them.

TeleComNasSprVen has raised the issue with hi.wp here:

https://hi.wikipedia.org/s/1wt8#Requests_for_comment.2FWikimedia_Commons

Which bug is for removal of the hi: interwiki? Bug 29940 is already RESOLVED FIXED, should it be REOPENED or so?

jayvdb added a comment.Via ConduitFeb 15 2014, 7:05 AM

Lets give hiwp community members a few days to respond on their WP:AN, then create a new bug to change their config and notify them again of the pending change, and wait for feedback again. Maybe we can find a hiwp community member to help with comms. A tech newsletter translator?

bzimport added a comment.Via ConduitFeb 16 2014, 7:14 AM

philippe wrote:

Adding Jan Eissfeldt from my team in hopes that he can find us a hi community member to help.

bzimport added a comment.Via ConduitFeb 16 2014, 7:19 AM

mayurdce wrote:

(In reply to John Mark Vandenberg from comment #27)

Lets give hiwp community members a few days to respond on their WP:AN, then
create a new bug to change their config and notify them again of the pending
change, and wait for feedback again. Maybe we can find a hiwp community
member to help with comms. A tech newsletter translator?

I have told earlier when it was asked that C: prefix can be used for commons as it is not as much used in hindi wikipedia. Intead a prefix Cat: can be used. Regards

MZMcBride added a comment.Via ConduitFeb 16 2014, 7:45 AM

(In reply to John Mark Vandenberg from comment #19)

A dump scan shows that it is not currently in use _on_ hiwiki, and was only
used twice by Mayur historically.

Amusingly:


$ bzcat hiwiki-20140205-pages-meta-current.xml.bz2 | grep -i "\[\[c:"

Sorry for writing this notice in English but there's been some important developments on [[m:Special:MyLanguage/Main Page|Meta-Wiki]] concerning the underlying MediaWiki code responsible for running the Hindi Wikipedia, and I wanted to make sure we have enough input from the Hindi Wikipedia community and the greater Wikimedia community at large to go ahead with our proposed changes. I am not sure whether or not [[सदस्य वार्ता:Mayur|Mayur]] has discussed this with you but as he/she is retired since 2011 I have decided to post this notice myself to the Hindi Wikipedia community, to perhaps engage in discussion or reopen an old one if Mayur did already discuss this with you. For us to move forward with our request, however, requires that Hindi Wikipedia file a bug at [[bugzilla:|Bugzilla]] to change their prefix C: which is used for pages like [[C:समग्र_विषय]] to allow us space to change it to an interwiki prefix to [[commons:Special:MyLanguage/Main Page|Commons-Wiki]]. There is already a discussion about this particular request on Bugzilla, at [[bugzilla:4676]] if you want to look also at what we are proposing, and [[m:Requests for comment/Wikimedia Commons]] which contains our reasons for doing so. If you can, please respond at the requests for comment link above, so we can get a better evaluation of the situation and its impact on Hindi Wikipedia. [[सदस्य:TeleComNasSprVen|TeleComNasSprVen]] ([[सदस्य वार्ता:TeleComNasSprVen|वार्ता]]) 00:50, 3 फ़रवरी 2014 (UTC)</text>

PiRSquared17 added a comment.Via ConduitFeb 16 2014, 10:08 PM

What about [[Special:WhatLinksHere/C:CSD]], etc.?

Thryduulf added a comment.Via ConduitFeb 16 2014, 11:21 PM

I very strongly oppose the developers actioning this change until there is evidence of a much stronger community consensus than just 23 people two years ago (in a discussion that does not seem to have been massively advertised) and the non-objection of one person on one project.

Much stronger evidence of consensus has typically been required for less significant changes that affect only one project (the addition of a new namespace at en Wiktionary for example).

[[Wikipedia:Redirects for discussion/Log/2014 February 16]] shows this conflicts with about 20 redirects (and at least 2 pages) on the English Wikipedia, and goodness knows how many on other projects (which appear not to have been consulted) so consensus does not seem to be guaranteed.

PiRSquared17 added a comment.Via ConduitFeb 16 2014, 11:39 PM

(In reply to Chris McKenna from comment #32)

I very strongly oppose the developers actioning this change until there is
evidence of a much stronger community consensus than just 23 people two
years ago (in a discussion that does not seem to have been massively
advertised) and the non-objection of one person on one project.

Much stronger evidence of consensus has typically been required for less
significant changes that affect only one project (the addition of a new
namespace at en Wiktionary for example).

[[Wikipedia:Redirects for discussion/Log/2014 February 16]] shows this
conflicts with about 20 redirects (and at least 2 pages) on the English
Wikipedia, and goodness knows how many on other projects (which appear not
to have been consulted) so consensus does not seem to be guaranteed.

http://tools.wmflabs.org/pirsquared/c.txt is a list of C: pages by wiki. As of writing, it's only up to enwiki, but it should finish in a minute or two.

PiRSquared17 added a comment.Via ConduitFeb 16 2014, 11:50 PM

$ cat c.txt | grep -i "C:" | wc -l
168
(!)
Sorry about the encoding. Someone might produce a prettier form of the list if needed, but I think this suffices for now.

Withoutaname added a comment.Via ConduitFeb 17 2014, 1:02 AM

(In reply to Chris McKenna from comment #32)

I very strongly oppose the developers actioning this change until there is
evidence of a much stronger community consensus than just 23 people two
years ago (in a discussion that does not seem to have been massively
advertised) and the non-objection of one person on one project.

Much stronger evidence of consensus has typically been required for less
significant changes that affect only one project (the addition of a new
namespace at en Wiktionary for example).

[[Wikipedia:Redirects for discussion/Log/2014 February 16]] shows this
conflicts with about 20 redirects (and at least 2 pages) on the English
Wikipedia, and goodness knows how many on other projects (which appear not
to have been consulted) so consensus does not seem to be guaranteed.

My thoughts exactly. It's why I reopened the RFC, 23 is not a suitable number for such a large change.

PiRSquared17 added a comment.Via ConduitFeb 18 2014, 3:41 AM

(In reply to PiRSquared17 from comment #34)

$ cat c.txt | grep -i "C:" | wc -l
168
(!)
Sorry about the encoding. Someone might produce a prettier form of the list
if needed, but I think this suffices for now.

Make that 146. Forgot to limit to ns 0.

Technical13 added a comment.Via ConduitFeb 20 2014, 2:34 AM

Ignoring PNR's, the results of http://tools.wmflabs.org/pirsquared/c.txt simply show too many legitimate articles that start with C: such as C:, C:\, C:\\, C:\\Window, C:\\Program files, etc. I've heard a suggestion that these pages simply be put on Commons, but commons is for media, and not content so that would first violate the spirit of commons and secondly since some of those pages are in multiple languages, this would require multiple translations of some already large articles making it difficult or possibly impossible to load the pages (I'm thinking of mobile devices).

PiRSquared17 added a comment.Via ConduitFeb 20 2014, 2:37 AM

(In reply to Technical 13 from comment #37)

Ignoring PNR's, the results of http://tools.wmflabs.org/pirsquared/c.txt
simply show too many legitimate articles that start with C: such as C:, C:\,
C:\\, C:\\Window, C:\\Program files, etc. I've heard a suggestion that
these pages simply be put on Commons, but commons is for media, and not
content so that would first violate the spirit of commons and secondly since
some of those pages are in multiple languages, this would require multiple
translations of some already large articles making it difficult or possibly
impossible to load the pages (I'm thinking of mobile devices).

Wherever there are \\, it should probably just be \. Sorry for getting imperfect output but I don't have time to perfect this one-time use script.
What about simply renaming pages like C:\Program files to C \Program files ?

Technical13 added a comment.Via ConduitFeb 20 2014, 2:50 AM

Not sure why clicking reply didn't put your text in here for me to reply to, but... First problem is that C (previously [[C:]]) would conflict with the article [[C]]. Secondly, things like [[C:\Windows]] would be inaccurate as C \Windows, and I don't think there are any reliable sources which could be found to support a move to [[C \Windows]], which would be an issue all of its own. Therefor, as an interwiki prefix, I would think C: (and for that matter D: as well as D:\ is the common command to access the CD-ROM drive) should be off limits as an interwiki prefix or a namespace alias.

PiRSquared17 added a comment.Via ConduitFeb 20 2014, 2:54 AM

(In reply to Technical 13 from comment #39)

Not sure why clicking reply didn't put your text in here for me to reply to,
but... First problem is that C (previously [[C:]]) would conflict with the
article [[C]]. Secondly, things like [[C:\Windows]] would be inaccurate as C
\Windows, and I don't think there are any reliable sources which could be
found to support a move to [[C \Windows]], which would be an issue all of
its own. Therefor, as an interwiki prefix, I would think C: (and for that
matter D: as well as D:\ is the common command to access the CD-ROM drive)
should be off limits as an interwiki prefix or a namespace alias.

[[d:]] is already an interwiki prefix. It's not going to be removed now, considering how many links there are.

Technical13 added a comment.Via ConduitFeb 20 2014, 3:02 AM

[[d:]] is already an interwiki prefix. It's not going to be removed now, considering how many links there are.

I wasn't around or didn't see the discussion for that change, and I agree that at this point, it would be disruptive to attempt to undo it. Which is why I'm not proposing that it be undone, I'm simply saying that doing this to C: is an even worse idea than it was to do that to D:.

TTO added a comment.Via ConduitFeb 20 2014, 3:40 AM

(In reply to Technical 13 from comment #39)

First problem is that C (previously [[C:]]) would conflict with the
article [[C]].

I'm not sure what is meant by this. Articles like [[D]], [[S]] etc continue to exist without issue.

Secondly, things like [[C:\Windows]] would be inaccurate as C
\Windows, and I don't think there are any reliable sources which could be
found to support a move to [[C \Windows]], which would be an issue all of
its own.

enwiki does it already for "Species: The Awakening" and "Q: Are We Not Men? A: We Are Devo!". Reliable sources do not come into it when considering technical matters such as this.

Technical13 added a comment.Via ConduitFeb 20 2014, 5:53 AM

https://en.wikipedia.org/wiki/D: doesn't take me to an article about how this is the device assignment for CD-ROMs. https://en.wikipedia.org/wiki/D:\ doesn't work either... In fact, that is even worse because it take you to https://www.wikidata.org/wiki/%5C which is "This data set does not exist. You can search the related logs to find out where it went. You can also create a new one." and that just seems broken to me.

Scott added a comment.Via ConduitFeb 20 2014, 11:05 AM

Technical 13, you need to look at the big picture. The number of links that could be created to Commons using a c: prefix is infinite. In reality, it will be thousands. Every single one of those thousands of links represents a saving of editor time. The benefit of maintaining a small number of articles (and yes, it is a very small number) at their exact, literal title does not outweigh the potential benefit to all users in the future.

Regarding "I don't think there are any reliable sources which could be found to support a move..." We have any number of articles at titles mandated by technical limitations. Sourcing doesn't come into it.

Technical13 added a comment.Via ConduitFeb 20 2014, 1:46 PM

The number of links that already exist to Commons is infinite, and I don't see a justifiable reason to need to "double" that. People have been typing [[commons:]] just fine for years now, why is it suddenly so important to change it to [[c:]]? For the record, this is not a technical limitation, this is a decision made by people to change the way that things currently work. As, such, it is a bad idea.

Scott added a comment.Via ConduitFeb 20 2014, 2:15 PM

(In reply to Technical 13 from comment #46)

The number of links that already exist to Commons is infinite

...No it isn't. What you meant to say is "the number of links that can be created to Commons using 'commons:' is already infinite".

and I don't see a justifiable reason to need to "double" that.

What you can't see, many others can.

People have been typing [[commons:]] just fine for years now, why is it suddenly so important to change it to [[c:]]?

First: please stop typing things with double brackets around them. It doesn't do what you think it does.
Secondly: nobody has claimed that this is "suddenly important".
Thirdly: nobody is proposing to change "commons:" to "c:".

For the record, this is not a technical limitation, this is a decision made
by people to change the way that things currently work. As, such, it is a
bad idea.

"For the record", I really don't think you understand what's going on here at all, and it's probably a good idea for you not to prognosticate on what makes a "bad idea" until you do.

Thryduulf added a comment.Via ConduitFeb 20 2014, 2:28 PM

(In reply to Scott Martin from comment #47)

> For the record, this is not a technical limitation, this is a decision made
> by people to change the way that things currently work. As, such, it is a
> bad idea.

"For the record", I really don't think you understand what's going on here
at all, and it's probably a good idea for you not to prognosticate on what
makes a "bad idea" until you do.

Actually Scott, Technical 13 is correct. This is a change to the way things work that will introduce a new technical limitation that does not exist at present. It is both perfectly reasonable and perfectly logical for anyone to object to this.

You should also note that your attempt to say who can and cannot comment here is exactly as baseless as your attempts to do so at Wikipedia are.

Scott added a comment.Via ConduitFeb 20 2014, 2:54 PM

That's selective quoting. Stop it. You didn't actually include any of the parts where I pointed out the serious mistakes in Technical 13's comments, and thus completely misrepresented my opinion on this matter. I've never said that this isn't a change to the way things work. Obviously.

As you're evidently unaware of it, this is only the latest instance of the long-running pattern of Technical 13's Bugzilla contributions - frequently making misinformed and/or irrelevant comments muddling discussions, mis-tagging bugs as duplicates, or forking them inappropriately. A basic level of competence is necessary to contribute productively to Bugzilla discussions, and that starts with understanding the basic facts of what you're talking about. That was not present in comment 46.

Aklapper added a comment.Via ConduitFeb 20 2014, 2:59 PM

Folks: Please take you personal debates to private email when unrelated to this specific bug report. Every comment creates bugmail for *everybody* subscribed to this topic. Thank you!

Scott added a comment.Via ConduitMar 12 2014, 1:48 PM

Okay, I have a question for the devs.

The RfC has now been open for three weeks, and the votes are at 84 yes, 17 no - that's a support ratio of five to one. In the meantime, those wikis with conflicting titles have all been notified (see:
https://meta.wikimedia.org/wiki/Requests_for_comment/Wikimedia_Commons_interwiki_prefix#Next_steps ). The ones that have replied so far have either indicated assent, or even removed the conflicting titles themselves. The deletion discussion for the conflicting titles on the English Wikipedia was closed pending the resolution of this proposal.

I'm going to propose that we close the RfC in a week's time, at the one month mark. Will you the devs then take this forward on the basis of the unquestionable broad, cross-project support for this idea?

Many thanks.

Thryduulf added a comment.Via ConduitMar 12 2014, 4:16 PM

(In reply to Scott Martin from comment #51)

I'm going to propose that we close the RfC in a week's time, at the one
month mark. Will you the devs then take this forward on the basis of the
unquestionable broad, cross-project support for this idea?

I dispute that the RfC shows "unquestionable broad, cross-project support" as the comments associated with many of the objections can not be trivially dismissed and were not addressed by all of the supporters. Maybe it does have support, but that is not "unquestionable" and needs to be judged on something other than simple vote counting.

Full disclosure: I am one of those who objected to the proposal.

Scott added a comment.Via ConduitMar 12 2014, 4:56 PM

[Apologies to subscribers for bugspam]

It is unquestionable that the RfC has received five times as much participation as the first one, that this time around the comments in support outnumber the opposes by a factor of five, and that they come from users on a number of projects.

The comments in opposition variously relate to conflicts with existing titles, which are being resolved or have been indicated to be a non-issue, as I've pointed out; impossible proposals like "com:"; or object to the shortcut being too short, despite the long-established existence of other equally short prefixes. If I was closing the RfC - and I won't, obviously, given that I was support voter #2 - I would not consider any of those reasons to carry enough weight to interfere with the obvious prevailing opinion. I seriously doubt that the actual closer will do, either.

If you have have comments about the resolution of the RfC, I suggest that you also make them over there, as they're unlikely to have any effect in here.... In the meantime, I'll wait to see if any developers agree with my analysis.

Withoutaname added a comment.Via ConduitMar 27 2014, 1:59 AM

The RFC has concluded and over one hundred people from several different language editions and project wikis have participated in it, with a clearer sense now of where "global consensus" is. Please merge this ticket and dependent bug 61431 as appropriate.

TTO added a comment.Via ConduitApr 19 2014, 4:37 AM

This just requires a synchronisation of the interwiki map.

Withoutaname added a comment.Via ConduitApr 19 2014, 8:31 AM

Actually we also need to run namespaceDupesWT.php and cleanupTitles.php on all the wikis in order to resolving page title conflicts still in existence on the various Wikimedia projects, some of which such as English Wikipedia have declined to comment on the redirects until the RFC has concluded.

And speaking of which we should also notify English Wikipedia about the closure outcome. I'm afraid of doing so myself because I was the one who started a "redirects for discussion" thread on them and may appear impartial on the closure (more involved than I already have been).

TTO added a comment.Via ConduitApr 19 2014, 10:31 AM

Given [[Wikipedia:Redirects_for_discussion/Log/2014_April_14#C:_category_shortcuts]] and the fact that no-one seems to have complained since those redirects were deleted, I think due notice has been given to enwiki.

As for the maintenance scripts, I don't think they will need to be run on every single wiki. Currently there are several pages on jawiki and ptwiki that use the "C:" prefix, two on urwiki (both with {{delete}} for some weeks), and one each on cywiki, elwiki, and plwiktionary. That makes only 6 wikis where the scripts will have to be run.

MZMcBride added a comment.Via ConduitApr 25 2014, 3:17 AM

[[c:File:Glühwendel brennt durch.jpg]]

gerritbot added a comment.Via ConduitApr 28 2014, 11:55 PM

Change 112920 abandoned by Hoo man:
Add c: as Commons interwiki prefix

Reason:
per author request

https://gerrit.wikimedia.org/r/112920

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.