Page MenuHomePhabricator

Flow does not integrate with watchlist "changed since my last visit" highlighting
Open, MediumPublic

Description

MediaWiki applies CSS classes to the individual rows in the watchlist to indicate whether the user has actually viewed that change (e.g. visited the page and seen a revision including the change). These classes are somewhat-unintuitively named mw-changeslist-line-watched for unviewed changes and mw-changeslist-line-not-watched for viewed changes.

Flow topic changes included in the watchlist are always using the mw-changeslist-line-not-watched class, even when the topic has not been viewed.

[Update]: Upon further testing, "top-level" replies to a topic aren't highlighting, but nested replies are. There's also no indication of which "top-level" replies haven't been viewed yet when viewing the thread.


Every line in this (screenshot) should be class=mw-changeslist-line-watched until I have visited the most recent version.


Similarly in Recent Changes, where that class is applied to my watchlisted pages. Eg. in screenshot, both [[ResourceLoader]] and the Flow Topic name should both be bolded, because they have new changes since the last time I visited the page:

Details

Reference
bz66876

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:25 AM
bzimport set Reference to bz66876.
bzimport added a subscriber: Unknown Object (MLST).
Anomie created this task.Jun 20 2014, 1:28 PM

Created attachment 16201
screenshot

Except for the few pages that I've visited, all the primary links (topic/page names) in the screenshot should be bold (that's the default style applied at mediawiki.org).

Logged in trello as https://trello.com/c/t0abHqXZ/

Attached:

How Flow activity in history is surfaced has somewhat changed
I'm not sure what the correct behaviour is now.

I'm guessing what needs to happen is when you view a Flow board, it updates any existing history entries relating to that page so they use the mw-changeslist-line-watched class?

Change 159395 had a related patch set uploaded by EBernhardson:
Move EmailNotification watchlist handling into helper methods

https://gerrit.wikimedia.org/r/159395

Change 159400 had a related patch set uploaded by EBernhardson:
Update wl_notificationtimestamp when updating Flow page

https://gerrit.wikimedia.org/r/159400

Change 159399 had a related patch set uploaded by EBernhardson:
Give RC/Watchlist titles the mw-title html class

https://gerrit.wikimedia.org/r/159399

Change 159399 merged by jenkins-bot:
Give RC/Watchlist titles the mw-title html class

https://gerrit.wikimedia.org/r/159399

Change 159395 merged by jenkins-bot:
Move EmailNotification watchlist handling into helper method

https://gerrit.wikimedia.org/r/159395

Change 159400 merged by jenkins-bot:
Update wl_notificationtimestamp when updating Flow page

https://gerrit.wikimedia.org/r/159400

All patches mentioned in this report were merged - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?

Quiddity removed a subscriber: Maryana.Dec 19 2014, 1:34 AM
Anomie reopened this task as Open.EditedMar 17 2015, 1:28 PM

Reopening this, as the problem is either not fixed or it has regressed.

Update: Upon further testing, "top-level" replies to a topic aren't highlighting, but nested replies are. There's also no indication of which "top-level" replies haven't been viewed yet when viewing the thread.

He7d3r added a subscriber: He7d3r.Mar 17 2015, 7:17 PM
Quiddity updated the task description. (Show Details)Mar 18 2015, 12:41 AM
Quiddity set Security to None.

Updated description with a few clarifications. Hope that helps.

Mattflaschen-WMF triaged this task as Medium priority.Mar 18 2015, 5:40 PM

It might be that the class is fine, and we just need to tweak our CSS (and maybe add a small Flow-specific CSS module)

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 6 2015, 8:35 PM
Stryn added a subscriber: Stryn.Sep 26 2015, 12:50 PM
Nikki added a subscriber: Nikki.Oct 18 2015, 11:23 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 18 2018, 6:56 PM
SBisson moved this task from Inbox to Triaged but Future on the Growth-Team board.Jul 20 2018, 6:02 PM