Page MenuHomePhabricator

The font size of headings in the "Format" dropdown doesn't match the font size in the page content (in MonoBook skin)
Closed, ResolvedPublic

Description

The Sub-heading 4 font as shown in the Text Style drop-down does not match with the other Sub-headings in it.

Screenshot:


(old screenshot: F15333)

Task: Update the styles for VisualEditor's "Format" dropdown when using the MonoBook skin, so that the text size for headings inside the dropdown is the same as their size on the page.

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:58 AM
bzimport set Reference to bz70559.
Swainr created this task.Sep 8 2014, 2:55 PM

Created attachment 17076
monobook Sub-heading 4 with font-size 85%

Attached:

Confirmed - Sub-headings(started with Sub-heading 1) are decreasing proportionally like this: 130, 115, 100(for Sub-heading 3). However, for Sub-heading 4 - it has font-size: 80% instead of 85%.

Look at the attached screenshot where Sub-heading 4 has font-size: 85% - it looks much more proportional relative to other Sub-headings.

matmarex added a subscriber: matmarex.

This is still a problem, the font size in the menu doesn't match the font size in the page content:


Looks like VE's styles were never updated after the change to heading font sizes in MW: rMW237787cbadaa: skins: Ensure headings are not smaller than body text.

(this may look like my fault, but it's not, I was not on the VE team then yet ;) )

I would like to mentor this task in Google-Code-in-2018.

matmarex renamed this task from VisualEditor: Sub-heading 4 font, does not match with the other heading style fonts, in Monobook to The font size of headings in the "Format" dropdown doesn't match the font size in the page content (in MonoBook skin).EditedOct 23 2018, 5:43 AM
matmarex moved this task from Proposed tasks to Imported in GCI Site on the Google-Code-in-2018 board.
Aklapper updated the task description. (Show Details)Oct 23 2018, 2:12 PM
matmarex updated the task description. (Show Details)Oct 23 2018, 4:16 PM
opentechno removed opentechno as the assignee of this task.Oct 25 2018, 6:04 PM
opentechno added a subscriber: opentechno.
opentechno removed a subscriber: opentechno.

Change 470992 had a related patch set uploaded (by Bjornskjald; owner: Bjornskjald):
[mediawiki/extensions/VisualEditor@master] Update the styles for VisualEditor's "Format" dropdown

https://gerrit.wikimedia.org/r/470992

Change 470992 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update the styles for VisualEditor's "Format" dropdown

https://gerrit.wikimedia.org/r/470992

matmarex closed this task as Resolved.Nov 2 2018, 12:03 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptNov 2 2018, 12:03 AM
Elitre removed a subscriber: Elitre.Nov 8 2018, 4:59 PM