Page MenuHomePhabricator

Cannot save deletion of {{clarify span}} template
Closed, DeclinedPublic

Description

Intention:
Remove a template on en.wikipedia. The template in question is {{clarify span}}

Steps to Reproduce:

  1. Click on span to open the template dialogue
  2. Click on show options
  3. Click on the delete icon next to the template name

Actual Results:
The transclusion dialogue then goes blank. The "Apply changes" button is greyed out so the edit cannot be saved. The cancel button is still live, but this results in the edit not being saved.

This is possibly an issue with other templates as well - I haven't tried.

Expected Results:
The template transclusion should be replaced by the contents of field 1.

Reproducible: Didn't try

This edit https://en.wikipedia.org/w/index.php?title=Frame-dragging&diff=next&oldid=628355567 had to be done by manually retyping the passage. It could not be done through the template dialogue. Not such a burden in this particular case as the passage was short, but the template is capable of containing a much lengthier block of text.


Version: unspecified
Severity: normal

Details

Reference
bz71701

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:48 AM
bzimport set Reference to bz71701.

To remove a template, you simply click on it and press Canc or Backspace.

(In reply to Elitre from comment #1)

To remove a template, you simply click on it and press Canc or Backspace.

Yes, but that also removes the text the template was bracketing. The text needs to be retained. Besides which, if the "delete template" button from within the dialogue is non-functional, that is still a bug.

Elitre added a comment.Oct 6 2014, 1:24 PM

I believe that ATM the fastest way to do so is simply copying the text, removing the template, pasting the text? A better support of templates incapsulating text has already been requested elsewhere, although I'm afraid I can't provide a link right now.
I also believe that that advanced settings interface is probably working as intended; the function is there to allow you to replace a template with another one (having to click like 5 times simply to get rid of a template would be such a bad experience!). James will tell us more, anyway :)

It's quite difficult to select the text without opening the template. Having opened it, it is not five clicks to get to delete. Having selected delete, it makes no sense not to allow "save changes" without specifying a replacement template.

Right, there are actually two issues here:

  • It's not possible to "Apply changes" from the transclusion dialog after it has been emptied. This is obviously a bug and should be easy to fix.
  • You're requesting support for "annotation templates", as I've heard it called during some brainstorming – a way to apply some styling or data from a template to some text, similarly to how you can mark text as bold, italic or being a link. I don't think there's a feature request filed for it, but it has been thought about.

    Possibly interesting are bug 54186, which is actually the inverse of this (rather than removing a template from text, it asks for a way to apply a template on top of text), or bug 18231 which asks for a way to annotate which fragment of text a citation pertains to.

Agreed there are two issues here, and I'm happy for this to be split into two bugs if necessary. It must also be easy to add a "save as plain text" button or something similar. If this *has* to be done with a template, it could be done with a subst'd template that outputs just field 1. Ooooh, just noticed the template form doesn't have a tick box for "subst", that's going to be needed one day.

(In reply to Spinningspark from comment #6)

Ooooh, just noticed the template form doesn't have a tick box for "subst",
that's going to be needed one day.

Bug 49904.

(In reply to Bartosz Dziewoński from comment #5)

  • It's not possible to "Apply changes" from the transclusion dialog after it has been emptied. This is obviously a bug and should be easy to fix.

Bug 72191.

Jdforrester-WMF changed the task status from Open to Stalled.Feb 2 2015, 7:24 PM
Aklapper closed this task as Declined.Nov 3 2016, 10:04 AM
Aklapper added a subscriber: Aklapper.

If I understand correctly T51904 and T74191 exist to cover the specific cases, hence closing this task as declined. (Please reopen and clarify if I misunderstood.)