Page MenuHomePhabricator

VisualEditor: [Regression pre-wmf5] Cannot open Mobile VE in Betalabs , in the console "TypeError: Cannot set property 'MWMobileContext' of undefined" appears
Closed, ResolvedPublic

Description

Screenshot

Steps to reproduce:

1.Load a page from http://en.m.wikipedia.beta.wmflabs.org/wiki/
2.Open the page in Edit Source mode first
3.Now go to the Settings icon and try to open the page with Mobile VE

Observed Result:
The following error appears in the console and VE does not open, stays in Edit Source mode:
"TypeError: Cannot set property 'MWMobileContext' of undefined"


Version: unspecified
Severity: normal

Attached:

Details

Reference
bz72282

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:51 AM
bzimport set Reference to bz72282.
Ryasmeen created this task.Oct 20 2014, 9:54 PM

Change 167715 had a related patch set uploaded by Catrope:
Followup e20b47f: make .mediawiki.mobile depend on .core

https://gerrit.wikimedia.org/r/167715

Change 167715 merged by jenkins-bot:
Followup e20b47f: make .mediawiki.mobile depend on .core

https://gerrit.wikimedia.org/r/167715

Change 167850 had a related patch set uploaded by Catrope:
Followup fbc7ecb: make mediawiki.mobile depend on core.mobile, not core

https://gerrit.wikimedia.org/r/167850

Change 167850 merged by jenkins-bot:
Followup fbc7ecb: make mediawiki.mobile depend on core.mobile, not core

https://gerrit.wikimedia.org/r/167850

Verified the fix in Betalabs

Verified the fix in test2