Page MenuHomePhabricator

VisualEditor: When I click the Save button, please take my cursor out of the main text and focus it in the Save dialog
Closed, ResolvedPublic1 Estimated Story Points

Description

Goal:

Save page with edit summary "Copyedit".

(Almost) result:

Save page with no edit summary, but with the word 'Copyedit' added in the middle of the link that I had just fixed.

Steps to reproduce:

  1. Edit any page.
  1. Click the save button.
  1. Start typing your edit summary.
  1. Stop typing your edit summary and start backspacing.
  1. Click inside the Save dialog.
  1. Type your edit summary again.
  1. File another bug in Bugzilla.

Version: unspecified
Severity: enhancement

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:57 AM
bzimport set Reference to bz73675.

Is this a regression? I thought it used to work…

Worksforme...

James also tried this and couldn't reproduce it. I think I may have asked someone else as well since... not sure.

If anything caused this, it's probably https://gerrit.wikimedia.org/r/172658/ (and -maybe- another thing related to the de-isolation of windows?)

Did anyone other than the reporter ever manage to reproduce this issue?

Tricky to reproduce - happens only in test2:

  • make some changes on a page - click Save
  • in 'Save your changes dialog box' check(or uncheck) 'This is minor edit' check box - notice that the cursor will be gone from the Summary area.
  • click 'Resume editing' and make some changes again
  • click Save - the cursor won't be placed in the Summary area anymore

The cursor always goes back to the summary field for me, after following those instructions.

Oh I did manage to reproduce what I think is this issue when I tried it on testwiki though - the focus moves from the summary field to somewhere else when I press save again.

Change 182976 had a related patch set uploaded (by Alex Monk):
Re-focus edit summary input when save dialog is ready

https://gerrit.wikimedia.org/r/182976

Patch-For-Review

Change 182976 merged by jenkins-bot:
Re-focus edit summary input when save dialog is ready

https://gerrit.wikimedia.org/r/182976

Jdforrester-WMF closed this task as Resolved.Jan 7 2015, 3:01 AM
Jdforrester-WMF set Security to None.