Red link to userpage if there is no content to show
Closed, ResolvedPublic

Description

If a user wants to opt-out from the feature and adds <noinclude> to all his userpage on Meta, the link to the local userpage should be red instead of blue. For example see this userpage on itwiki: https://it.wikipedia.org/wiki/Utente:Castagna

Incola created this task.Feb 26 2015, 7:35 AM
Incola updated the task description. (Show Details)
Incola raised the priority of this task from to Needs Triage.
Incola added a project: GlobalUserPage.
Incola added a subscriber: Incola.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 26 2015, 7:35 AM
Melos added a subscriber: Melos.Feb 27 2015, 12:05 PM
Ricordisamoa added a subscriber: Ricordisamoa.

Change 194379 had a related patch set uploaded (by Ricordisamoa):
A global user page's title is only known if there are contents in it

https://gerrit.wikimedia.org/r/194379

Ricordisamoa changed the task status from Open to Stalled.Sep 8 2015, 7:05 AM

Pending analysis of performance implications.

XXN awarded a token.Feb 6 2016, 7:46 PM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptFeb 6 2016, 7:46 PM
XXN added a subscriber: XXN.Feb 6 2016, 7:46 PM
XXN added a comment.Feb 15 2016, 12:33 PM

I strongly support this idea. User should have possibility to decide if he wants to have a page in a project, or no. For example some retired user from certain wikiproject, with deleted user page, probably does not want to display his Meta page content on that wiki and also probably prefers a red-linked username instead of one blue-linked which may suggest user is active further.

XXN added a comment.EditedFeb 15 2016, 12:40 PM

Probably the best way is to add in user preferences option to enable/disable global user page feature (and additionally one more option to enable/disable global user custom scripts)

In T90849#2028514, @XXN wrote:

I strongly support this idea. User should have possibility to decide if he wants to have a page in a project, or no. For example some retired user from certain wikiproject, with deleted user page, probably does not want to display his Meta page content on that wiki and also probably prefers a red-linked username instead of one blue-linked which may suggest user is active further.

The current opt-out system has no granularity, as far as I can tell. The opt-out applies to all wikis.

We should consider a local wiki user preference, but I'm wary of additional user preferences, especially ones targeted for retired users.

The use-case of someone retiring from or quitting de.wikinews.org and not wanting a user page there, but simultaneously creating/keeping a meta.wikimedia.org user page, seems pretty limited.

Change 303912 had a related patch set uploaded (by Legoktm):
Implement magic word based opt-out

https://gerrit.wikimedia.org/r/303912

Change 303912 had a related patch set uploaded (by Legoktm):
Implement magic word based opt-out

https://gerrit.wikimedia.org/r/303912

This approach is opt-out at a global and binary level. As implemented, it would not allow disabling having a global user page on a per-wiki basis.

In thinking about this task again, I'll point out (probably repeat) that currently:

  • a user can opt out of having a global user page everywhere by not having a user page on Meta-Wiki;
  • a user can opt out of having a global user page everywhere by wrapping everything in <noinclude></noinclude> or having a blank global user page on Meta-Wiki; and
  • a user can opt out of having a global user page on a specific wiki by creating a local user page.

The use-cases we seem to be discussing are:

  • a user wants to have a global user page on Meta-Wiki, but because of retirement or some other reason, wants to opt out of having a specific local user page altogether (not even a "this user is retired" message, as though would disable the global page, of course); or
  • a user wants to only have local user pages, including on Meta-Wiki (the large majority of users currently have only local user pages and no global user page on Meta-Wiki, as I understand it).

Are there other use-cases that are missing? If it's just these two, I remain unconvinced that here's a real problem in need of solving right now.

(I thought these issues were discussed in another Phabricator Maniphest task, but if it exists, I can't find it at the moment.)

Change 194379 abandoned by Legoktm:
A global user page's title is only known if there are contents in it

https://gerrit.wikimedia.org/r/194379

Change 303912 had a related patch set uploaded (by Legoktm):
Implement magic word based opt-out

https://gerrit.wikimedia.org/r/303912

This approach is opt-out at a global and binary level. As implemented, it would not allow disabling having a global user page on a per-wiki basis.

Yes.

In thinking about this task again, I'll point out (probably repeat) that currently:

  • a user can opt out of having a global user page everywhere by not having a user page on Meta-Wiki;

This will always be supported.

  • a user can opt out of having a global user page everywhere by wrapping everything in <noinclude></noinclude> or having a blank global user page on Meta-Wiki; and

I want to remove this functionality.

  • a user can opt out of having a global user page on a specific wiki by creating a local user page.

This will probably always be supported.

The use-cases we seem to be discussing are:

  • a user wants to have a global user page on Meta-Wiki, but because of retirement or some other reason, wants to opt out of having a specific local user page altogether (not even a "this user is retired" message, as though would disable the global page, of course); or
  • a user wants to only have local user pages, including on Meta-Wiki (the large majority of users currently have only local user pages and no global user page on Meta-Wiki, as I understand it).

    Are there other use-cases that are missing? If it's just these two, I remain unconvinced that here's a real problem in need of solving right now.

The problem is that I would like to kill the opt-out of noinclude tags because the implementation is bad, and I don't want it in core as part of shadow namespaces.

Change 303912 merged by jenkins-bot:
Implement magic word based opt-out

https://gerrit.wikimedia.org/r/303912

Legoktm closed this task as Resolved.Sep 14 2016, 11:02 PM

I'll announce this soon along with a deprecation process

XXN added a comment.Apr 28 2017, 1:36 PM
This comment was removed by XXN.