Page MenuHomePhabricator

English Wikipedia user talk page shown as blue link but displays: revision #0 does not exist
Closed, ResolvedPublic

Description

I load https://en.wikipedia.org/wiki/User_talk:1r3gr37n0n and get:

The revision #0 of the page named "User talk:1r3gr37n0n" does not exist.

This is usually caused by following an outdated history link to a page that has been deleted. Details can be found in the deletion log.

Talk page history renders but is blank:
https://en.wikipedia.org/w/index.php?title=User_talk:1r3gr37n0n&action=history

Nothing in the deletion log:
https://en.wikipedia.org/w/index.php?title=Special:Log/delete&page=User_talk:1r3gr37n0n

When I try to link to it, it shows up as a blue link. See attachment.

Event Timeline

Harej created this task.Mar 9 2015, 11:35 PM
Harej raised the priority of this task from to High.
Harej updated the task description. (Show Details)
Harej added a project: MediaWiki-General.
Harej added a subscriber: Harej.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 9 2015, 11:35 PM
Earwig added a subscriber: Earwig.Mar 9 2015, 11:36 PM

There appear to be sixteen affected pages in total, given by the following query. Note that NS 3 is User_talk and NS 4 is Wikipedia.

MariaDB [enwiki_p]> SELECT page_namespace, page_title FROM page LEFT OUTER JOIN revision ON page_latest = rev_id WHERE rev_id IS NULL;
+----------------+------------------------------------------------------------------------+
| page_namespace | page_title                                                             |
+----------------+------------------------------------------------------------------------+
|              3 | 1r3gr37n0n                                                             |
|              3 | Vd437                                                                  |
|              3 | Heelo1                                                                 |
|              3 | HOTPOCKETSG                                                            |
|              3 | Jaeh0317                                                               |
|              3 | Mightym53821                                                           |
|              3 | 68.148.238.76                                                          |
|              3 | Lilyonthevalley                                                        |
|              4 | Articles_for_deletion/2009_Sulu_kidnapping_crisis                      |
|              4 | Articles_for_deletion/3_Libras_(song)                                  |
|              3 | Ttylxox1000                                                            |
|              4 | Articles_for_deletion/333:_A_Bibliography_of_the_Science-Fantasy_Novel |
|              4 | Articles_for_deletion/2009_Sulu_kidnapping_crisis_(2nd_nomination)     |
|              4 | Articles_for_deletion/2009_Sulu_kidnapping_crisis_(3rd_nomination)     |
|              3 | Vishal.gkamath                                                         |
|              3 | 71.129.57.41                                                           |
+----------------+------------------------------------------------------------------------+
16 rows in set (34 min 55.94 sec)
scfc added a subscriber: scfc.Mar 10 2015, 8:57 AM
Aklapper renamed this task from English Wikipedia user talk page simultaneously exists and doesn't exist to English Wikipedia user talk page shown as blue link but displays: revision #0 does not exist.Mar 10 2015, 11:55 AM
Aklapper lowered the priority of this task from High to Normal.
Aklapper set Security to None.

Wondering if this is another duplicate of T18674: Broken revisions with rev_page=0...

TheDJ added a subscriber: TheDJ.Mar 31 2015, 6:13 AM

Another report on en.wp this morning: https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#Homo_ergaster

ther is definitely seems to be an 'increase' of some sort in how often this happens. 4 users reporting this in 3 weeks ?

Anomie added a subscriber: Anomie.Mar 31 2015, 5:34 PM

There seems to be more than one thing going on here:

  • All the titles listed by Earwig were last touched over a year ago and have no entries in the revision table.
  • Entries such as Homo ergaster and the others reported on enwiki's VPT do have entries in the revision table, as shown by them being able to be purged or reverted to be fixed.

The second bullet is the more interesting case, since that seems to be what's causing the new reports. Looking at the code, though, I can't see anything obvious as to how this could be happening.

Change 200894 had a related patch set uploaded (by Anomie):
Add checks to try to catch T92046

https://gerrit.wikimedia.org/r/200894

Change 200894 merged by jenkins-bot:
Add checks to try to catch T92046

https://gerrit.wikimedia.org/r/200894

Change 201719 had a related patch set uploaded (by Anomie):
Add checks to try to catch T92046

https://gerrit.wikimedia.org/r/201719

Change 201720 had a related patch set uploaded (by Anomie):
Add checks to try to catch T92046

https://gerrit.wikimedia.org/r/201720

Change 201720 merged by jenkins-bot:
Add checks to try to catch T92046

https://gerrit.wikimedia.org/r/201720

Change 201719 merged by jenkins-bot:
Add checks to try to catch T92046

https://gerrit.wikimedia.org/r/201719

Anomie added a comment.Apr 6 2015, 3:26 PM

Ok, we've merged and deployed some patches that should detect the error situation on the edit when it occurs instead of requiring people to find it later on. If anyone finds instances of this problem due to edits made after 2015-04-06T15:23:00Z, please report them here.

TheDJ added a comment.Apr 7 2015, 9:25 AM

I have a report on VP/T from 01:06, 7 April 2015 (UTC). By kwami, on the page [[Na Dialect]].

Anomie added a comment.Apr 7 2015, 3:00 PM

Thanks to PrimeHunter for making a list of recently-affected pages without immediately fixing them, it looks like the problem isn't that it's actually trying to fetch revision zero. Instead, "0" is code for "the latest revision of the page" in Article::fetchContentObject().

My updated suspicion is that something somewhere is getting into that function while some piece of the saved data isn't yet available, because of slave lag or who knows what. More debugging to come...

Change 202408 had a related patch set uploaded (by Anomie):
Report correct rev_id in missing-revision message

https://gerrit.wikimedia.org/r/202408

Change 202409 had a related patch set uploaded (by Anomie):
AdHocDebug: Get stack traces for failures in Article::fetchContentObject

https://gerrit.wikimedia.org/r/202409

Change 202408 merged by jenkins-bot:
Report correct rev_id in missing-revision message

https://gerrit.wikimedia.org/r/202408

It happens on other Wikipedias, too.

I've today such error at least twice at Latvian Wikipedia. At this edit (had to make NULLEDIT) and on this redirect creation (just refreshed the page and everything was just fine).

Just notifying.

Change 202602 had a related patch set uploaded (by Anomie):
Report correct rev_id in missing-revision message

https://gerrit.wikimedia.org/r/202602

Change 202603 had a related patch set uploaded (by Anomie):
AdHocDebug: Get stack traces for failures in Article::fetchContentObject

https://gerrit.wikimedia.org/r/202603

Change 202602 merged by jenkins-bot:
Report correct rev_id in missing-revision message

https://gerrit.wikimedia.org/r/202602

Change 202603 merged by jenkins-bot:
AdHocDebug: Get stack traces for failures in Article::fetchContentObject

https://gerrit.wikimedia.org/r/202603

Ok, we've merged some more debugging code to wmf24. If you see an instance of the problem on a non-Wikipedia for an edit after 2015-04-08T15:26:00Z, or to a Wikipedia after the update to wmf24 later today, please report it here.

Today on Estonian Wikipedia (etwiki).
Tried to look at a revision diff from my watchlist, result:
https://et.wikipedia.org/w/index.php?title=Marek_Ranne&curid=401471&diff=4158722&oldid=4067351

"Viga
Selle erinevuste vaate 2 redaktsiooni (4067351 ja 4158722) ei leitud.
Harilikult tähendab see seda, et sind siia juhatanud link on vananenud ja siin asunud lehekülg on kustutatud. Üksikasjad leiad kustutamislogist."
(Error. Diff between 2 revisions (4067351 and 4158722) not found.
This is usually caused by following an outdated history link to a page that has been deleted. Details can be found in the deletion log.)

4158722 is a link to page https://et.wikipedia.org/w/index.php?title=Eri:Lehek%C3%BClje_taastamine&target=Marek+Ranne&timestamp=20150413114734 (looking or restoring deleted revision, edit box is empty)

Today on Estonian Wikipedia (etwiki).
Tried to look at a revision diff from my watchlist, result:
https://et.wikipedia.org/w/index.php?title=Marek_Ranne&curid=401471&diff=4158722&oldid=4067351

[...]

(Error. Diff between 2 revisions (4067351 and 4158722) not found.
This is usually caused by following an outdated history link to a page that has been deleted. Details can be found in the deletion log.)

This does not seem to be an instance of this bug. Revision 4158722 on etwiki is deleted.

This bug is when viewing a page via the normal URL shows a missing revision error. For example, the url illustrating the bug would be https://et.wikipedia.org/wiki/Marek_Ranne rather than a diff link.

Ok, I am sorry then. This seemed similar and I have not seen something like this before.

Change 204050 had a related patch set uploaded (by Anomie):
AdHocDebug: Get stack traces for failures in Article::fetchContentObject

https://gerrit.wikimedia.org/r/204050

Change 204050 merged by jenkins-bot:
AdHocDebug: Get stack traces for failures in Article::fetchContentObject

https://gerrit.wikimedia.org/r/204050

Change 202409 abandoned by Anomie:
AdHocDebug: Get stack traces for failures in Article::fetchContentObject

Reason:
Meh

https://gerrit.wikimedia.org/r/202409

Octahedron80 added a subscriber: Octahedron80.EditedJul 27 2016, 11:29 PM

Hello. I also found the same issue at mg.wiktionary on these two pages while running bot:

https://mg.wiktionary.org/wiki/franciu
https://mg.wiktionary.org/wiki/heliu
(Perhaps there will be more)

Sysop Kaganer led me here. He said this may be result of database corruption.

Yes, database corruption apparently from 2012. I see 5 pages on mgwiktionary apparently created between 2012-06-11 23:37:17Z and 2012-06-11 23:55:13Z that have no page_latest: ficțiune, flacără, franciu, frunte, and heliu.

The best thing to do there would be to just delete them, there's no chance anyone is going to be able to figure out what might have gone wrong four years ago.

Anomie closed this task as Resolved.Jul 28 2016, 3:53 PM
Anomie claimed this task.

Since no one has reported any valid instances of this bug since 1.25wmf24, let's close this.