Page MenuHomePhabricator

Feature to add Newsletter subscribers manually
Closed, ResolvedPublic

Description

There needs a way to add subscribers to a newsletter manually. Now the only way is to expect users to subscribe themselves, which is good as a default use case but limits two other valid use cases:

  • Migration of existing lists of users in other formats (MassMessage, wiki lists...)
  • Possibility to add manually users by admins, under admin's criteria (probably more relevant in 3rd party wikis than Wikimedia) i.e. a corporate wiki.

This feature should be available for administrators only. When abused, this is basically a powerful tool for easy spamming. Considering how easy is to become the owner of a newsletter and how infrequent is the need of this feature, I think restriction to administrators is the way to go.

Old description

A way to easily help readers migrate to the new system, without them having to do anything.

  • Develop a way for admins (or confirmed newsletter publishers) to migrate the list of existing subscribers (either raw wikitext lists, or a massmessage listing) into the new system - (??)
  • ...
  • Profit!

For the initial newsletters that use this system, and/or old newsletters with massive subscription lists, this will also need: First get community consensus (or per-newsletter consensus) that this extension is a good replacement for all stakeholders

Event Timeline

Quiddity raised the priority of this task from to Low.
Quiddity updated the task description. (Show Details)
Quiddity added a subscriber: Quiddity.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 25 2015, 10:09 AM
Tinaj1234 set Security to None.
Tinaj1234 removed Tinaj1234 as the assignee of this task.Oct 1 2015, 11:05 AM
QuimGil renamed this task from Migrate existing subscribers of existing newsletters to the new system to Feature to add Newsletter subscribers manually.Dec 18 2016, 3:44 PM
QuimGil updated the task description. (Show Details)
QuimGil added subscribers: 01tonythomas, QuimGil.

@01tonythomas I wonder whether the implementation of this feature could be sliced in different GCi tasks?

@01tonythomas I wonder whether the implementation of this feature could be sliced in different GCi tasks?

I need to get to know how this should be sliced upon, like I need information on:

  1. Is current newsletters stored only in MassMessage lists (if there are more, then these can be individual tasks, as parsing them is different)
  2. Should we be going for a migration script - in this case - it would be easy, but only executed by someone with shell on the wiki

@Legoktm might know how to get things out of MassMessage lists. CCing him. If we can get this done by GCI, then it would be great, and a very serious task completed!

I don't think we need to complicate things so much. The Newsletter extension could simply offer somewhere a textarea where administrators could introduce usernames, one per line, with a format "User:Xyz". That's it.

You can see how MassMessages subscribers lists look like at https://meta.wikimedia.org/wiki/Global_message_delivery/Targets

Owners of MassMessage lists willing to move to Newsletters can clean their own lists pretty easily.

I don't think we need to complicate things so much. The Newsletter extension could simply offer somewhere a textarea where administrators could introduce usernames, one per line, with a format "User:Xyz". That's it.

Will there be a problem of interwiki users coming up ? Like the massmessage stores things of the format {{target | user = Username | site = en.wikipedia.org}} and I think we should be considering something like that too ? It would be greatful for the existing newsletters if we can direcetly use the same format {{target | user = Username | site = en.wikipedia.org}} though :D

Qgil added a subscriber: Qgil.EditedDec 19 2016, 10:25 AM

I have no idea about the complexity of the interwiki implementation... I think the right agile sequence is:

  1. Implement this feature with "User:Xyz" only. Wikimedia has cross-wiki notifications, so users will get those notifications anyway.
  2. Implement T110645: Interwiki support for Newsletter extension
  3. Celebrate! ;)
  4. Go back to this feature and see whether we still want to work on Username/wiki pairs.

I have no idea about the complexity of the interwiki implementation... I think the right agile sequence is:

  1. Implement this feature with "User:Xyz" only. Wikimedia has cross-wiki notifications, so users will get those notifications anyway.

can be broken down to:

  1. Create a new 'subscribers' view for administrators (a new subtitle on top, etc - probably at Special:Newsletter/id/subscribers) and have a text box there listing down subscribers one per line
  2. Make the textbox to be part of a form so that its editable and changes are committed to the database

see how it works ?

Qgil added a comment.Dec 19 2016, 10:43 AM

Works for me.

Works for me.

Alright. Creating the tasks :D Hope someone is ready to work on that kind of messy tasks !

01tonythomas reopened this task as Open.Dec 28 2016, 10:49 AM

Looks like we got more subtasks coming in!

Pppery reassigned this task from Pppery to Filip.Dec 28 2016, 2:16 PM
Pppery added a subscriber: Pppery.
Pppery removed a subscriber: Pppery.
01tonythomas closed this task as Resolved.Dec 29 2016, 12:03 AM

Everything is set here, I guess. Closing this one as resolved! Thank you!