Page MenuHomePhabricator

Recruit event scout for November IETF meeting in preparation for #WikiDev16
Closed, DeclinedPublic

Description

I've long held that we should model the Wikimedia Developer Summit (née Architecture Summit) after Internet Engineering Task Force (IETF) meetings. I've had a hard time communicating how that can really work in part because we have so little institutional knowledge about how the IETF works. Let's build that institutional knowledge beyond just me.

The next meeting is IETF 94 in Yokohama, Japan. Dates: November 1-6, 2015. It isn't necessary to attend the whole thing to get the benefit of going, and it's quite frequent for people to only attend a day or two.

I did some poking around on the IETF website, and it reminded me of both how dated my knowledge of the IETF is (I wasn't able to find things that used to know the tricks for), how much things have improved (they've modernized a number of things) and how old school it still is. The challenges they face should be very, very familiar to people who live in our world.

This video is a fantastic introduction to IETF meetings: Youtube: Top 10 Things to Know Before Your First IETF Meeting. The short video (<7 min) really gives you a good intro for what a newcomer should expect out of a typical IETF meeting. The advice they give could have easily applied just as easily in 1996 as it (hopefully) does today, and I wish I had the benefit of something that well-presented before my first meeting.

Jari Arkko (IETF Chair) wrote up a great summary of IETF 93 which happened in July of this year. It may be worth a skim to see what current meetings are like (the videos in that summary could just as easily been from a Wikimedia Hackathon as from an IETF meeting)

A lot of material at IETF is deeply technical, such that I would have a hard time keeping up with a lot of it myself (despite having been to 15-20 of these). That said, some of the work about meeting logistics, such as RFC 6640. RFC 6640 is basically "How to build a travel FAQ for IETF meetings", and it's a fantastic checklist of things to look out for when setting up a big meeting in a new place.

An example of something the Wikimedia movement should consider participating in seriously is the proposed Human Rights Protocol Considerations Research Group (hrpc). To quote that proposed charter "This research has two major aims: 1) to expose the relation between protocols and human rights, with a focus on the rights to freedom of expression and freedom of assembly, and 2) to propose guidelines to protect the Internet as a human-rights enabling environment in future protocol development, in a manner similar to the work done for Privacy Considerations in RFC 6973". That's an example of important work that is frequently given the short shrift because most participants are sent by for-profit employers, who are often exclusively motivated by the bottom line, but that's an area that we can take a wider view.

Event Timeline

RobLa-WMF assigned this task to Qgil.
RobLa-WMF raised the priority of this task from to Needs Triage.
RobLa-WMF updated the task description. (Show Details)
RobLa-WMF added a subscriber: RobLa-WMF.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 3 2015, 3:19 AM
RobLa set Security to None.
Krenair added a subscriber: Krenair.Sep 3 2015, 3:27 AM
RobLa-WMF updated the task description. (Show Details)Sep 3 2015, 3:29 AM
RobLa-WMF removed a subscriber: Krenair.
RobLa-WMF updated the task description. (Show Details)Sep 3 2015, 4:57 AM
RobLa-WMF added a subscriber: Krenair.
Qgil triaged this task as Normal priority.Sep 3 2015, 8:34 AM
Qgil added a subscriber: Rfarrand.

These are the questions that this proposal raises in my mind.

I'm happy with the idea of emulating and adapting the IETF model for meetings to the Wikimedia Developer Summit. I'm just not convinced about having to allocate basically one week of one person and this travel cost (counting flights to Japan etc) to investigate such model. As @RobLa-WMF reports, there is plenty of documentation available. I understand that there is nothing like being in an event to understand that event, but I wonder how different would be our next Summit if we send one person there or we have that person dedicating a full day learning online how that event works, and maybe even setting a couple of meetings with an organizer, a regular attendee...

Who and how much? ECT is just three people with a small travel budget, and such trip in the next quarter would have a clear impact in our plans.

If that who is @Rfarrand or someone else based in San Francisco... aren't there any events in this busy city that are also using a similarly interesting format that we could learn from?

If that who is @Rfarrand or someone else based in San Francisco... aren't there any events in this busy city that are also using a similarly interesting format that we could learn from?

I came up with the idea to have someone go to IETF in a conversation with @Rfarrand, and I think she'd be a fine choice.

IETF is unique. To quote the Wikipedia article about it:

The first IETF meeting was attended by 21 U.S.-government-funded researchers on 16 January 1986. It was a continuation of the work of the earlier GADS Task Force. Representatives from non-governmental entities were invited to attend starting with the fourth IETF meeting in October 1986. Since that time all IETF meetings have been open to the public.[3]

The IETF is an international organization, and as such, they aren't always going to meet in places that are convenient to us. That doesn't make them any less important in our thinking; if anything, it makes them more important than some easy SF-based organization.

Quim, please stop trying to water this down to make it happy and easy for your budget numbers.

Legoktm added a subscriber: Legoktm.Sep 3 2015, 9:51 PM

It appears as though the OpenStack Summit is being held in Tokyo October 27-30. Budget permitting, it would be possible to send someone to both events if someone was up for two weeks worth of meetings.

Nemo_bis added a subscriber: whym.Sep 5 2015, 7:51 AM

+Japanese cc.

coren added a subscriber: coren.Sep 8 2015, 7:22 PM

Given Lab's reliance on Openstack, I think it would be very beneficial if one of us[1] managed to attend - if we can combine this with a valuable learning experience at the IETF meeting then so much the better. I don't think that any of us has significant IETF experience (I did a short stint in a WG almost two decades ago, hardly meaningful).

[1] One of Andrew (Boggot), Yuvi or Me.

Qgil added a comment.Sep 16 2015, 7:49 PM

@coren adding two conferences makes the justification of the trip simpler. If Operations wants to send someone, great. We can talk about the details on IETF when this is confirmed.

whym added a comment.EditedSep 17 2015, 12:17 PM

Thanks @Nemo_bis for the ping. Assuming the travel happens, I wonder if the event scout would be interested in spending a little bit of time with local Wikimedia volunteers (and perhaps OSS engineers) while their visit. A tech talk or just a casual meetup might be great to have.

EDIT: I just realized this was probably offtopic - if someone is interested, please talk to me offline.

cscott added a subscriber: cscott.Sep 18 2015, 9:51 PM
cscott added a subscriber: RobLa.Sep 18 2015, 9:54 PM

An alternative might be to get a bunch of IETF folks to spend time at WMF. This might be harder on the research-and-persuasion side, but getting 10 IETF regulars to participate in summit planning might ultimately have a bigger impact than having @RobLa and 1 other person who's been to a single IETF meeting. (I could work some contacts here in Boston among people I know attend IETF meetings, if that would help.)

@cscott: that is a great idea! please let me know if you end up finding any contacts who would be willing to meet with us (remotely) is fine. Especially if they have been involved in the facilitation and even planning side of things. I would love to talk with them.

@cscott, it's an interesting thought, but it's not a substitute for having someone else who can actually speak from experience about how an IETF meeting is put together, rather than relying purely on my admittedly dated knowledge of it. Also, I'm not proposing that I go myself. As much as I would enjoy going, I have personal reasons why November is a bad time for me to schedule international travel.

@Rfarrand, I was thinking of making an introduction to Steve Coya. I remember him being the guy to ask about IETF meeting logistical stuff, and I would have loved to introduce folks like you to him. However, sadly, I won't get that opportunity.

The IETF Secretariat is actually administered in the SF Bay area. However, the demands on their time are very high, so I wouldn't be surprised if they politely decline an invitation should we extend one.

Participating in the IETF and learning from how they Get Stuff Done is a potentially very high-value opportunity. I see this from the perspectives of being involved in technical working groups (getting to play a part in technical standards decision making that will ultimately affect us somehow), of the networking potential (in human terms, not technical - participating in the broader open technical community tends to have reciprocal effects and generally strengthens the broader open source ecosystem), and the learning opportunities of successfully executing large collaborative events from the people who practically invented this stuff (we'll get better at the events we hold and how we go about collaborative decision making).

We should be looking at the potential value we would get out of participating in an IETF gathering (in both the short and long term) and using that as the primary driver of a decision about whether or not to send someone. I believe we'd get much more value out of having someone (or some people) from the WMF participating in IETF 94 than having folks from the IETF come hang out with the WMF for a bit.

RobLa-WMF renamed this task from Assign event scout for November IETF meeting in preparation for WDS 2016 to Assign event scout for November IETF meeting in preparation for #WikiDev16.Sep 22 2015, 1:33 AM
Qgil removed Qgil as the assignee of this task.EditedSep 22 2015, 10:41 AM
Qgil added a subscriber: Qgil.

After letting the idea sink, work on the definition of the Summit, and discussing with @Rfarrand again, we Developer-Advocacy prefer not to invest the time and budget this trip requires, even if we will do our best to incorporate ideas of how IETF works. In an ideal world we would attend it to take lessons helping to organize a better Summit, but we are a small team and we have limitations. We hope to be able to organize anyway a good Summit in the IETF-ish terms that @RobLa-WMF has proposed and we have integrated to the definition of the event.

Being Wikimedia a big Internet player, there might be good reasons for some of our teams to participate in IETF. If someone working in topics more aligned with IETF attends, we will welcome their first-hand feedback on how that conference is organized.

RobLa-WMF renamed this task from Assign event scout for November IETF meeting in preparation for #WikiDev16 to Recruit event scout for November IETF meeting in preparation for #WikiDev16.Oct 1 2015, 7:22 AM
RobLa-WMF assigned this task to Qgil.

@Qgil: please try to at least find someone to take this on while I'm out of town

Qgil reassigned this task from Qgil to coren.Oct 1 2015, 7:57 AM

@coren, you said that a possibility would be that a Labs team member would connect this event with Openstack's conference.

coren removed coren as the assignee of this task.Nov 17 2015, 3:03 PM

The opportunity to attend either/both conferences has come and gone without the ability to do so (in particular, the Openstack conference came too close at the heels of our teamwide offsite to make it reasonable).

Qgil closed this task as Declined.Nov 18 2015, 10:25 AM
Qgil claimed this task.