[Story] ArticlePlaceholder pages should show up in search engines
Closed, ResolvedPublic

Related Objects

StatusAssignedTask
Resolvedthiemowmde
DeclinedNone
InvalidLydia_Pintscher
ResolvedLucie
ResolvedLucie
Resolvedhoo
ResolvedLydia_Pintscher
ResolvedLydia_Pintscher
ResolvedLucie
OpenLucie
OpenNone
Resolvedhoo
ResolvedLucie
Resolvedoschposch
Resolvedhoo
ResolvedLydia_Pintscher
ResolvedLydia_Pintscher
OpenNone
DeclinedNone
OpenNone
Lucie created this task.Nov 4 2015, 1:35 PM
Lucie updated the task description. (Show Details)
Lucie raised the priority of this task from to Normal.
Lucie claimed this task.
Lucie added subscribers: Lydia_Pintscher, Lucie.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 4 2015, 1:35 PM

That depends on how actually useful article placeholders are. If you try to trick search engines (and their users) into mistaking such pages for real articles, that may be interpreted as clickbaiting and affect the site's rank adversely.

If you try to trick search engines

What would count as "trick"? I think one criterion is how much content is duplicated.

If labels of all statements (their properties and items) are translated and there is something more than P31 and identifiers, is that enough for the special page not to be considered a duplicate of the equivalent in another subdomain?

If you try to trick search engines

What would count as "trick"? I think one criterion is how much content is duplicated.

If labels of all statements (their properties and items) are translated and there is something more than P31 and identifiers, is that enough for the special page not to be considered a duplicate of the equivalent in another subdomain?

Whenever I pick a search result from Wikipedia, I expect it to be a real article with at least some content written by a human. I'd be very disappointed in finding the page filled with machine-generated infoboxes just like the ones displayed by some search engines. What I mean you can easily find elsewhere.

By the way if you request an answer by a specific person be sure to ping them.

DarTar added a subscriber: DarTar.May 12 2016, 10:33 PM

I too am curious to hear (1) how these placeholders (which I really like) will show up and be indexed and (2) if readers will start blurring (as in, not understanding) the distinction between WP articles and placeholders, which will certainly raise concerns for the part of the WP community most sensitive to notability criteria. I imagine this has been extensively discussed, if it has do you have a pointer handy?

I imagine this has been extensively discussed, if it has do you have a pointer handy?

See parent task.

So the trial run on Welsh Wikipedia seems to be going fine. I'd like to expand it now to also allow indexing of the rest of the notable ArticlePlaceholder pages on Welsh Wikipedia and then the other Wikipedias that already have the ArticlePlaceholder extension enabled.

@hoo: Anything that speaks against moving forward from your side?

the rest of the notable ArticlePlaceholder pages

Note for the readers: the currently selected articles were not the "most notable" ones, but just the "sufficiently notable" ones (3+ statements, 2+ sitelinks) which happened to have a lower ID on Wikidata. See T144592#2971972.

hoo added a comment.Feb 22 2017, 6:27 PM

@hoo: Anything that speaks against moving forward from your side?

Well, the search engines didn't yet pick up the placeholders we have index enabled on. I'm not sure about the implications this will have once all placeholders are being picked up. I would like to wait for this (at least some more).

Now there seem to be a few hundreds placeholders, but their content appears to be mostly in English: https://archive.fo/14RUY

This suggests the priority of T158507: Consider translations and tweak the "notability" requirement for placeholders to be indexable is higher than expected.

Ah good check, @Nemo_bis! It seems there are still a lot of cases where the language fallback to English kicks in because there is no label or description in Welsh - at least for the ones I spot-checked now.

Lydia_Pintscher closed this task as Resolved.Apr 3 2017, 1:48 PM
hoo moved this task from Broader tickets to Done on the ArticlePlaceholder board.Apr 3 2017, 3:34 PM

Search engines and users are confused if we give them results in unexpected languages, so T167872: Correctly set lang HTML attribute for each article placeholder string is rather important to fix.

Deskana moved this task from Tag to Done on the SEO board.Fri, Jul 6, 10:28 AM