"You must choose a space for this object" notification when attempting to save changes to a Task
Closed, ResolvedPublic

Description

This only happens for some tasks. It prevents any changes from being committed.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 18 2016, 9:44 AM
Christopher added a subscriber: mmodell.
Restricted Application added subscribers: Luke081515, scfc. · View Herald TranscriptFeb 18 2016, 9:46 AM
Christopher removed mmodell as the assignee of this task.Feb 18 2016, 9:47 AM

Is this via "Edit Task"? Or via the "Actions" dropdown? Is the "Space" field displayed for you? Is it prefilled with S1?

Examples of tasks with this issue would be helpful

T89249 T100535 T91529

I do not see a space field on the task edit form.

I'm getting this error too.

Paladox added a comment.EditedFeb 18 2016, 11:12 AM

If I go to for example https://phabricator.wikimedia.org/T63626 then click edit task then just save it brings up the error, also updated the description does the same and subscribing.

Also @Aklapper no the space field is not displayed.

It seems that editing newly created tasks after the upgrade earlier today works. Such as https://phabricator.wikimedia.org/T127294 works.

If you use actions from comment box it works but editing the task directly dosent.

Amire80 added a subscriber: Amire80.EditedFeb 18 2016, 3:27 PM

Another example: T99892

I clicked "Edit" and tried to add the ContentTranslation tag, and got this cryptic error message.

greg added a subscriber: greg.Feb 18 2016, 3:32 PM

@zeljkofilipin can not edit https://phabricator.wikimedia.org/T94150 without getting that error, but I just did: https://phabricator.wikimedia.org/T94150#2039599 without getting that error.

Why can some do it and some not?

Paladox added a comment.EditedFeb 18 2016, 3:41 PM

@greg I can edit some tasks if they were created after today update, any before the update I carn't edit so its strange why some can edit and some carn't.

It maybe because some users who are in the admin group can edit and others carn't

mmodell claimed this task.Feb 18 2016, 5:35 PM

Ok I've applied a hotfix from https://secure.phabricator.com/D15306, can someone confirm if this is fixed? I haven't been able to reproduce the problem.

Mentioned in SAL [2016-02-18T18:03:53Z] <twentyafterfour> applied a hotfix from https://secure.phabricator.com/D15306 on iridium to test a fix for https://phabricator.wikimedia.org/T127290

Ok I've applied a hotfix from https://secure.phabricator.com/D15306, can someone confirm if this is fixed? I haven't been able to reproduce the problem.

Works now at least on the task I had issues with.

@Danny_B: Thanks, I'll wait for one more confirmation before closing this.

Mentioned in SAL [2016-02-18T18:53:07Z] <twentyafterfour> tagged phabricator hotfixes as release/2016-02-18/2 in the phabricator/phabricator repository. This includes fixes T127290 and T127349

It works now.

mmodell closed this task as Resolved.Feb 18 2016, 7:05 PM

thanks for confirming, @Paladox