Page MenuHomePhabricator

script test for featured.py fails
Closed, ResolvedPublic

Description

With en.wp as test site:

======================================================================
FAIL: test_featured (tests.script_tests.TestScriptSimulate)
Test running featured -simulate.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "tests/script_tests.py", line 295, in testScript
    stderr_other)
AssertionError: u'Use -help for further information.' not found in [u'Link FA does not exist', u'', u'NOTE: featured articles are not implemented at wikipedia:en.', u'0 pages written.']

With ar.wp

======================================================================
FAIL: test_featured (tests.script_tests.TestScriptSimulate)
Test running featured -simulate.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "tests/script_tests.py", line 295, in testScript
    stderr_other)
AssertionError: u'Use -help for further information.' not found in [u'\u0648\u0635\u0644\u0629 \u0645\u0642\u0627\u0644\u0629 \u0645\u062e\u062a\u0627\u0631\u0629 does not exist', u'', u'NOTE: featured articles are not implemented at wikipedia:ar.', u'0 pages written.']

featured.py was recently 'archived' in T109210: [RFC] featured.py is outdated for wm projects, but I am not sure if that is the cause.

Event Timeline

jayvdb created this task.Mar 5 2016, 3:25 PM
Restricted Application added subscribers: pywikibot-bugs-list, Aklapper. · View Herald TranscriptMar 5 2016, 3:25 PM

Change 275391 had a related patch set uploaded (by Xqt):
[bugfix] Enable script_tests for featured.py

https://gerrit.wikimedia.org/r/275391

Xqt claimed this task.Mar 7 2016, 11:14 AM
Xqt added a parent task: T95384: errors in script tests.

featured.py was recently 'archived' in T109210: [RFC] featured.py is outdated for wm projects, but I am not sure if that is the cause.

yes, this bug was caused by that, specifically removing 'featured' from the auto run list in https://gerrit.wikimedia.org/r/#/c/267410/6/tests/script_tests.py,cm

Change 275391 merged by jenkins-bot:
[bugfix] Enable script_tests for featured.py

https://gerrit.wikimedia.org/r/275391

Xqt closed this task as Resolved.Mar 7 2016, 11:37 PM

Change 275717 had a related patch set uploaded (by John Vandenberg):
Re-add featured script to the auto run list

https://gerrit.wikimedia.org/r/275717

jayvdb reopened this task as Open.Mar 7 2016, 11:42 PM

The regression hasnt been fixed yet.

Change 275717 merged by jenkins-bot:
Re-add featured script to the auto run list

https://gerrit.wikimedia.org/r/275717

Xqt closed this task as Resolved.Mar 8 2016, 1:53 PM