Page MenuHomePhabricator

Flow "mark as patrolled" links don't work (claims "Session failure")
Closed, ResolvedPublic

Description

  1. https://www.mediawiki.org/w/index.php?title=Talk:MoodBar/Design&action=history
  2. Click "prev" on the latest revision. Goes to

https://www.mediawiki.org/w/index.php?title=Talk:MoodBar/Design&action=compare-header-revisions&header_newRevision=t2i8f0pwkfw2uilt

  1. (Logged-in with the proper user rights) Click "Mark as patrolled" link. Goes to https://www.mediawiki.org/w/index.php?title=Talk:MoodBar/Design&action=markpatrolled&rcid=2424021.

Results in page claiming "Session failure" which isn't true.

Looks like this got broken as part of AJAX refactoring around tokens.

  • We no longer output tokens in the fallback html since we don't need them in most cases, expensive to compute, and we don't allow write actions on GET anymore.
  • Fallback of displaying a form that POSTs with token (similar to purge) is missing.
  • Main workflow (AJAX via API) isn't working on this page for some reason.

Event Timeline

Krinkle created this task.Apr 21 2016, 9:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 21 2016, 9:04 PM

Re-checked in betalabs cawiki (and also just general testing for patrolling) - could not reproduce.

The tested scenario - I tried to stick as close as possible to the ticket description:

  • in betalabs cawiki find a page that was converted from LQT to Flow (e.g. Talk:ET8)
  • from a Board description delete the template {{Pàgina de discussió en wikitext convertida a Flow|archive=Ajuda Discussió:ET17/Archive 1|date=2015-06-21}}
  • as a user with patrolling rights, go to 'View history' and click on 'prev' for that change
  • a compare-header-revisions&header_newRevision page will be displayed; 'Mark as patrolled' links will be displayed
  • click on 'Mark as patrolled' link - the change will be marked as patrolled.

Thanks for merging in the duplicates, could not find the correct task but suspected there must be one. :)

SBisson claimed this task.Jul 29 2016, 2:39 PM
SBisson added a subscriber: SBisson.

Any patch or ticket related to the "AJAX refactoring around tokens" that I could look at? Thanks.

Change 301868 had a related patch set uploaded (by Sbisson):
[WIP] Fix patrolling links

https://gerrit.wikimedia.org/r/301868

Yamaha5 removed a subscriber: Yamaha5.Jul 29 2016, 8:02 PM

Change 301868 merged by jenkins-bot:
Fix patrolling links

https://gerrit.wikimedia.org/r/301868

Checked in betalabs 1.28.0-alpha (2c35abe) - patrolling is enabled only cawiki( via Recent changes).

Checked

Note: The confirmation sliding popup displays a cryptic topic title, not the actual topic title. Per @Catrope, the issue is outside of the scope of the ticket.

jmatazzoni closed this task as Resolved.Aug 2 2016, 12:51 AM