Page MenuHomePhabricator

Add Iran in Farsi to the Monuments Database
Closed, ResolvedPublic

Description

Details

Related Gerrit Patches:
labs/tools/heritage : masterFix issus with Iranian monuments in Farsi

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 22 2016, 10:16 AM
Multichill triaged this task as High priority.Jun 22 2016, 10:26 AM
Multichill updated the task description. (Show Details)
Multichill added subscribers: Ladsgroup, leila, Multichill.

Mentioned in SAL [2016-06-22T16:56:26Z] <JeanFred> Deployed latest from Git: 76c6dd6c (T138377)

Merged both 43420dd49324 and 76c6dd6c9884, created the table, and started the harvesting via Normal process. :)

This shows that it worked!

From the statistics I note that there are no mapped entries for adm0, commonscat, coordinates, image or article is this as it should be or have we missed some template parameter?

I see that استان is a parameter which we failed to map.

Lokal_Profil added a comment.EditedJun 23 2016, 9:13 AM

Ok.
There were a few issues:

  • "address" was missmatched (patch on the way)
  • "استان" not mapped (not needed for monuments_all but mapping for completion (patch on the way)
  • "ISO" is not being correctly harvested (investigating)
  • fa.wikipedia not yet added to pywikibot family (@Multichill is fixing)

Change 295645 had a related patch set uploaded (by Lokal Profil):
Fix issus with Iranian monuments in Farsi

https://gerrit.wikimedia.org/r/295645

Ok. the ISO issue was related to underscores in template names in monuments_config. Patch (with new test) committed.

Change 295645 merged by jenkins-bot:
Fix issus with Iranian monuments in Farsi

https://gerrit.wikimedia.org/r/295645

Mentioned in SAL [2016-06-23T14:01:37Z] <JeanFred> Deployed latest from Git: 4030533, bb95d23 (T55808), bd96bbd (T138377), 0a3247d, be9b1a9 (T134764)

Lokal_Profil closed this task as Resolved.Jun 26 2016, 8:03 AM

Both the field, adm-2 + address fixed

\o/ Thanks everyone for making this happen. :)

Have no fear @JeanFred. ;) We're working on them.

@JeanFred, we ran into a question. How is it that for an ID such as 352 or 382, we have chosen a picture to be shown in the table, but still the bot has not removed the rest of the pictures for the ID from https://fa.wikipedia.org/wiki/کاربر:LilyOfTheWest/Unused_images?

Lokal_Profil added a comment.EditedJul 15 2016, 11:26 AM

When I look at the logs I see the line Page [[fa:کاربر:LilyOfTheWest/Unused images]] saved which occurred at some point between 2016-07-13 12:36:13 and 2016-07-13 12:43:29.

Since I see no save in the page revision history the bot either didn't detect any changes (but tried saving anyway?) Or the bot didn't manage to successfully save the page.

In response to @LilyOfTheWest's issue, this does seem like something that might be caused by an incomplete fix to T139258: Figure out improved matching of monuments for Iran. Other examples include 944 aka ۹۴۴. The unused images page has an image, even though it's filled in on the associated monuments page.

So it seems like we have a fix for T139258, both in Lua and Python, but we haven't seen any changes on the Unused images page. Has the fix been deployed and/or has the job been run?

So it seems like we have a fix for T139258, both in Lua and Python, but we haven't seen any changes on the Unused images page. Has the fix been deployed and/or has the job been run?

First half of the patch has been deployed. I'll deploy the second part tomorrow.

So it seems like we have a fix for T139258, both in Lua and Python, but we haven't seen any changes on the Unused images page. Has the fix been deployed and/or has the job been run?

First half of the patch has been deployed. I'll deploy the second part tomorrow.

Second part deployed. Lets keep the rest of the discussion in T139258 though.

@Lokal_Profil This page with unused images is now empty which can be a good sign but the Monuments database stats page says that there are more than 26K images in ir fa. Is this because the monument database accepts images outside of the wlm contest cuz through the contest we collected in the order of 3K.

@Lokal_Profil This page with unused images is now empty which can be a good sign but the Monuments database stats page says that there are more than 26K images in ir fa. Is this because the monument database accepts images outside of the wlm contest cuz through the contest we collected in the order of 3K.

The stats say that there are 26k monuments, out if which 404 have images. The stats don't keep track of total number of images just coverage.

My bad, @Lokal_Profil. It seems everything is correct then. Thanks for all your help. :)