Page MenuHomePhabricator

[Regression] Wikidata description not showing in search results on mobile web
Closed, ResolvedPublic3 Story Points

Description

wikidata descriptions should show under title in search results on mobile web. As of today, possibly earlier (on safari iOS and chrome OSX) they are not.

Event Timeline

JKatzWMF created this task.Jun 26 2016, 8:17 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 26 2016, 8:17 PM
JKatzWMF updated the task description. (Show Details)Jun 26 2016, 8:19 PM
jhobs renamed this task from wikidata description not showing in search results on mobile web to [Regression] Wikidata description not showing in search results on mobile web.Jun 27 2016, 4:11 PM
jhobs added a project: Regression.

Good catch @JKatzWMF! Initial investigation shows this was a result of the code checking the wrong variable: the one we use for the tagline descriptions ($wgMFUseWikibaseDescriptions), which we recently set to false by default as part of moving the descriptions to stable. As such, this is definitely a regression and should be fixed ASAP. I'll be bringing this up at standup with the intention to pull it into the current sprint.

dr0ptp4kt triaged this task as Unbreak Now! priority.Jun 27 2016, 5:04 PM
dr0ptp4kt assigned this task to jhobs.
Restricted Application added subscribers: Luke081515, TerraCodes, Urbanecm. · View Herald TranscriptJun 27 2016, 5:04 PM

I predict this bug has existed for a long period of time and we've only just noticed it. If that's so I'll challenge the Unbreak now nature. :)

From the documentation

$wgMFUseWikibaseDescription

If set to true, will add Wikidata description to page JS as wgMFDescription variable

$wgMFDisplayWikibaseDescription

If set to true wikidata descriptions will be displayed in UI elements such as search,
nearby and watchlist.

Thus this should be unrelated to UseWikibaseDescriptions.
Note MFDisplayWikibaseDescription is currently true on the cluster so I suspect some MobileFrontend code change broke it.

Investigating...

Okay we worked this out. Apparently there was a stray config change that I couldn't find that converted wgMFUseWikibaseDescription from true to false.

Talked to @jhobs and it seems wgMFUseWikibaseDescription is incorrectly being used to display the Wikidata description tagline when really it is just a flag to show that Wikibase is enabled and it is available (for gadgets etc - see README)

We originally intended to ship Wikidata descriptions in search results and page at same time so this is where confusion came from.

Agreed to do following:

  1. Revert wgMFUseWikibaseDescription back to true
  2. Introduce new config variable in MobileFrontend controlling the tagline which is false by default. Suggested name $wgMFDisplayWikibaseDescriptionAsTagline

Change 296281 had a related patch set uploaded (by Jhobs):
Refactor wikibase config variables to be less confusing

https://gerrit.wikimedia.org/r/296281

Created T138788 to handle the technical debt refactoring portion found during investigation of this regression.

Change 296281 merged by jenkins-bot:
Introduce config variable to control tagline

https://gerrit.wikimedia.org/r/296281

Change 296345 had a related patch set uploaded (by Jhobs):
Introduce variable for wikidata taglines

https://gerrit.wikimedia.org/r/296345

Change 296346 had a related patch set uploaded (by Jhobs):
Introduce variable for wikidata taglines

https://gerrit.wikimedia.org/r/296346

Change 296345 abandoned by Jhobs:
Introduce variable for wikidata taglines

Reason:
In favor of Id2e38fd5b60efeb3d4459d9a00ac125364e784b5

https://gerrit.wikimedia.org/r/296345

Change 296345 restored by Dereckson:
Introduce variable for wikidata taglines

Reason:
To discard change ID

https://gerrit.wikimedia.org/r/296345

Change 296345 abandoned by Dereckson:
Introduce variable for wikidata taglines

Reason:
Change ID are immutable: a new change with another change ID will be offered as a new change on Gerrit.

https://gerrit.wikimedia.org/r/296345

Change 296351 had a related patch set uploaded (by Dereckson):
Introduce config variable to control tagline

https://gerrit.wikimedia.org/r/296351

Change 296352 had a related patch set uploaded (by Jhobs):
Introduce config variable to control tagline

https://gerrit.wikimedia.org/r/296352

Change 296351 merged by jenkins-bot:
Introduce config variable to control tagline

https://gerrit.wikimedia.org/r/296351

Change 296352 merged by jenkins-bot:
Introduce config variable to control tagline

https://gerrit.wikimedia.org/r/296352

Change 296346 merged by jenkins-bot:
Introduce variable for wikidata taglines

https://gerrit.wikimedia.org/r/296346

Mentioned in SAL [2016-06-28T00:02:52Z] <dereckson@tin> Synchronized php-1.28.0-wmf.7/extensions/MobileFrontend/: Introduce config variable to control tagline (T138738) (duration: 00m 39s)

Mentioned in SAL [2016-06-28T00:05:41Z] <dereckson@tin> Synchronized php-1.28.0-wmf.6/extensions/MobileFrontend/: Introduce config variable to control tagline (T138738) (duration: 00m 29s)

Mentioned in SAL [2016-06-28T00:08:34Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Introduce config variable to control tagline (T138738, 1/2) (duration: 00m 32s)

Mentioned in SAL [2016-06-28T00:09:20Z] <dereckson@tin> Synchronized wmf-config/mobile.php: Introduce config variable to control tagline (T138738, 2/2) (duration: 00m 27s)

jhobs added a comment.EditedJun 28 2016, 3:06 AM

The patches (296281 and 296346) fixing this task and, incidentally, a problem with T138085, were able to be backported to 1.28.0-wmf.6 and rolled out to 1.28.0-wmf.7 during today's evening SWAT deployment. I've confirmed on several wikis that Wikidata descriptions are back to working in search (and other locations).

Sorry for the patch spam above; there were some merge issues during SWAT that we tried to workaround in a few different ways.

phuedx closed this task as Resolved.Jun 28 2016, 8:24 AM
phuedx added a subscriber: phuedx.

Per T138738#2410805 and my own testing.

jhobs set the point value for this task to 3.Jun 30 2016, 6:07 PM