Page MenuHomePhabricator

Ensure Wikidata descriptions disabled by default on stable channel prod cluster mobile web Wikipedias
Closed, ResolvedPublic1 Estimate Story Points

Description

This should be done during the Monday morning (most ideal for people's schedules) or Monday evening SWAT on 20-June-2016. This is a follow on from T127250: Prepare Wikidata descriptions to roll out to stable.

In T127250: Prepare Wikidata descriptions to roll out to stable there will be an additional patch slated to land 17-June-2016 that, once merged and slated for train rollout 21-23 June, will add logic to MobileFrontend to ensure that if $mfUseWikibaseDescription is true, or if the user is on beta, then Wikidata descriptions will be shown.

The practical consequence of the timing of the patches is that Wikidata descriptions will not show on the beta mode of the prod cluster for 1-3 days, depending on whether a server is in group 0, 1, or 2, but then they'll be back on across the board after the train finishes rolling 23-June-2016.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterRemove old mobile workaround for wikidata descriptions

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 17 2016, 3:02 PM
dr0ptp4kt triaged this task as High priority.Jun 17 2016, 3:02 PM
dr0ptp4kt moved this task from Incoming to 2016-17 Q2 on the Readers-Web-Backlog board.
dr0ptp4kt set the point value for this task to 1.

Change 295311 had a related patch set uploaded (by Jhobs):
Remove old mobile workaround for wikidata descriptions

https://gerrit.wikimedia.org/r/295311

Change 295311 merged by jenkins-bot:
Remove old mobile workaround for wikidata descriptions

https://gerrit.wikimedia.org/r/295311

Stashbot added a subscriber: Stashbot.

Mentioned in SAL [2016-06-20T23:13:23Z] <dereckson@tin> Synchronized wmf-config/mobile.php: Remove old mobile workaround for Wikidata descriptions (T127250, T138085) (duration: 00m 33s)

^ @dr0ptp4kt. I've confirmed it "working" as intended (i.e. descriptions are now missing from Stable Beta).

phuedx closed this task as Resolved.Jun 21 2016, 8:32 AM
phuedx added a subscriber: phuedx.

^ @dr0ptp4kt. I've confirmed it "working" as intended (i.e. descriptions are now missing from Stable Beta).

@jhobs: What's Stable Beta? AFAICT Wikidata descriptions should show in MFStable and MFβ on the test, test2, and wikidatawiki wikis, and on the Beta Cluster; and in MFβ everywhere else.

phuedx reopened this task as Open.Jun 21 2016, 8:32 AM

^ @dr0ptp4kt. I've confirmed it "working" as intended (i.e. descriptions are now missing from Stable Beta).

@jhobs: What's Stable Beta? AFAICT Wikidata descriptions should show in MFStable and MFβ on the test, test2, and wikidatawiki wikis, and on the Beta Cluster; and in MFβ everywhere else.

My apologies, I was referring to enwiki MFβ. The descriptions will not show in MFβ anywhere other than the Beta Cluster until the train rolls out to the respective wiki groups. This was our intended workaround and why we did the second SWAT deploy fairly close to the train deployment (rather than last week). Because the code in the current branch for groups 0-2 has the descriptions behind a feature flag, even on MFβ, it will not show up until the new branch is deployed (i.e. Thursday for group2). Since the Beta Cluster is always on the cutting edge, it does have the descriptions.

You are correct in leaving this task open until the train has finished rolling out on Thursday though.

In beta I do not see a wikidata description. Was this intended? I'm a little confused why we temporarily disabled these on beta (the description says "$mfUseWikibaseDescription is true, or if the user is on beta, then Wikidata descriptions will be shown.") - which is not true)

In beta I do not see a wikidata description. Was this intended? I'm a little confused why we temporarily disabled these on beta (the description says "$mfUseWikibaseDescription is true, or if the user is on beta, then Wikidata descriptions will be shown.") - which is not true)

This appears to have been fixed along with T138738#2410805.

phuedx closed this task as Resolved.Jun 28 2016, 8:26 AM

Per T138085#2410806 and my own testing.