Page MenuHomePhabricator

Enable GTID on beta cluster mariaDB once upgraded
Closed, ResolvedPublic

Description

@aaron would like to enable https://gerrit.wikimedia.org/r/#/c/289985/ via config. It would be nice to do this in betalabs too (instead of just starting with testwiki).

Event Timeline

Aklapper changed the task status from Stalled to Open.May 10 2020, 8:28 AM

Upgrade happened in 2016, hence this task is not stalled anymore.
No idea if it is still valid though (given stuff like 7f888f94a4a97092f0b825eba2fb6a25eb0159c8 or 462855cefc1bb466243a01c7f8a33dd657d78efc)

No idea if it is still valid though

Not sure if you ask because you think it is done in production and/or beta, or because the problems we found on production about it :-D. We are in a hybrid status because both. Upgrading to 10+ forces gtid, but not fully. Some iterations will be needed on both envs.

For the purpose of this task, enabling useGTIDs => true is enough to close it. This was done in production a while ago for the core databases.

Two weeks ago, it was also enabled in prod for external databases (e.g. ES content blobs, and Flow) as part of https://gerrit.wikimedia.org/r/#/c/operations/mediawiki-config/+/525147/.

However, oddly, what was intended as the first step (Beta Cluster) does not yet have it configured. I don't know whether that can be done or not.

Marostegui added a subscriber: Marostegui.

We have GTID enabled for replication on the slaves but we don't really use it for replication topology changes as we've found lots of issues with it in production. Essentially, we relay on the old position/binlog file when having to move slaves around.
Note that the DBA team doesn't own the Beta cluster.

aaron moved this task from Inbox to Radar on the Performance-Team board.May 11 2020, 8:25 PM
aaron edited projects, added Performance-Team (Radar); removed Performance-Team.

Change 597624 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[operations/mediawiki-config@master] db-labs: Enable 'useGTIDs' in Beta Cluster, same as prod

https://gerrit.wikimedia.org/r/597624

Change 597624 merged by jenkins-bot:
[operations/mediawiki-config@master] db-labs: Enable 'useGTIDs' in Beta Cluster, same as prod

https://gerrit.wikimedia.org/r/597624

Krinkle closed this task as Resolved.May 20 2020, 11:10 PM
Krinkle claimed this task.