Page MenuHomePhabricator

Long edit summaries are not displayed properly on the Revision Slider when in RTL mode
Closed, ResolvedPublic2 Story Points

Description

Hello. Here is the revision slider's first bug on RTL wikis... ;)

When hovering over a bar, the edit summary is not displayed well if it's long.

Instead of line-wrapping, an annoying horizontal scrollbar appears and it's impossible to see the entire summary.

Will screenshot be helpful?

Event Timeline

Guycn2 created this task.Jul 22 2016, 1:15 AM
Restricted Application added projects: TCB-Team, I18n. · View Herald TranscriptJul 22 2016, 1:15 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Hi @Guycn2, thanks for reporting this issue! A screenshot would be great, it makes understanding the issue easier – and I assume that an easy-to-understand issue will get picked up quicker :-)

WMDE-leszek set the point value for this task to 2.
WMDE-leszek moved this task from Proposed to Doing on the TCB-Team-Sprint-2016-07-14 board.
WMDE-leszek renamed this task from Edit summaries are not displayed properly on the Revision Slider to Long edit summaries are not displayed properly on the Revision Slider when in RTL mode.

Please find screenshots from my local mediawiki instance (thus silly content) that show the problem:

Long summary displayed correctly with lines wrapped in LTR language version:

The same long summary not wrapped when in RTL language version and not fitting in the window even the horizontal scrollbar gets added:

@Jan_Dittrich, here is a video demonstrating the issue (I think it is more clear than a screenshot in this case):
https://www.youtube.com/watch?v=OsjkqczH-Jw

@Guycn2, wow, the video is very useful, thanks!

Change 300541 had a related patch set uploaded (by WMDE-leszek):
Smarter setting of the "gravity" of tooltips

https://gerrit.wikimedia.org/r/300541

Thanks for the patch! :)

@Guycn2 Thanks for taking the time for making the video!
@WMDE-leszek Thanks for the quick patch

Addshore moved this task from Incoming to Doing on the Revision-Slider board.Jul 25 2016, 8:22 PM
Addshore triaged this task as Normal priority.Jul 26 2016, 9:12 AM

Change 300541 merged by jenkins-bot:
Smarter setting of the "gravity" of tooltips

https://gerrit.wikimedia.org/r/300541

Addshore moved this task from Doing to Done on the Revision-Slider board.Jul 27 2016, 5:59 PM
Guycn2 added a comment.EditedJul 29 2016, 4:14 PM

@Jan_Dittrich, The Hebrew Wikipedia was already been updated to the new MW version two days ago, but yet the problem is not fixed... why?

@Guycn2: Thanks for letting us know. @Addshore or @WMDE-Fisch: Do you know why that is?

@Guycn2 could you provide a link on hewiki for us to link at please?

So, looking at the merged patch it is no currently deployed and will be deployed this week!

Guycn2 added a comment.Aug 1 2016, 3:30 PM

OK, thank you!

WMDE-leszek closed this task as Resolved.Aug 5 2016, 7:04 AM

The change has been deployed and the issue should be now solved.
Please report if there are still happened to be some problems or bugs in this regard. And thank you @Guycn2 for reporting this!

Guycn2 added a comment.Aug 5 2016, 7:36 AM

The change has been deployed and the issue should be now solved.
Please report if there are still happened to be some problems or bugs in this regard. And thank you @Guycn2 for reporting this!

@WMDE-leszek, thank you very much, edit summaries are now properly displayed!

However, I've noticed something new: The popup now appears beneath the bars. Previously, it used to appear ABOVE the bars. Does it have something to do with this patch, or is it intentional?

Yes, this has changed indeed. This is intentional. Showing popups above bars turned out to be problematic. For instance it has been reported in T141093 that when there is no main section header of the diff page (which happens on some wikis for main page diff, for instance) the popup does not entirely fits the screen. Also (maybe even worse problem) when appearing above the bars popups could cover patrolling buttons which makes might be slightly annoying to people patrolling revisions. And generally there is not that much space above the bars so there is only limited amount of space to squeeze the popup in there.

To avoid such problems we decided to move popups below the bars. Placed over there popups still do "hide" some contents of the diff page but we think that possible "hidden" parts (diff column headers) not being entirely visible when popup is up is still acceptable.

Yes, this has changed indeed. This is intentional. Showing popups above bars turned out to be problematic. For instance it has been reported in T141093 that when there is no main section header of the diff page (which happens on some wikis for main page diff, for instance) the popup does not entirely fits the screen. Also (maybe even worse problem) when appearing above the bars popups could cover patrolling buttons which makes might be slightly annoying to people patrolling revisions. And generally there is not that much space above the bars so there is only limited amount of space to squeeze the popup in there.

To avoid such problems we decided to move popups below the bars. Placed over there popups still do "hide" some contents of the diff page but we think that possible "hidden" parts (diff column headers) not being entirely visible when popup is up is still acceptable.

Okay, thank you for the detailed answer!