Page MenuHomePhabricator

WikiForum: Stop using getForm due to ConfirmEdit changes
Closed, ResolvedPublic

Description

We have to either remove or deprecate getForm, and replace it with getFormInformation.

See T141300: Clean up how ConfirmEdit tracks modules associated with CAPTCHA .

Details

Related Gerrit Patches:
mediawiki/extensions/WikiForum : masterCAPTCHA: Update for getForm removal and other issues

Event Timeline

Restricted Application added a project: Social-Tools. · View Herald TranscriptJul 27 2016, 2:22 AM
Mattflaschen-WMF renamed this task from Stop using getForm for ConfirmEdit changes to WikiForum: Stop using getForm for ConfirmEdit changes.Jul 27 2016, 2:22 AM
Mattflaschen-WMF renamed this task from WikiForum: Stop using getForm for ConfirmEdit changes to WikiForum: Stop using getForm due to ConfirmEdit changes.Jul 27 2016, 2:24 AM

Change 301911 had a related patch set uploaded (by Mattflaschen):
CAPTCHA: Update for getForm removal and other issues

https://gerrit.wikimedia.org/r/301911

SamanthaNguyen moved this task from Backlog to WikiForum on the Social-Tools board.Aug 1 2016, 7:42 AM

Removing from our workboard. Patch is up, but this is not WMF-deployed.

Florian closed this task as Resolved.Aug 5 2016, 5:49 PM

Change 301911 merged by jenkins-bot:
CAPTCHA: Update for getForm removal and other issues

https://gerrit.wikimedia.org/r/301911