Page MenuHomePhabricator

Notification badges are REALLY big in IE10
Closed, ResolvedPublic

Description

Event Timeline

Catrope created this task.Aug 3 2016, 9:22 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 3 2016, 9:22 PM

According to T142045: Alerts and Notices icons look terrible on IE this is also broken in IE11 in RTL languages; it worked for me in IE11 in LTR though.

In addition, it doesn't only LOOK bad. It prevents users from clicking links that are hidden by these large icons (such as tabs on the top).

Etonkovidova added a subscriber: Etonkovidova.EditedAug 3 2016, 10:12 PM

Checked in IE11 Windows7 LTR


Monobook

Catrope triaged this task as Unbreak Now! priority.Aug 3 2016, 10:13 PM

In addition, it doesn't only LOOK bad. It prevents users from clicking links that are hidden by these large icons (such as tabs on the top).

Good point. Raising priority.

Restricted Application added subscribers: Luke081515, TerraCodes. · View Herald TranscriptAug 3 2016, 10:13 PM

Checked in IE11 LTR

Interesting, I can't reproduce in IE11 on Win10, in either LTR or RTL.

...but I can in IE11 on Windows 8.

Change 302843 had a related patch set uploaded (by Catrope):
Prevent IE from rendering the badge SVGs ridiculously big

https://gerrit.wikimedia.org/r/302843

Change 302843 merged by jenkins-bot:
Prevent IE from rendering the badge SVGs ridiculously big

https://gerrit.wikimedia.org/r/302843

Change 302845 had a related patch set uploaded (by Catrope):
Prevent IE from rendering the badge SVGs ridiculously big

https://gerrit.wikimedia.org/r/302845

The fix works - checked in IE11 Windows7. @Catrope, Monobook display issue is still there.

The fix works - checked in IE11 Windows7. @Catrope, Monobook display issue is still there.

Yeah, I'm trying to fix that now but it seems to be much harder.

Change 302845 merged by jenkins-bot:
Prevent IE from rendering the badge SVGs ridiculously big

https://gerrit.wikimedia.org/r/302845

I've split out the Monobook issue into T142053: Notification badges misaligned in Monobook in IE11 and below because it happens in more IE versions than this bug, and because it was there even before Moriel made changes to the Monobook styles for T141942.

greg added a subscriber: greg.Aug 3 2016, 11:12 PM
Stashbot added a subscriber: Stashbot.

Mentioned in SAL [2016-08-03T23:41:02Z] <dereckson@tin> Synchronized php-1.28.0-wmf.13/extensions/Echo/modules/nojs/: Adjust notification badges for monobook (T141923). Prevent IE from rendering the badge SVGs ridiculously big (T142042). (duration: 00m 29s)

Etonkovidova added a comment.EditedAug 4 2016, 8:12 PM

Checked in IE10 (via dev tools in IE 11) and IE11 - the icons displayed normally sized as for Chrome/FF/Safari.

IE11

IE10

IE9 also displays badges icons (and Special Notifications page) correctly.

Change 303253 had a related patch set uploaded (by Bartosz Dziewoński):
mw.echo.badge: Use 'background-image' rather than 'content'

https://gerrit.wikimedia.org/r/303253

Change 303253 merged by jenkins-bot:
mw.echo.badge: Use 'background-image' rather than 'content'

https://gerrit.wikimedia.org/r/303253

jmatazzoni closed this task as Resolved.Aug 8 2016, 7:34 PM
jmatazzoni claimed this task.