Page MenuHomePhabricator

Upgrade Selenium gem for various reading web opened extensions
Closed, ResolvedPublic1 Story Points

Description

The following extensions have failing browser tests. Upgrading the selenium gem for each of them should resolve this issue.

Event Timeline

Jdlrobson updated the task description. (Show Details)

Change 303083 had a related patch set uploaded (by Jdlrobson):
Upgrade mediawiki_selenium in Gemfile

https://gerrit.wikimedia.org/r/303083

Change 303084 had a related patch set uploaded (by Jdlrobson):
Upgrade mediawiki_selenium in Gemfile

https://gerrit.wikimedia.org/r/303084

Change 303085 had a related patch set uploaded (by Jdlrobson):
Upgrade mediawiki_selenium in Gemfile

https://gerrit.wikimedia.org/r/303085

Remember to run bundle install before committing so that your patch will include the updated Gemfile.lock. Your version spec is strict enough to force an update upon bundle install, so the CI job will work, but the next person to run bundle install locally will end up with a locally modified Gemfile.lock which may be confusing. Just a nitpick, really. Thanks for updating these extensions so quickly!

Change 303091 had a related patch set uploaded (by Jdlrobson):
Run bundle install

https://gerrit.wikimedia.org/r/303091

You're right. Thanks @dduvall for pointing that out!

Change 303083 merged by jenkins-bot:
Upgrade mediawiki_selenium in Gemfile

https://gerrit.wikimedia.org/r/303083

Change 303085 merged by jenkins-bot:
Upgrade mediawiki_selenium in Gemfile

https://gerrit.wikimedia.org/r/303085

phuedx added a comment.EditedAug 5 2016, 8:55 AM

303083 and 303085 were both missing updated Gemfile.lock files.

303090 needs review from someone other than me /cc @bmansurov @jhobs

phuedx updated the task description. (Show Details)Aug 5 2016, 9:23 AM
phuedx added a comment.EditedAug 5 2016, 9:29 AM

303083 and 303085 were both missing updated Gemfile.lock files.

Per T129483#2524381, that's OK but should probably be followed up on.

phuedx updated the task description. (Show Details)Aug 5 2016, 9:36 AM
phuedx updated the task description. (Show Details)
phuedx updated the task description. (Show Details)Aug 5 2016, 9:38 AM

Change 303084 merged by jenkins-bot:
Upgrade mediawiki_selenium in Gemfile

https://gerrit.wikimedia.org/r/303084

Change 303169 had a related patch set uploaded (by Bmansurov):
Freeze gem versions for all devs

https://gerrit.wikimedia.org/r/303169

303083 and 303085 were both missing updated Gemfile.lock files.

Please see above follow up patch for 303083. 303085 already has the lock file.

Yes, I'd also give 1 point for the task.

phuedx updated the task description. (Show Details)Aug 5 2016, 3:26 PM
phuedx set the point value for this task to 1.

@Jdlrobson, @jhobs: Update the point value if you disagree.

Change 303169 merged by jenkins-bot:
Freeze gem versions for all devs

https://gerrit.wikimedia.org/r/303169

Looks like @Jdlrobson has a question on whether this task is complete, but in any event, this task is for engineer signoff.

phuedx added a comment.Aug 8 2016, 8:31 AM

@Jdlrobson, @dr0ptp4kt: Should we be diving into those failures? /cc @Tgr

Tgr added a comment.Aug 8 2016, 6:21 PM

It seems to be broken at various points where it is waiting for AJAX responses, so probably not unrelated.

Looking closely at the Sauce labs url it's not related to this particular bug (the mediawiki_api related steps are passing) and all tests fail with the step:
"timed out after 30 seconds, waiting for {:class=>"mw-mmv-final-image", :tag_name=>"img"} to become present (Watir::Wait::TimeoutError)"

It's possible upgrade in Gems may have introduced some new regression but we should track this in a separate task: T142423. This is not the same problem.

Change 303091 merged by jenkins-bot:
Run bundle install

https://gerrit.wikimedia.org/r/303091

this is yet another new error. MobileFrontend is trying to log in on the mobile domain and failing. I'm going to see if I can get a MTC

Tgr added a comment.Aug 9 2016, 10:09 PM

Can't reproduce directly:

vagrant@mediawiki-vagrant:/vagrant/mediawiki/extensions/MobileFrontend/tests/browser$ bundle exec irb
irb(main):001:0> require 'mediawiki_api'
=> true
irb(main):002:0> c = MediawikiApi::Client.new('https://en.wikipedia.beta.wmflabs.org/w/api.php', true)
=> #<MediawikiApi::Client:0x00000001f1edd8 @cookies=#<HTTP::CookieJar:0x00000001f1edb0 @store=#<HTTP::CookieJar::HashStore:0x0000000220dfa8 @mon_owner=nil, @mon_count=0, @mon_mutex=#<Mutex:0x0000000220ffb0>, @logger=nil, @gc_threshold=150, @jar={}, @gc_index=0>>, @conn=#<Faraday::Connection:0x000000020cb0f0 @parallel_manager=nil, @headers={"User-Agent"=>"Faraday v0.9.2"}, @params={}, @options=#<Faraday::RequestOptions (empty)>, @ssl=#<Faraday::SSLOptions (empty)>, @default_parallel_manager=nil, @builder=#<Faraday::RackBuilder:0x00000001e7c3d0 @handlers=[Faraday::Request::Multipart, Faraday::Request::UrlEncoded, Faraday::Response::Logger, Faraday::CookieJar, FaradayMiddleware::FollowRedirects, Faraday::Adapter::NetHttp]>, @url_prefix=#<URI::HTTPS:0x000000014eda08 URL:https://en.wikipedia.beta.wmflabs.org/w/api.php>, @proxy=nil>, @logged_in=false, @tokens={}>
irb(main):003:0> c.log_in('Selenium_user', 'PASSWORD')
I, [2016-08-09T21:53:50.866585 #21293]  INFO -- : post https://en.wikipedia.beta.wmflabs.org/w/api.php
D, [2016-08-09T21:53:50.866876 #21293] DEBUG -- request: User-Agent: "Faraday v0.9.2"
Content-Type: "application/x-www-form-urlencoded"
I, [2016-08-09T21:53:52.764591 #21293]  INFO -- Status: 200
D, [2016-08-09T21:53:52.767676 #21293] DEBUG -- response: date: "Tue, 09 Aug 2016 21:53:56 GMT"
content-type: "application/json; charset=utf-8"
transfer-encoding: "chunked"
connection: "close"
server: "deployment-mediawiki01.deployment-prep.eqiad.wmflabs"
x-powered-by: "HHVM/3.12.1"
x-content-type-options: "nosniff"
cache-control: "private, must-revalidate, max-age=0"
p3p: "CP=\"This is not a P3P policy! See https://en.wikipedia.beta.wmflabs.org/wiki/Special:CentralAutoLogin/P3P for more info.\""
x-frame-options: "SAMEORIGIN"
vary: "Accept-Encoding"
set-cookie: "enwikiSession=3j0nREDACTED; path=/; secure; httponly, WMF-Last-Access=09-Aug-2016;Path=/;HttpOnly;secure;Expires=Sat, 10 Sep 2016 12:00:00 GMT, GeoIP=US:CA:San_Francisco:37.79:-122.39:v4; Path=/; secure; Domain=.beta.wmflabs.org"
backend-timing: "D=1313180 t=1470779635025030"
x-varnish: "683167381, 1212119239"
via: "1.1 varnish, 1.1 varnish"
age: "0"
x-cache: "deployment-cache-text04 pass, deployment-cache-text04 pass"
x-cache-status: "pass"
x-analytics: "ns=-1;special=Badtitle;https=1;nocookies=1"
x-client-ip: "198.73.209.5"
I, [2016-08-09T21:53:52.771626 #21293]  INFO -- : post https://en.wikipedia.beta.wmflabs.org/w/api.php
D, [2016-08-09T21:53:52.771842 #21293] DEBUG -- request: User-Agent: "Faraday v0.9.2"
Content-Type: "application/x-www-form-urlencoded"
I, [2016-08-09T21:53:54.496997 #21293]  INFO -- Status: 200
D, [2016-08-09T21:53:54.497568 #21293] DEBUG -- response: date: "Tue, 09 Aug 2016 21:53:58 GMT"
content-type: "application/json; charset=utf-8"
transfer-encoding: "chunked"
connection: "close"
server: "deployment-mediawiki02.deployment-prep.eqiad.wmflabs"
x-powered-by: "HHVM/3.12.1"
x-content-type-options: "nosniff"
cache-control: "private, must-revalidate, max-age=0"
p3p: "CP=\"This is not a P3P policy! See https://en.wikipedia.beta.wmflabs.org/wiki/Special:CentralAutoLogin/P3P for more info.\""
x-frame-options: "SAMEORIGIN"
vary: "Accept-Encoding"
set-cookie: "enwikiSession=4qi5REDACTED; path=/; secure; httponly, enwikiUserID=820; expires=Thu, 08-Sep-2016 21:53:57 GMT; Max-Age=2592000; path=/; secure; httponly, enwikiUserName=Selenium+user; expires=Thu, 08-Sep-2016 21:53:57 GMT; Max-Age=2592000; path=/; secure; httponly, centralauth_User=Selenium+user; expires=Thu, 08-Sep-2016 21:53:57 GMT; Max-Age=2592000; path=/; domain=.wikipedia.beta.wmflabs.org; secure; httponly, centralauth_Token=9f3cREDACTED; expires=Thu, 08-Sep-2016 21:53:57 GMT; Max-Age=2592000; path=/; domain=.wikipedia.beta.wmflabs.org; secure; httponly, centralauth_Session=cec2REDACTED; path=/; domain=.wikipedia.beta.wmflabs.org; secure; httponly"
backend-timing: "D=1230624 t=1470779636840768"
x-varnish: "683167400, 1212119242"
via: "1.1 varnish, 1.1 varnish"
age: "0"
x-cache: "deployment-cache-text04 pass, deployment-cache-text04 pass"
x-cache-status: "pass"
x-analytics: "ns=-1;special=Badtitle;WMF-Last-Access=09-Aug-2016;https=1"
x-client-ip: "198.73.209.5"
=> {"result"=>"Success", "lguserid"=>820, "lgusername"=>"Selenium user", "lgtoken"=>"4ebb431ea6c9945b72f271e843ae920d", "cookieprefix"=>"enwiki", "sessionid"=>"4qi5REDACTED"}

Maybe there is some error in the test logic and it tries to log in when already logged in? That would produce the right error.

Tgr added a comment.Aug 9 2016, 10:15 PM

Maybe there is some error in the test logic and it tries to log in when already logged in? That would produce the right error.

Never mind, that does not match up with the stack trace.

Jdlrobson closed this task as Resolved.Aug 10 2016, 5:26 PM

The task requested that all gems are updated. This is now done. The remaining browser tests issues are now tracked in T142600