Page MenuHomePhabricator

SUL login randomly appears to not work
Closed, DeclinedPublic

Description

Unified login feature randomly appears to not work. This bug appears especially on wikidata.org, wikimedia.org and mediawiki.org (other Wikimedia projects respond with login flyout more frequently).

In a nutshell: I am visiting one of Wikimedia sites (e. g. Wikidata) while signed in Wikipedia, but Wikidata doesn’t sign me in. This can lead to confusion since Wikidata interface is fully on AJAX (so user could not notice relatively small warning about being anonymous).

Issue appears in Firefox 47 (Windows 10). None of my browser addons interfere with cookies at Wikimedia sites.


See Also: T139298: Central Login to Commons buggy

Event Timeline

stjn created this task.Aug 10 2016, 11:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 10 2016, 11:56 AM

@stjn Could you repro with Chrome the issue?

stjn added a comment.Aug 10 2016, 7:12 PM

@stjn Could you repro with Chrome the issue?

I don’t have it, sorry. On new user session with Vivaldi (fork of Chromium) bug didn’t appear.

Base added a subscriber: Base.Aug 10 2016, 7:15 PM

If you can't reproduce the issue in another browser, please continue to investigate Firefox state.

For example, you can do some tests in a privacy window.

Another solution is to create a new Firefox profile to test.

I experienced this problem couple months ago, multiple times in fact. It happened in Firefox, but I'm not sure if it's Firefox-only issue, and sadly I cannot reproduce it, as it seems to happen randomly. It was so annoying that I had to change this warning sign (which is indeed quite small) with CSS, make it as big as possible, so I could finally notice it.

Just as a note:
Despite being logged in all other projects, I always have to log in separately on Wikidata. It hasn't worked over the last months (~9 at least, I'd say).

(using Chromium Version 68.0.3440.75 (Offizieller Build) Built on Ubuntu , running on Ubuntu 18.04 (64-Bit))

For anyone affected by log-in problems who wants to help track them down, see https://www.mediawiki.org/wiki/Manual:How_to_debug/Login_problems and report back here. Thanks!

Stryn added a subscriber: Stryn.Aug 25 2018, 4:02 PM

Happens randomly to me.
You will stay logged in for example all Wikipedia projects, but when go to other domain like wikibooks.org, you are logged out.
Annoying bug especially when 2FA is enabled and you need to log in many times.

Was just reported on Finnish Wikipedia (by 2 different users):
https://fi.wikipedia.org/wiki/Wikipedia:Kahvihuone_(tekniikka)#Keskitetty_kirjautuminen_failaa

Aklapper changed the task status from Open to Stalled.Aug 3 2019, 10:46 PM

Still need info as per https://www.mediawiki.org/wiki/Manual:How_to_debug/Login_problems hence setting status to stalled. @stjn: After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!

Aklapper closed this task as Declined.Tue, Sep 10, 7:44 AM

Unfortunately closing this report as no further information has been provided.

@stjn: After you have followed https://www.mediawiki.org/wiki/Manual:How_to_debug/Login_problems to provide the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!