Page MenuHomePhabricator

<mapframe>: Remove empty div with thumbcaption class
Closed, DeclinedPublic

Description

If no text parameter in <mapframe> is given an empty thumbcaption-class div is placed in the source code. Of course it is empty but the thumbcaption class defines a 3px padding and therefore a big empty space is shown.

Example of html code generated:

<div class="mw-kartographer-container thumb tright">
<div class="thumbinner" style="width: 300px;">
<div class="mw-kartographer-map" mw-data="interface" ...
<div class="thumbcaption"></div>
</div>
</div>

Details

Related Gerrit Patches:
mediawiki/extensions/Kartographer : masterDon't add empty thumbcaption

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 3 2016, 11:12 AM
Restricted Application added a project: Discovery. · View Herald TranscriptOct 5 2016, 10:29 PM
Yurik moved this task from Unsorted to General on the Maps (Kartographer) board.Oct 6 2016, 8:32 PM

Change 314794 had a related patch set uploaded (by MaxSem):
Don't add empty thumbcaption

https://gerrit.wikimedia.org/r/314794

MaxSem claimed this task.Oct 8 2016, 12:47 AM
MaxSem moved this task from Backlog to Needs review on the Maps-Sprint board.
Yurik added a subscriber: Esanders.Oct 8 2016, 1:28 AM

A while ago I raised this issue with @JGirault, and I was told that it is actually by design, similar to how [[File:example.jpg|frame]] and [[File:example.jpg|frame|caption]] function - they produces the same image as a map without and with the caption. So unless we want mapframe to function differently from the framed images, we should keep it as is.

MaxSem reassigned this task from MaxSem to JGirault.Nov 30 2016, 7:08 PM
MaxSem added a subscriber: MaxSem.
Yurik removed a project: Maps.Dec 15 2016, 4:39 AM
TheDJ added a subscriber: TheDJ.Jan 13 2017, 12:51 AM

This is indeed exactly as core does this as well.

BTW. we really should fix core to be able to generate a framewrapper for content that is not a File: so that we can:
1: not duplicate code for thumb frames
2: fix issues like this in a central location

Change 314794 abandoned by MaxSem:
Don't add empty thumbcaption

Reason:
Stale.

https://gerrit.wikimedia.org/r/314794

Deskana triaged this task as Low priority.Feb 6 2017, 7:47 PM
Deskana added a subscriber: Deskana.

This is not a pressing issue, and it does not affect users significantly. This cannot be prioritised right now.

Deskana moved this task from Needs review to Backlog on the Maps-Sprint board.
debt removed JGirault as the assignee of this task.Jun 14 2017, 3:21 PM
debt removed projects: Patch-For-Review, Maps-Sprint.
debt added a subscriber: debt.

Moving off the sprint board - the Discovery team won't be able to do this work at this time.

MaxSem closed this task as Declined.Feb 12 2018, 7:09 PM

We decided to keep it as it is for consistency with image thumbnails. If images change Kartographer can change too, but introducing subtle differences in look & feel is bad.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptFeb 12 2018, 7:09 PM