Page MenuHomePhabricator

Limit the Quality version of the flagged revision in Arabic Wikipedia to ns=0
Open, Needs TriagePublic

Description

Hi everyone,

Can I add a fourth task to the list (T117215, T117217, T117216) of urgent Arabic wikipedia issues that are still pending for over one year ?
We want to limit the quality version flagged revision (https://en.wikipedia.org/wiki/Wikipedia:Flagged_revisions/Quality_versions) to only one namespace which is the articles (ns=0).
Actually we have 6 namespaces (available in the table in this page https://ar.wikipedia.org/wiki/%D8%AE%D8%A7%D8%B5:%D8%A5%D8%AD%D8%B5%D8%A7%D8%A1%D8%A7%D8%AA_%D8%A7%D9%84%D8%AA%D8%AD%D9%82%D9%82).

If there is a pending revision please move it to the regular flagged revision (we use 2 flagged revisions in Arabic wikipedia, the regular one and the quality one)
Thank you very much.

Community approval : https://ar.wikipedia.org/wiki/%D9%88%D9%8A%D9%83%D9%8A%D8%A8%D9%8A%D8%AF%D9%8A%D8%A7:%D8%A7%D9%84%D9%85%D9%8A%D8%AF%D8%A7%D9%86/%D8%B3%D9%8A%D8%A7%D8%B3%D8%A7%D8%AA/10/2016#.D8.AD.D8.B0.D9.81_.D8.A7.D9.84.D9.86.D8.B3.D8.AE.D8.A9_.D8.A7.D9.84.D9.85.D8.AF.D9.82.D9.82.D8.A9

Arabic text : خلاصة: نقل النقاش إلى فبريكيتر في ما يخص الحد من إستعمال الخاصية لنطاق المقالات فقط وأنتظار مقترح ابراهيم في ما يخص تصور جديد للخاصية.

Google Translation : Abstract: The discussion was moved to Verbrecher in terms of limiting the use of the property to the scope of the articles only and waiting for Ibrahim's proposal regarding a new concept of property.

Event Timeline

Helmoony created this task.Oct 19 2016, 3:58 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 19 2016, 3:58 AM

Setting project to Wikimedia-Site-requests, as this request is about settings / configuration of a Wikimedia website.
For more information about how to request these kinds of changes, please see https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes

Restricted Application added subscribers: JEumerus, Matanya. · View Herald TranscriptOct 19 2016, 12:54 PM

Can I add a fourth task to the list (T117215, T117217, T117216) of urgent Arabic wikipedia issues that are still pending for over one year ?

Other tasks are blocked on MediaWiki i18n development. New task is configuration-only. The others don't block this one, and this one doesn't block the others. That's two separate independant sets.

Dereckson added a comment.EditedOct 19 2016, 4:48 PM

The last time ar.wikipedia required something about flagged revisions with community approval, another part of the community tell us not to do it.

Did you discuss what are the conditions a FlaggedRevisions related request has the legitimate support of ar.wikipedia community?

Relevant previous problematic task is T42499.

@Dereckson As mentioned above there is a community approval (made in the pump village) to restrict the use of the quality flagged revision (and not the regular flagged revision which also exists in ar.wiki) to ns=0. Thank you.

Hi @Dereckson @Luke081515 , did you see the approval above? Is there something else that you need to do the task ( limit the Quality version of the flagged revision in Arabic Wikipedia to ns=0).

I gave a wrong link of the community approval. Here is the right one :
https://ar.wikipedia.org/wiki/%D9%88%D9%8A%D9%83%D9%8A%D8%A8%D9%8A%D8%AF%D9%8A%D8%A7:%D8%A7%D9%84%D9%85%D9%8A%D8%AF%D8%A7%D9%86/%D8%B3%D9%8A%D8%A7%D8%B3%D8%A7%D8%AA/10/2016#.D8.AD.D8.B0.D9.81_.D8.A7.D9.84.D9.86.D8.B3.D8.AE.D8.A9_.D8.A7.D9.84.D9.85.D8.AF.D9.82.D9.82.D8.A9

Arabic text : خلاصة: نقل النقاش إلى فبريكيتر في ما يخص الحد من إستعمال الخاصية لنطاق المقالات فقط وأنتظار مقترح ابراهيم في ما يخص تصور جديد للخاصية.

Google Translation : Abstract: The discussion was moved to Verbrecher in terms of limiting the use of the property to the scope of the articles only and waiting for Ibrahim's proposal regarding a new concept of property.

@Dereckson Please take off the - Community-consensus-needed tag - since I already added a link for that 6 months ago.

Change 404620 had a related patch set uploaded (by TerraCodes; owner: TerraCodes):
[operations/mediawiki-config@master] Move flaggedrevs to NS_MAIN on arwiki

https://gerrit.wikimedia.org/r/404620

@TerraCodes thank you for claiming the task. If you have any question we are available here.

@TerraCodes as @Helmoony said, if there's any question we are here!

@TerraCodes thank you for claiming the task. If you have any question we are available here.

@TerraCodes as @Helmoony said, if there's any question we are here!

Ok, thanks~

Change 404620 merged by jenkins-bot:
[operations/mediawiki-config@master] Restrict FlaggedRevs to only operated on NS_MAIN on arwiki

https://gerrit.wikimedia.org/r/404620

Mentioned in SAL (#wikimedia-operations) [2018-03-02T00:49:22Z] <ebernhardson@tin> Synchronized wmf-config/flaggedrevs.php: SWAT: T148603: (duration: 00m 57s)

@TerraCodes it seems that the regular flagged has been removed from other ns than ns=0 instead of only removing the quality revision (see above) on those ns.
I made a test here https://ar.wikipedia.org/wiki/%D9%82%D8%A7%D9%84%D8%A8:%D9%85%D8%B3%D8%AA%D8%AE%D8%AF%D9%85_%D8%B3%D9%81%D9%8A%D8%B1_%D9%84%D9%83%D9%8A%D9%88%D9%8A%D9%83%D8%B3

Usually when I make an edit from an IP, my edits should be flagged (regular flagging).

@TerraCodes it seems that the regular flagged has been removed from other ns than ns=0 instead of only removing the quality revision (see above) on those ns.
I made a test here https://ar.wikipedia.org/wiki/%D9%82%D8%A7%D9%84%D8%A8:%D9%85%D8%B3%D8%AA%D8%AE%D8%AF%D9%85_%D8%B3%D9%81%D9%8A%D8%B1_%D9%84%D9%83%D9%8A%D9%88%D9%8A%D9%83%D8%B3

Usually when I make an edit from an IP, my edits should be flagged (regular flagging).

@TerraCodes Any new here?

@TerraCodes it seems that the regular flagged has been removed from other ns than ns=0 instead of only removing the quality revision (see above) on those ns.
I made a test here https://ar.wikipedia.org/wiki/%D9%82%D8%A7%D9%84%D8%A8:%D9%85%D8%B3%D8%AA%D8%AE%D8%AF%D9%85_%D8%B3%D9%81%D9%8A%D8%B1_%D9%84%D9%83%D9%8A%D9%88%D9%8A%D9%83%D8%B3

Usually when I make an edit from an IP, my edits should be flagged (regular flagging).

@TerraCodes Any new here?

No, I couldn't find a way to fix this, so I asked for help in Z398 about 10 days, but I have yet to receive a response.

Ahmed123 updated the task description. (Show Details)Mar 11 2018, 2:13 PM

@Ahmed123: Removing MediaWiki-extensions-FlaggedRevs as there is nothing to change in the code base of FlaggedRevs, only in the configuration of servers.

alanajjar added a comment.EditedMar 17 2018, 6:07 PM

@TerraCodes @Aklapper @Dereckson @EBernhardson @Urbanecm @Zoranzoki21

sorry for that, but can you at least revert the previous version of the code (revert all changes made based on this task)?

I thought (sure) that changes here made this problem T189224, and it affects arwiki in huge manner! The problem is worsening day by day!

Its already being reverted by https://gerrit.wikimedia.org/r/#/c/418700. Also why ping 6 different people?

I scheduled deploy for this revert on Monday, March 19 13:00–14:00 UTC.

Mentioned in SAL (#wikimedia-operations) [2018-03-19T13:20:11Z] <zfilipin@tin> Synchronized wmf-config/flaggedrevs.php: SWAT: [[gerrit:418700|Revert "Restrict FlaggedRevs to only operated on NS_MAIN on arwiki" (T148603 T189224)]] (duration: 00m 58s)

Urbanecm closed this task as Declined.Apr 23 2018, 11:53 AM

Mass-declining of all old "Blocked on community consensus" site request tasks. If this is still wanted, please make sure community consensus was reached and if so, please re-open this task and link to the discussion.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptApr 23 2018, 11:53 AM
Helmoony reopened this task as Open.Apr 26 2018, 6:48 PM
Helmoony removed a project: Wikimedia-Site-requests.
Helmoony updated the task description. (Show Details)

@Urbanecm , I removed community approval tag, but it seems related somewhere with Wikimedia-Site-requests. Thank you for the review.

@Helmoony Oh, I understand. The Wikimedia-Site-requests tag is a tag that should be added every time when a task is about "change the configuration of MediaWiki" or similar things (do not develop something new, but just change the behaiviour of existing things). Each project can have one or more columns that express something about the task's status. For example, there's "To Deploy" column that means everything is ready for deployment (the task is almost done). Another column is "Blocked on community consensus". If you want to change the column, you can use the "Add action" dropdown menu, select "Move on Workboard" and choose the column you want the task to be in. I hope it is more clear to you.

@TerraCodes What's the task's status? Do you still work on this task? I can see it was deployed and reverted, any issues I can try to help with? We really should move this forward.

TerraCodes removed TerraCodes as the assignee of this task.Jun 14 2018, 8:13 AM
TerraCodes added a subscriber: TerraCodes.

@Urbanecm Do you want to claim the task? Or can you refer us to someone?

Disclaimer: I'm not familiar with FlaggedRevs and I'm only reading through docs in past 10 minutes. Don't take my comments as absolute truth.

Actually I'm not sure that's possible. I apparently can disable FlaggedRevs on all namespaces but the main one by modifying wgFlaggedRevsNamespaces, but that's what @TerraCodes did by not understanding the task and what the community do not want. If you want, you can read through the docs and tell me what variable you think should be changed to what value. The current configuration file for flaggedrevs is on https://noc.wikimedia.org/conf/highlight.php?file=flaggedrevs.php. So I don't want to claim this task, because I don't know how to process it. Every change on any ticket in Wikimedia-Site-requests is notified to almost 40 users, so no need to specifically call for people I think.

alanajjar added a subscriber: aaron.EditedSep 5 2018, 12:39 PM

@aaron helped previously T21332#233026 to remove File Namespace (NS:6) and to add Portal (NS:100) and Annex (NS:104) Namespaces.

So, probably he can help to limit the flagged revision to Main/Article Namespace (NS:0) only?

} elseif ( $wgDBname == 'arwiki' ) {
	$wgFlaggedRevsWhitelist = [ 'الصفحة_الرئيسية' ];
	$wgFlaggedRevsNamespaces = array_merge( $wgFlaggedRevsNamespaces, [ 100, 104 ] ); // T21332

https://noc.wikimedia.org/conf/highlight.php?file=flaggedrevs.php

aaron added a comment.Oct 2 2018, 3:40 AM

It looks like there is no way to say "Level 2 (reviewed for quality) is not allowed as a tag on pages outside namespace 0". Right, now, I suppose it is just convention that reviewers only mark template revisions as at level 1 (basic review). If $wgFlaggedRevsTags included a 'namespaces' field with (NS => level) as the value (defaulting to all of $wgFlaggedRevsNamespaces at the highest level, the status quo), then this could be configured.