Page MenuHomePhabricator

Qunit tests for MultimediaViewer fail with the currently submitted code
Closed, ResolvedPublic

Description

https://gerrit.wikimedia.org/r/#/c/321097/ contains a change that only changes some text in the unit test descriptions. Still, the QUnit run fails. Continuous integration tests should work for submitted code.

Event Timeline

Strainu created this task.Nov 12 2016, 10:55 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 12 2016, 10:55 AM
TheDJ added a subscriber: Tgr.Nov 12 2016, 10:58 AM
TheDJ added a subscriber: TheDJ.
hashar renamed this task from Unit tests for MultimediaViewer fail with the currently submitted code to Qunit tests for MultimediaViewer fail with the currently submitted code.Nov 13 2016, 9:08 PM
hashar updated the task description. (Show Details)

That is the QUnit tests that are failing most probably due to a breaking change in MediaWiki. It should be quite easy to reproduce.

Looking at https://gerrit.wikimedia.org/r/#/q/project:mediawiki/extensions/MultimediaViewer

https://gerrit.wikimedia.org/r/#/c/316706/ passed on October 19th

https://gerrit.wikimedia.org/r/#/c/318066/ by @Gilles failed on October 26th.

  • One can run the QUnit tests with MediaWiki core at both dates and see what happens then bisect and find out the commit that caused the regression.
  • Maybe it is an issue with a new Chromium version
jhobs triaged this task as Normal priority.Nov 14 2016, 6:17 PM
jhobs moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.

@jhobs Would you please indicate what this task needs to get out of Needs Analysis? :)

@jhobs Would you please indicate what this task needs to get out of Needs Analysis? :)

We're running some rechecks on the gerrit patches now. If Jenkins still reports failures, then we'll investigate if these can be reproduced locally. If Jenkins passes, then we should be able to decline this as a sporadic failure.

Both CI rechecks failed with the same assertion error:

mmv.Config shouldShowStatusInfo FAILED
  Status info is not shown when MMV is enabled
  Expected: false
  Actual: true

Might be an issue with Chrome local storage or most probably an incompatible change in MediaWiki core.

Change 319478 had a related patch set uploaded (by Gergő Tisza):
[WIP] Fix broken test

https://gerrit.wikimedia.org/r/319478

Change 322397 had a related patch set uploaded (by Gergő Tisza):
Fix broken tests

https://gerrit.wikimedia.org/r/322397

Change 319478 merged by jenkins-bot:
Fix broken tests

https://gerrit.wikimedia.org/r/319478

Change 322397 merged by jenkins-bot:
Fix broken tests

https://gerrit.wikimedia.org/r/322397

hashar assigned this task to Tgr.Nov 19 2016, 8:22 PM

Looks like @Tgr aced it entirely. Root cause seems to be related to a MediaWiki core change T146432.

Tgr closed this task as Resolved.Nov 21 2016, 10:06 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptMar 6 2018, 11:47 PM