Page MenuHomePhabricator

@ReleaseTaggerBot stops working if a repo has no wmf branches
Open, MediumPublic

Description

@ReleaseTaggerBot seems to have stopped working. I can't see any activity since Friday, 18 November. Is it possible to have it restarted or has it been disabled for a reason? Thanks.

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 27 2016, 4:57 PM

Seems to be a configuration confusion issue.

https://phabricator.wikimedia.org/diffusion/MREL/browse/master/make-wmf-branch/config.json reports ElectronPdfService should use wmf-style branches (https://phabricator.wikimedia.org/rMREL9717d1fd547f5265f17003505f5ae67354672b9b), but project mediawiki/extensions/ElectronPdfService does not have any wmfXX tags. Result: a crashing bot.

Whether the best solution is to revert the MREL change, to create a wmf branch, or to change releasetaggerbot... @Jdforrester-WMF / @Addshore , what are your ideas?

We should fix the bot to gracefully handle repositories with no wmf branches...there will be a short gap in which a repository is added to the list and when the next wmf branch is created, in this case it was just prolonged because there was no deploy this week.

Mentioned in SAL (#wikimedia-operations) [2016-11-27T21:47:34Z] <legoktm> created wmf/1.29.0-wmf.3 branch pointing at master for mediawiki/extensions/ElectronPdfService to workaround T151725

Bot is working again :)

Aklapper renamed this task from @RelaseTaggerBot not working since 18 November to @ReleaseTaggerBot not working since 2016-11-18.Nov 28 2016, 12:54 PM
Jdforrester-WMF renamed this task from @ReleaseTaggerBot not working since 2016-11-18 to @ReleaseTaggerBot stops working if a repo has no wmf branches.Nov 28 2016, 6:27 PM
Jdforrester-WMF triaged this task as Medium priority.