Turn off patrolling in ruwiki
Closed, InvalidPublic

Restricted Application added subscribers: Base, Aklapper. · View Herald TranscriptDec 29 2016, 2:22 PM

I'm looking at the files and I don't see patrolling enabled for ruwiki. The automatic edit patrol done by sysops is not removable I think.

Base added a comment.Dec 31 2016, 2:45 PM

What happens to the new page patrol logs and patroller flag related user right log entries in case the task is resolved?

So you wish to unassign autopatrol from all users?

@MarcoAurelio Old patrolling is enabled for files, wgUseFilePatrol in IS.

So you wish to unassign autopatrol from all users?

Exactly.

What happens to the new page patrol logs and patroller flag related user right log entries in case the task is resolved?

I think nothing. History can't be changed as well as logs.

So you wish to unassign autopatrol from all users?

Exactly.

Was this discussed at ruwiki?

No, I didn't thought it should be discussed.

I think it should. Also please discuss if you wish to disable the old-style file patrolling too (it seems to be handled in FlaggedRevs too).

But https://ru.wikipedia.org/wiki/special:listgrouprights says that patrol right withdrawn from all usergroups, including admins.

Strange, I can't see it in config files... For example https://bg.wikipedia.org/wiki/Специални:Групови_права doesn't show autopatrol at all for the sysop group.

What a mess :-)

  • Sysops at ruwiki have patrol and autopatrol permissions. Both are (IIRC) standard in mediawiki core.
  • wgUseRCPatrol is set to false by default, and there's no override for ruwiki. Not the problem.
  • wgUseNPPatrol is set to true by default but ruwiki has set it to false. Not the problem.
  • wgUseFilePatrol is set to true by default, only huwiki has opted-out. This might need to be turned off.

My idea is, so far, this:

1diff --git a/wmf-config/InitialiseSettings.php b/wmf-config/InitialiseSettings.php
2index 6585c9e..9323903 100644
3--- a/wmf-config/InitialiseSettings.php
4+++ b/wmf-config/InitialiseSettings.php
5@@ -7058,6 +7058,7 @@ $wgConf->settings = [
6​ 'wgUseFilePatrol' => array(
7​ 'default' => true,
8​ 'huwiki' => false, // T21241
9+ 'ruwiki' => false, // T154285
10​ ),
11
12​ # wgNoFollow... @{
13@@ -8652,32 +8653,31 @@ $wgConf->settings = [
14​ ],
15​ ],
16​ '+ruwiki' => [
17- '*' => [ 'patrolmarks' => true, ],
18+ '*' => [
19+ 'patrolmarks' => true,
20+ ],
21+ 'arbcom' => [ // T51334
22+ 'abusefilter-log-detail' => true,
23+ 'browsearchive' => true,
24+ 'deletedhistory' => true,
25+ 'deletedtext' => true,
26+ ],
27​ 'autoconfirmed' => [
28​ 'collectionsaveascommunitypage' => false, // T85780
29​ ],
30​ 'bot' => [
31- 'move-categorypages' => true, // T87230
32+ 'autopatrol' => false, // T154285
33​ 'changetags' => true, // T136187
34- ],
35- 'rollbacker' => [ 'rollback' => true ],
36- 'uploader' => [ // T14334
37- 'upload' => true,
38- 'reupload-own' => true,
39- 'reupload' => true,
40- ],
41- 'user' => [ // T68871
42- 'move-categorypages' => false,
43- 'changetags' => false, // T136187
44+ 'move-categorypages' => true, // T87230
45​ ],
46​ 'closer' => [
47- 'move-categorypages' => true, // T68871
48​ 'delete' => true,
49+ 'move-categorypages' => true, // T68871
50+ 'move-subpages' => true, // T76131
51+ 'reupload' => true,
52+ 'reupload-own' => true,
53​ 'suppressredirect' => true,
54​ 'upload' => true,
55- 'reupload-own' => true,
56- 'reupload' => true,
57- 'move-subpages' => true, // T76131
58​ ],
59​ 'engineer' => [ // T144599
60​ 'apihighlimits' => true,
61@@ -8694,26 +8694,35 @@ $wgConf->settings = [
62​ 'suppressredirect' => true,
63​ ],
64​ 'filemover' => [ // T32984
65+ 'move-categorypages' => true, // T68871
66+ 'move-subpages' => true, // T76131
67​ 'movefile' => true,
68+ 'reupload' => true,
69+ 'reupload-own' => true,
70​ 'suppressredirect' => true,
71​ 'upload' => true,
72+ ],
73+
74+ 'uploader' => [ // T14334
75+ 'upload' => true,
76​ 'reupload-own' => true,
77​ 'reupload' => true,
78- 'move-categorypages' => true, // T68871
79- 'move-subpages' => true, // T76131
80+ ],
81+ 'user' => [ // T68871
82+ 'changetags' => false, // T136187
83+ 'move-categorypages' => false,
84+ ],
85+ 'rollbacker' => [
86+ 'rollback' => true
87​ ],
88​ 'suppressredirect' => [ // T40408, T68871
89- 'suppressredirect' => true,
90​ 'move-categorypages' => true,
91- ],
92- 'arbcom' => [ // T51334
93- 'browsearchive' => true,
94- 'deletedhistory' => true,
95- 'deletedtext' => true,
96- 'abusefilter-log-detail' => true,
97+ 'suppressredirect' => true,
98​ ],
99​ 'sysop' => [
100+ 'autopatrol' => false, // T154285
101​ 'changetags' => true, // T136187
102+ 'patrol' => false, // T154285
103​ ],
104​ ],
105​ 'ruwikiquote' => [
where we remove from bots the autopatrol right and the patrol and autopatrol right from sysops (plus I ordered everything in alphabetical order). Let me know if that would work.

Urbanecm updated the task description. (Show Details)Jan 1 2017, 9:29 AM

@MaxBioHazard Thanks for the link.

@MarcoAurelio At least it should stop patrol anything from my POV and stop old patrol events appear in logs (as they won't exist).

putnik added a subscriber: putnik.Jan 11 2017, 1:16 PM

The discussion ended, all users voted for a full disable of old-style patrolling (including files).

Change 331605 had a related patch set uploaded (by Urbanecm):
Turn off patrolling in ruwiki

https://gerrit.wikimedia.org/r/331605

Okay, I've uploaded a patch for this to gerrit based on the on from @MarcoAurelio. I'll deploy it today.

Urbanecm claimed this task.Jan 11 2017, 1:24 PM
Urbanecm triaged this task as Normal priority.
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptJan 11 2017, 1:25 PM
Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.Jan 11 2017, 1:25 PM

What means

'+ruwiki' => [
		'*' => [
			'patrolmarks' => true,
		],

that remains in new code? If this is a right to see patrol marks, maybe it should be disabled too?

Yes, you're right. It means View recent changes patrol marks. I'll disable it.

Change 331605 merged by jenkins-bot:
Turn off patrolling in ruwiki

https://gerrit.wikimedia.org/r/331605

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2017-01-11T14:11:43Z] <hashar@tin> Synchronized wmf-config/InitialiseSettings.php: Import source on bd.wikimedia.org T154990 + Turn of patrolling on ruwiki T154285 (duration: 00m 42s)

Urbanecm closed this task as Resolved.Jan 11 2017, 2:13 PM

It seems FlaggedRevs mark every edit reviewed by this tool as patrolled using the old way.

"Patrolling of reviewable pages is disabled, but flagged revisions are marked as patrolled in Recent Changes. This will mean that the only way to patrol a reviewable revision is to flag it. Non-reviewable pages still behave as normal (depending on site patrol settings). " confirm it.

Urbanecm moved this task from To deploy to Backlog on the User-Urbanecm board.Jan 14 2017, 5:17 PM
Urbanecm moved this task from Backlog to Working on on the User-Urbanecm board.Jan 17 2017, 5:39 PM

Can this behaviour be changed? By adding an option to extension options or just removing this functionality?

Urbanecm closed this task as Invalid.Feb 6 2017, 10:12 AM

@MaxBioHazard Sadly not currently. The extension doesn't allow to turn it off per wiki so I can't change it just for ruwiki. Closing it as invalid because requested action can't be done.

You can create new ticket under MediaWiki-extensions-FlaggedRevs and ask the developers to add this feature as a feature request.