Reindex el, en, fr and he wikis to enable ICU folding
Closed, ResolvedPublic

Description

ICU folding is now available, we now just need to reindex the wikis where we decided to activate it:
For now the list is :

  • English wikis (desperately needed for wiktionary)
  • French wikis (likely needed for wiktionary)
  • Hebrew wikis (afaik. mostly needed for wikisource)
  • Greek wikis (greek stress marks including ancient ones)

More languages may come in the future but we need to figure out some details before.
There won't be any patch attached to this task but when this task is marked resolved the ICU folding features should be enabled and available on these wikis.

For context please read the following tasks: T132637, T3836, T75605.
The discussions around ICU folding have been spread out over a long a period of time and into many tasks that it's now hard for me to retrieve all the users that may be interested in being a subscriber of this task.

dcausse created this task.Jan 17 2017, 6:50 PM
Restricted Application added a project: Discovery. · View Herald TranscriptJan 17 2017, 6:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
CKoerner_WMF edited subscribers, added: CKoerner_WMF; removed: Ckoerner.Jan 17 2017, 6:56 PM
Deskana triaged this task as Normal priority.Jan 20 2017, 11:31 PM

Change 333863 had a related patch set uploaded (by DCausse):
[cirrus] properly set wgCirrusSearchUseIcuFolding

https://gerrit.wikimedia.org/r/333863

Change 333863 merged by jenkins-bot:
[cirrus] properly set wgCirrusSearchUseIcuFolding

https://gerrit.wikimedia.org/r/333863

Mentioned in SAL (#wikimedia-operations) [2017-01-24T14:23:21Z] <dcausse@tin> Synchronized wmf-config/InitialiseSettings.php: T155515 [cirrus] properly set wgCirrusSearchUseIcuFolding (duration: 00m 39s)

I have to delay the reindex, activation of the feature caused an issue in elasticsearch (see subtask), I'll have to investigate the cause and find a workaround before activating ICU on these wikis, sorry about that but this was totally unexpected.

Change 337423 had a related patch set uploaded (by DCausse):
[cirrus] properly set wgCirrusSearchUseIcuFolding

https://gerrit.wikimedia.org/r/337423

Change 337423 merged by jenkins-bot:
[cirrus] properly set wgCirrusSearchUseIcuFolding

https://gerrit.wikimedia.org/r/337423

Mentioned in SAL (#wikimedia-operations) [2017-02-13T19:11:01Z] <thcipriani@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:337423|properly set wgCirrusSearchUseIcuFolding]] T155515 (duration: 00m 41s)

dcausse closed this task as Resolved.Feb 25 2017, 5:13 PM
dcausse moved this task from Backlog to Done on the Discovery-Search (Current work) board.
dcausse reassigned this task from dcausse to EBernhardson.

The reindex was done as part of the full reindex needed for elastic5 upgrade.