Page MenuHomePhabricator

Write basic documentation for WikibaseMediaInfo extension
Closed, ResolvedPublic

Description

We want to get a review of the WikibaseMediaInfo extension. For this (but obviously not only for this) we need basic documentation for it on https://www.mediawiki.org/wiki/Extension:WikibaseMediaInfo, including:

  • Copy-paste basic page structure from an existing extensions page
  • Introduction, what the extension is about
  • Installation, setup, relevant configuration to get started
  • How to create a MediaInfo page, because this is different
  • Include a screenshot
  • Possibly a FAQ section, what can go wrong
    • Introduce the concept of "virtual" entities

Also documentation in git:

  • Readme
  • Settings

Details

Related Gerrit Patches:
mediawiki/extensions/WikibaseMediaInfo : masterSmall updates to README.md file
mediawiki/extensions/WikibaseMediaInfo : masterAdd README file

Related Objects

StatusAssignedTask
OpenNone
Declineddchen
OpenNone
OpenNone
DuplicateNone
OpenNone
ResolvedAbit
OpenNone
DuplicateNone
OpenNone
OpenNone
Resolveddaniel
ResolvedMholloway
ResolvedMholloway
OpenNone
OpenNone
ResolvedRamsey-WMF
Resolveddaniel
Resolveddaniel
InvalidTgr
Resolveddaniel
ResolvedTgr
ResolvedTgr
ResolvedTgr
ResolvedBstorm
ResolvedCCicalese_WMF
ResolvedCparle
Resolvedmatthiasmullie
Resolvedegardner
ResolvedCparle
Resolvedegardner
Resolvedmatthiasmullie
ResolvedCparle
ResolvedCparle
OpenNone
ResolvedCparle
ResolvedJdforrester-WMF
OpenNone
OpenWMDE-leszek
ResolvedWMDE-leszek
ResolvedNone
ResolvedCparle
ResolvedJdforrester-WMF
ResolvedCparle
Resolvedmatthiasmullie
Resolvedmatthiasmullie
ResolvedCparle
Resolvedmatthiasmullie
Resolvedmatthiasmullie
Resolvedmatthiasmullie
Resolvedmatthiasmullie
Resolvedmatthiasmullie
ResolvedCparle
Resolvedegardner
OpenNone
OpenNone
Resolvedmatthiasmullie
Resolvedegardner
ResolvedRamsey-WMF
ResolvedEdtadros
ResolvedEdtadros
ResolvedEdtadros
ResolvedHa78na
OpenNone
OpenCparle
ResolvedCparle
ResolvedCparle
ResolvedCparle
ResolvedCparle
OpenNone
OpenCparle
ResolvedCparle
ResolvedCparle
OpenNone
DuplicateCparle
ResolvedCparle
ResolvedCparle
OpenNone
Resolvedmatthiasmullie
OpenNone
Resolvedmatthiasmullie
ResolvedEBernhardson
ResolvedRamsey-WMF
Resolvedmatthiasmullie
Resolvedmatthiasmullie
Resolvedmatthiasmullie
Resolvedmatthiasmullie
ResolvedCparle
OpenNone
Openmatthiasmullie
Resolvedmatthiasmullie
OpenNone
Openmatthiasmullie
ResolvedRamsey-WMF
ResolvedCparle
ResolvedRamsey-WMF
Resolvedthiemowmde
ResolvedMarkTraceur
Resolvedmatthiasmullie
Resolvedmatthiasmullie
ResolvedCparle
DeclinedCparle
DeclinedCparle
DeclinedCparle
ResolvedCparle
ResolvedEdtadros
OpenNone
ResolvedRamsey-WMF
InvalidNone
OpenNone
OpenCparle
ResolvedCparle
ResolvedRamsey-WMF
ResolvedCCicalese_WMF
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedBawolff
ResolvedWMDE-leszek
ResolvedWMDE-leszek

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 6 2017, 2:46 PM
thiemowmde updated the task description. (Show Details)Mar 7 2017, 2:54 PM
thiemowmde added subscribers: thiemowmde, WMDE-leszek, aude and 4 others.
WMDE-leszek moved this task from Backlog to Doing on the Wikidata-Former-Sprint-Board board.

Change 347366 had a related patch set uploaded (by WMDE-leszek):
[mediawiki/extensions/WikibaseMediaInfo@master] Add README file

https://gerrit.wikimedia.org/r/347366

I've created some basic documentation, including installation and configuration notes.
The documentation has been put into README.md file (https://gerrit.wikimedia.org/r/347366), and almost identically reproduced at https://www.mediawiki.org/wiki/Extension:WikibaseMediaInfo.

README gerrit patch, and the Mediawiki page are ready to be reviewed.

Regarding few things the tickets lists, several remarks:

  • How to create a MediaInfo page, because this is different -> currently no specific section in the docs, although it is mentioned. If required, there could be covered in a more elaborate way.
  • Include a screenshot -> no screenshot of mw.org so far. I could go and make a screenshot e.g. of http://structured-commons.wmflabs.org/wiki/MediaInfo:M13. Some concerns:
    • "No label defined (M13)" is not really representative.
    • Also there would be no actual "picture" on the screenshot. It might not be something bad, just want to make it clear.
  • Possibly a FAQ section, what can go wrong -> I don't really know what to put there, so no FAQ so far.

Change 347366 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Add README file

https://gerrit.wikimedia.org/r/347366

WMDE-leszek updated the task description. (Show Details)Apr 12 2017, 8:15 AM
WMDE-leszek moved this task from Review to Backlog on the Wikidata-Former-Sprint-Board board.

So the basic documentation at mediawiki.org is there. Still no screenshot - suggestion what to include on it are welcome!
Also no FAQ section but I am not sure if there is a need to have right now.

Change 347833 had a related patch set uploaded (by Thiemo Mättig (WMDE)):
[mediawiki/extensions/WikibaseMediaInfo@master] Small updates to README.md file

https://gerrit.wikimedia.org/r/347833

Change 347833 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Small updates to README.md file

https://gerrit.wikimedia.org/r/347833

WMDE-leszek closed this task as Resolved.Apr 18 2017, 3:49 PM
WMDE-leszek updated the task description. (Show Details)
WMDE-leszek moved this task from Backlog to Done on the Wikidata-Former-Sprint-Board board.

No need for FAQ at this point has been recognized. Screen cap added. Some more polishing of installation instructions, and minor changes to other section of the page.
With all that, this task is considered done.