Page MenuHomePhabricator

Remove of Vector indent causes ULS cog to be incorrectly positioned
Closed, ResolvedPublic

Description

T67444 caused a regression such that the ULS cog is positioned incorrectly in the sidebar. @Nikerabbit is looking how to fix this, but he might need help figuring out how to make the positioning more generic, or how to detect presence of this change reliably, or have this change reverted before next deployment train if no fix is ready at at that time.

https://en.wikipedia.beta.wmflabs.org/wiki/Language_test

Before:


After:

Event Timeline

Jdlrobson created this task.Apr 6 2017, 5:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 6 2017, 5:45 PM

Change 346752 had a related patch set uploaded (by Jdlrobson; owner: Nikerabbit):
[mediawiki/extensions/UniversalLanguageSelector@master] Try to make cog positioning more robust

https://gerrit.wikimedia.org/r/346752

Jdlrobson triaged this task as Normal priority.Apr 10 2017, 5:53 PM

This was discussed in the daily meeting yesterday, where I explained that there is a patch that works and has been tested (it has -1 from Krinkle with suggestions to make the code better). It was decided that if someone feels like it is important and doesn't need much time to review it, they can do it. But unless it is SWATed on this Thursday, the next possible deployment is SWAT on Monday 24th. If that does not happen, then there is plenty of time to redo the patch.

Amire80 claimed this task.May 3 2017, 6:43 AM

Change 346752 merged by jenkins-bot:
[mediawiki/extensions/UniversalLanguageSelector@master] Correct alignment of cog in interlanguage links in Vector skin

https://gerrit.wikimedia.org/r/346752

Nikerabbit moved this task from Backlog to QA on the Language-2018-July-September board.
Nikerabbit added a subscriber: Amire80.

This was a patch that I updated when going over my old open patches. Amir had worked on it in between, but didn't finish, and due to changing requirements it was now only one line change.

Etonkovidova closed this task as Resolved.Sep 20 2018, 1:26 AM
Etonkovidova added a subscriber: Etonkovidova.

Checked in cawiki (wmf.22) - the fix is in place.