Page MenuHomePhabricator

Some messages should be updated due to "Save" => "Publish"
Closed, ResolvedPublic

Description

The following system messages should be updated from "{{int:savearticle}}" to "{{int:publishchanges}}" OR "{{int:publishpage}}":

Event Timeline

Guycn2 created this task.May 8 2017, 5:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 5:13 PM
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM

Anyone working on this would have to provide two patches for the files i18n/en.json in the LiquidThreads and GuidedTour Git repositories...

Deskana renamed this task from Some messages should be updated due to "Save" => "Publish" to VisualEditor.Aug 30 2018, 1:31 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptAug 30 2018, 1:31 PM
Deskana renamed this task from VisualEditor to Some messages should be updated due to "Save" => "Publish".Aug 30 2018, 1:42 PM

@Jdforrester-WMF When should {{int:publishchanges}} vs. {{int:publishpage}} be used?

@Jdforrester-WMF When should {{int:publishchanges}} vs. {{int:publishpage}} be used?

{{int:publishchanges}} is for when the user is changing a page that already existed; {{int:publishpage}} is when they are creating a page from scratch. In the context of GuidedTour, I think that those would suffice; for LQT, perhaps a new message would be needed for "publish post", "publish topic", etc., or you could just always use {{int:publishchanges}} depending on product desire.

Change 460077 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/GettingStarted@master] Use "Publish changes" instead of "Save changes"

https://gerrit.wikimedia.org/r/460077

Change 460090 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/LiquidThreads@master] Use "publish" instead of "save" for summary page

https://gerrit.wikimedia.org/r/460090

SBisson claimed this task.Sep 12 2018, 8:19 PM
SBisson edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
SBisson moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

Change 460090 merged by jenkins-bot:
[mediawiki/extensions/LiquidThreads@master] Use "publish" instead of "save" for summary page

https://gerrit.wikimedia.org/r/460090

Change 460077 merged by jenkins-bot:
[mediawiki/extensions/GettingStarted@master] Use "Publish changes" instead of "Save changes"

https://gerrit.wikimedia.org/r/460077

Etonkovidova added a subscriber: Etonkovidova.EditedSep 19 2018, 9:58 PM

@SBisson why the following messages have ""Aldaketak argitaratu"" text (it's Basque) ? "Aldaketak argitaratu" will be displayed for any language .

"lqt-update-summary-intro": "Please summarize the below thread in the editing box.\nYou may use any wikitext in your summary.\nWhen you finish, click \"{{int:publishchanges}}\".

https://translatewiki.net/wiki/MediaWiki:Guidedtour-tour-firstedit-save-description/en

MediaWiki:Guidedtour-tour-firstedit-save-description/en
When you're ready, clicking "Aldaketak argitaratu" will make your changes visible for everyone.

https://translatewiki.net/wiki/MediaWiki:Guidedtour-tour-gettingstarted-click-save-description/en

MediaWiki:Guidedtour-tour-gettingstarted-click-save-description/en
Click "Aldaketak argitaratu" and your changes will be visible.

The another message is displayed correctly:

"lqt-summarize-intro": "Please summarize the below thread in the editing box.\nYou may use any wikitext in your summary.\nWhen you finish, click \"{{int:publishpage}}\"."

https://translatewiki.net/wiki/MediaWiki:Lqt-summarize-intro/en
MediaWiki:Lqt-summarize-intro/en
Please summarize the below thread in the editing box. You may use any wikitext in your summary. When you finish, click "Publish page".

@SBisson why the following messages have ""Aldaketak argitaratu"" text (it's Basque) ? "Aldaketak argitaratu" will be displayed for any language .

It turns out there was an incorrect local translation of publishchanges on translatewiki.net. @Nikerabbit fixed it.

Also, be aware that {{int:publishchanges}} will be rendered using your interface language on TWN so that can be different than the language of the message you are looking at but that's ok.

Etonkovidova closed this task as Resolved.Sep 20 2018, 4:42 PM