Editing references (cite web) through Visual Editor just got more complicated
Closed, ResolvedPublic1 Story Points

Description

Somehow, the workflow for editing footnotes that make use of the "citeer web" template on nlwiki (equivalent of "cite web") changed in the past 24 hours. This may also apply to other projects, but I cannot confirm whether the old situation was the same there.

Before this change, you could simply edit the fields of "citeer web" by clicking on the footnote number in the text, and a popup with the fields would appear. This has now changed to a situation where a popup with the reference text appears. This reference text is still produced by "citeer web", but to edit those fields, you have to click on the text and then edit the template fields in yet another popup.

That is two popups on top of each other, without a clear direction that you have to take this second step. It is easy to try to edit the text as if it is raw text, this is a confusing situation for editors.

I don't know if this is caused by a change in software or locally - but at least the template itself was not edited. Example available on https://nl.wikipedia.org/wiki/Gebruiker:Effeietsanders/Kladblok if you want to try it out.

Template used: https://nl.wikipedia.org/wiki/Sjabloon:Citeer_web

Restricted Application added a project: VisualEditor. · View Herald TranscriptJun 30 2017, 9:52 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I do not understand which change could have caused this, but it definitely is a regression introduced with 1.30.0-wmf.7. There is one change to detecting template names, rEVED624211a60f52: Use Parsoid data for template names rather than detect from wikitext, though this actually shouldn't break anything. I can also see that there were some confusions about whether references are wrapped in paragraphs or not, rECITca45349b840f: Update ve.ui.MWWikitextStringTransferHandler.test results for <p> wrapping and related, so if the code is looking on the wrong element for the template name, this could be the cause of this bug.

Esanders triaged this task as Unbreak Now! priority.Jul 3 2017, 4:07 PM
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptJul 3 2017, 4:07 PM

Looks like it was @matmarex's fix, locally it's trying to compare "Cite web" to "Cite web\n".

Change 363026 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Noramlize to template namespace when comparing

https://gerrit.wikimedia.org/r/363026

Change 363026 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Normalize to template namespace when comparing

https://gerrit.wikimedia.org/r/363026

Deskana closed this task as Resolved.Jul 3 2017, 5:56 PM
Deskana assigned this task to Esanders.
Deskana set the point value for this task to 1.
Deskana added a subscriber: Deskana.

This will be deployed on Thursday.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 3 2017, 5:56 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Specifically, Thursday 13 July.