Live preview does not show the preview of the summary anymore
Closed, ResolvedPublic

Description

Live preview does not show the preview of the summary anymore.

97d7de0b84ef65094108fbcf62ffcc1c55d75345 is responsible for this.

Fomafix created this task.Jul 20 2017, 9:33 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 20 2017, 9:33 AM

Change 366570 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] Live Preview: Cope with the edit summary being an OOjs UI widget

https://gerrit.wikimedia.org/r/366570

The summary is still POSTed to the server and the parsed summary is in the response. The problem is in attaching the result into the DOM:

$( '#wpSummary' ).after(
	$( '<div>' ).addClass( 'mw-summary-preview' )
);

does not work anymore with OOjs UI.

TheDJ added a subscriber: TheDJ.Jul 24 2017, 9:25 AM

Should also be tested for "New section"-flow.

Jdforrester-WMF triaged this task as Normal priority.Aug 2 2017, 12:57 AM
Jdforrester-WMF claimed this task.
matmarex closed this task as Resolved.Aug 9 2017, 8:49 PM
matmarex removed a project: Patch-For-Review.

Change 366570 merged by jenkins-bot:
[mediawiki/core@master] Live Preview: Cope with the edit summary being an OOjs UI widget

https://gerrit.wikimedia.org/r/366570