Page MenuHomePhabricator

'Latest revision' + 'Logged actions' filters don't display Deleted pages on Watchlist and Recent Changes
Closed, ResolvedPublic

Description

Feedback from English Wikipedia: "I want to see deletions combined with edits like I'm currently able to do in my watchlist, I should be able to have that as a setting without having to change the filters every time."

I understand the idea here: I see deletions in my watchlist when not using the Beta, so I also expect to have it when using the default filters. Also the lastest edit to a page is obviously the log entry, in my mind at least.

Also see the discussion on MediaWiki.org: https://www.mediawiki.org/wiki/Topic:Tyiluei3if8nn89e

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 20 2017, 4:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Trizek-WMF updated the task description. (Show Details)Sep 20 2017, 4:53 PM
Stryn added a subscriber: Stryn.Sep 20 2017, 4:55 PM

The legacy "extended" filter had a special case to include log entries and other non-revision rc types (like Flow). This behavior was kept for this filter but was not reproduced for it's structured replacement (lastRevision).

ORES + Log actions is somewhat similar and we mark it as a conflict.

It looks like some log entries (page moved?) have a page revision associated and will be included by the lastRevision filter. Maybe page deleted doesn't and that's something to look at?

Flow has its own storage (not the page table) so the lastRevision filter cannot work with it. It is possible to make it work but it's more work than fine tunning an existing filter.

jmatazzoni renamed this task from Lastest filters + Logged actions filters don't display Deleted pages on Watchlist to 'Latest revision' + 'Logged actions' filters don't display Deleted pages on Watchlist.Sep 20 2017, 10:28 PM

In T176328#3622106, @SBisson wrote:

The legacy "extended" filter had a special case to include log entries and other non-revision rc types (like Flow). This behavior was kept for this filter but was not reproduced for it's structured replacement (lastRevision).

We should provide feature parity with the old UX. I can't test this on Watchlist because I don't have a big enough Watchlist. But on Recent Changes, Logged Actions + Latest Revision appears to work fine for many types of actions (uploads, moves, protections); I just don't see any deletions. So, two questions: 1) is that the user's complaint, and 2) is Watchlist a special case, or should we fix for RC page as well?

It looks like some log entries (page moved?) have a page revision associated and will be included by the lastRevision filter. Maybe page deleted doesn't and that's something to look at?

See above. Yes, that's what I see too.

Flow has its own storage (not the page table) so the lastRevision filter cannot work with it. It is possible to make it work but it's more work than fine tunning an existing filter.

  1. So are you saying that Flow has never worked with Latest Revisions, or "extended," whatever that was? If that is true, we should put it on the Flow board for consideration, but it doesn't need to be an immediate fix, I think.
  2. (Flow is not mentioned in this ticket; is this what the complaint is about in T176329?)

Change 379614 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/core@master] RCFilters: Make 'lastRevision' filter include non-rev types

https://gerrit.wikimedia.org/r/379614

jmatazzoni renamed this task from 'Latest revision' + 'Logged actions' filters don't display Deleted pages on Watchlist to 'Latest revision' + 'Logged actions' filters don't display Deleted pages on Watchlist and Recent Changes.Sep 21 2017, 8:56 PM

I changed the title to say "....Watchlist and Recent Changes," because that is what we said in the meeting today. Just confirming that this is correct.

The patch above makes 'lastRevision' work like 'extended'. I believe this is the source for T176328 and T176329 as this change of behavior is seen as a regression.

Other aspects should made explicit in their own tickets.

I changed the title to say "....Watchlist and Recent Changes," because that is what we said in the meeting today. Just confirming that this is correct.

That is correct. 'last revision' filter exists on both RC and WL and behaves the same everywhere.

Change 379614 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Make 'lastRevision' filter include non-rev types

https://gerrit.wikimedia.org/r/379614

Checked in betalabs. In short, 'Latest revision' will show log actions on a page (move, protect, delete).

  • 'Latest revision' + 'Logged actions' filter combination will display 'Deletion log' aciton along with other logged actions on pages and, of course, any latest page edits.

  • Checked the specific combinations mentioned in Feedback from English Wikipedia

    'Changes by others' + 'Latest revision' + 'Page edits' + 'Page creations' + 'Logged actions' displays the 'Deletion log' actions

Note 'Page edits' will not include those log actions, which is correct.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Sep 25 2017, 5:38 PM