Page MenuHomePhabricator

Prevent showing CentralNotice on History/Diff pages to partially resolve banner-bump issues
Closed, ResolvedPublic

Description

Problem: As an editor who is looking at [Special:Watchlist/Special:RecentChanges/Special:Contributions/Special:Log or History or Diff] pages, the delayed banner-bump of CentralNotice appearing, sometimes causes me to mis-click on "rollback", sometimes without realizing it.

Suggested solution: Prevent showing CentralNotice on Special pages (either just these 4 types if possible, or everywhere), and on history/diff pages.

Notes: These are also the only pages (?) to contain the 1-click rollback links. These are also among the most link-dense pages we have, hence mis-clicking is more likely than elsewhere.


(Filed based on ongoing discussion at https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#Pages_jumping_around_while_loading and some historic reports of the same problem.)

See also:

Event Timeline

Quiddity created this task.Sep 25 2017, 5:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2017, 5:57 PM
Jseddon triaged this task as Lowest priority.Sep 25 2017, 6:53 PM
Jseddon claimed this task.

As of 4439645ece32 (June 2016) no banners have been shown on any Special or Edit page.

Cause is likely to user, site or other css or js scripts/gadgets etc

Jseddon closed this task as Declined.Sep 25 2017, 7:09 PM
Quiddity changed the task status from Declined to Invalid.Sep 25 2017, 7:19 PM
Pcoombe reopened this task as Open.Sep 25 2017, 11:09 PM
Pcoombe added a subscriber: Pcoombe.

The current code spares Special pages and editing from CentralNotice, but not history or diffs. Reopening, as I think hiding on both of these would be a good idea because of the potential for misclicks on rollback links.

(I believe T32009 is unrelated, and refers to incorporating Special:CentralNoticeLogs with other logs.)

Base added a subscriber: Base.Sep 26 2017, 12:45 AM
Quiddity removed Jseddon as the assignee of this task.Sep 26 2017, 1:34 AM
Quiddity added a subscriber: Jseddon.

Change 380891 had a related patch set uploaded (by Pcoombe; owner: Pcoombe):
[mediawiki/extensions/CentralNotice@master] Don't load CentralNotice on history or diff pages

https://gerrit.wikimedia.org/r/380891

Pcoombe claimed this task.Sep 26 2017, 10:29 PM
Quiddity renamed this task from Prevent showing CentralNotice on Special pages and History/Diff pages to partially resolve banner-bump issues to Prevent showing CentralNotice on History/Diff pages to partially resolve banner-bump issues.Sep 27 2017, 3:26 AM

Change 380891 merged by jenkins-bot:
[mediawiki/extensions/CentralNotice@master] Don't load CentralNotice on history or diff pages

https://gerrit.wikimedia.org/r/380891

Pcoombe closed this task as Resolved.Feb 12 2018, 2:44 PM
Pcoombe added a subscriber: AndyRussG.

This was deployed and I confirmed it's working. Thanks @AndyRussG!