Page MenuHomePhabricator

Help communicate read-only time for Commons for schema change required by adding 3D filetype
Closed, ResolvedPublic

Description

We need to let the Commons community (and Wikimedia in general) know that there will be a short period where Commons will be read-only.

Wednesday, 11 October, starting at 6:00 UTC (07:00 BST, 08:00 CEST, 02:00 EDT, 23:00 PDT) for 30 minutes.

Event Timeline

Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptSep 27 2017, 3:33 PM

Thank you @CKoerner_WMF for managing this!
How much do we need: 30 minutes
When: What about Wednesday 11th at 6:00 UTC?

//cc @jcrespo

I looked at the actives happing on Commons and that date looks to be good. I started a draft and would appreciate input. Once approved (by whom?) I can let the Commons community (and other communities) know.

https://commons.wikimedia.org/wiki/User:CKoerner_(WMF)/Read-only_Commons_for_3D

Jseddon added a subscriber: Jseddon.Oct 2 2017, 4:17 PM

I presume a centralnotice will be required for this?

You are correct Mr @Jseddon. That would be most welcome. I just added a request on Meta. Help guiding me through the process would be appreciated. It's my first time.

https://meta.wikimedia.org/wiki/CentralNotice/Request/Update_to_Commons_database_to_prepare_for_3D_file_support#What_is_the_purpose_of_Campaign.3F_How_will_you_measure_the_success_of_the_campaign.3F

I looked at the actives happing on Commons and that date looks to be good. I started a draft and would appreciate input. Once approved (by whom?) I can let the Commons community (and other communities) know.

https://commons.wikimedia.org/wiki/User:CKoerner_(WMF)/Read-only_Commons_for_3D

I would change:
"The team needs to modify the database so it understands this new file type"
With
"The team needs to modify the database primary master so it understands this new file type"

As commons has lots of databases and only due to a mariadb bug, we cannot modify the master on the fly like with did with the rest of the hosts.
If you want more technical details on the "why?" section, just let me know and I can provide more insights :-)

Thank you!

@Marostegui Thanks for the edits. I don't think we need more technical details at this point, but that you for the offer.

Sure! Just let me know if you need anything from me :)

I've posted the message to the Commons Village Pump, wikitech-l, commons-l, and have included it in next Monday's Tech News.

https://commons.wikimedia.org/wiki/Commons:Village_pump#Read-only_Commons_in_preparation_for_3D_file_support_-_11_October

CKoerner_WMF updated the task description. (Show Details)Oct 4 2017, 9:08 PM

Thank you @CKoerner_WMF!! We'll update this ticket once we are finished with the maintenance on Wednesday!

Change 382379 had a related patch set uploaded (by Marostegui; owner: Marostegui):
[operations/mediawiki-config@master] db-eqiad.php: Set commonswiki on read only

https://gerrit.wikimedia.org/r/382379

Legoktm added a subscriber: Legoktm.Oct 5 2017, 7:50 AM

Since this ticket is about the communication...I think sending non-technical users to #wikimedia-operations is kind of a mixed bag. My experience is mostly from unplanned outages, but often it ends up with a lot of "me toos" and gets in the way of actual work. I think having non-technical users gather/communicate in #wikimedia-tech and having a more technically inclined user ferry messages across the channels works better. (Of course, there are positives to having normally wiki users in -operations since there's no middle person for communicating, and users are helpful when trying to reproduce things..so I guess YMMV, just my two cents.)

Agreeing with that^

Not a problem. I just updated the post on Commons and sent a correction to the mailing lists.

Change 382379 merged by jenkins-bot:
[operations/mediawiki-config@master] db-eqiad.php: Set commonswiki on read only

https://gerrit.wikimedia.org/r/382379

Marostegui closed this task as Resolved.Oct 11 2017, 6:20 AM

This maintenance is finished

Read only time started at: 6:01
Read only time finished at: 6:14

Total 13 minutes

Thanks @CKoerner_WMF for coordinating and helping to get this maintenance arranged.